update to 1.8.10
This commit is contained in:
parent
e8c18092cd
commit
1f329d5e7d
1
.gitignore
vendored
1
.gitignore
vendored
@ -42,3 +42,4 @@ doxygen-1.7.1.src.tar.gz
|
|||||||
/doxygen-1.8.7.src.tar.gz
|
/doxygen-1.8.7.src.tar.gz
|
||||||
/doxygen-1.8.8.src.tar.gz
|
/doxygen-1.8.8.src.tar.gz
|
||||||
/doxygen-1.8.9.1.src.tar.gz
|
/doxygen-1.8.9.1.src.tar.gz
|
||||||
|
/doxygen-1.8.10.src.tar.gz
|
||||||
|
24
doxygen-1.8.10-install.patch
Normal file
24
doxygen-1.8.10-install.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -up doxygen-1.8.10/doc/CMakeLists.txt.than doxygen-1.8.10/doc/CMakeLists.txt
|
||||||
|
--- doxygen-1.8.10/doc/CMakeLists.txt.than 2015-08-28 11:46:15.675460840 +0200
|
||||||
|
+++ doxygen-1.8.10/doc/CMakeLists.txt 2015-08-28 11:51:27.894592457 +0200
|
||||||
|
@@ -88,17 +88,17 @@ install(FILES
|
||||||
|
"${PROJECT_BINARY_DIR}/man/doxywizard.1"
|
||||||
|
"${PROJECT_BINARY_DIR}/man/doxysearch.1"
|
||||||
|
"${PROJECT_BINARY_DIR}/man/doxyindexer.1"
|
||||||
|
- DESTINATION man/man1
|
||||||
|
+ DESTINATION "${MAN_INSTALL_DIR}"
|
||||||
|
)
|
||||||
|
|
||||||
|
install(FILES
|
||||||
|
"${PROJECT_BINARY_DIR}/latex/doxygen_manual.pdf"
|
||||||
|
- DESTINATION "${CMAKE_INSTALL_PREFIX}/${DOC_INSTALL_DIR}"
|
||||||
|
+ DESTINATION "${DOC_INSTALL_DIR}"
|
||||||
|
)
|
||||||
|
|
||||||
|
install(DIRECTORY
|
||||||
|
"${PROJECT_BINARY_DIR}/html"
|
||||||
|
- DESTINATION "${CMAKE_INSTALL_PREFIX}/${DOC_INSTALL_DIR}"
|
||||||
|
+ DESTINATION "${DOC_INSTALL_DIR}"
|
||||||
|
)
|
||||||
|
|
||||||
|
endif()
|
@ -1,78 +0,0 @@
|
|||||||
diff -up doxygen-1.8.9.1/addon/doxywizard/Makefile.in.config doxygen-1.8.9.1/addon/doxywizard/Makefile.in
|
|
||||||
--- doxygen-1.8.9.1/addon/doxywizard/Makefile.in.config 2014-10-19 16:39:17.000000000 +0200
|
|
||||||
+++ doxygen-1.8.9.1/addon/doxywizard/Makefile.in 2015-01-21 16:27:20.207772693 +0100
|
|
||||||
@@ -10,7 +10,6 @@
|
|
||||||
# See the GNU General Public License for more details.
|
|
||||||
#
|
|
||||||
|
|
||||||
-QMAKE=$(QTDIR)/bin/qmake $(MKSPECS)
|
|
||||||
INCBUFSIZE=$(PYTHON) ../../src/increasebuffer.py
|
|
||||||
|
|
||||||
all: Makefile.doxywizard
|
|
||||||
diff -up doxygen-1.8.9.1/configure.config doxygen-1.8.9.1/configure
|
|
||||||
--- doxygen-1.8.9.1/configure.config 2015-01-04 12:00:55.000000000 +0100
|
|
||||||
+++ doxygen-1.8.9.1/configure 2015-01-21 16:27:20.207772693 +0100
|
|
||||||
@@ -362,9 +362,10 @@ if test "$f_wizard" = YES; then
|
|
||||||
if test -z "$QTDIR"; then
|
|
||||||
echo " QTDIR environment variable not set!"
|
|
||||||
printf " Checking for Qt..."
|
|
||||||
- for d in /usr/{lib,share,qt}/{qt-4,qt4,qt,qt*,4} /usr; do
|
|
||||||
+ for d in /usr/{lib64,lib,share,qt}/{qt-4,qt4,qt,qt*,4} /usr; do
|
|
||||||
if test -x "$d/bin/qmake"; then
|
|
||||||
QTDIR=$d
|
|
||||||
+ QMAKE=$d/bin/qmake
|
|
||||||
break 2
|
|
||||||
fi
|
|
||||||
done
|
|
||||||
@@ -771,6 +772,8 @@ INSTTOOL = $f_insttool
|
|
||||||
DOXYDOCS = ..
|
|
||||||
DOCDIR = $f_docdir
|
|
||||||
QTDIR = $QTDIR
|
|
||||||
+QMAKE = $QMAKE
|
|
||||||
+MAN1DIR = share/man/man1
|
|
||||||
EOF
|
|
||||||
|
|
||||||
if test "$f_dot" != NO; then
|
|
||||||
diff -up doxygen-1.8.9.1/Makefile.in.config doxygen-1.8.9.1/Makefile.in
|
|
||||||
--- doxygen-1.8.9.1/Makefile.in.config 2014-11-13 21:22:20.000000000 +0100
|
|
||||||
+++ doxygen-1.8.9.1/Makefile.in 2015-01-21 16:27:20.208772683 +0100
|
|
||||||
@@ -73,8 +73,6 @@ distclean: clean
|
|
||||||
|
|
||||||
DATE=$(shell date "+%B %Y")
|
|
||||||
|
|
||||||
-MAN1DIR = man/man1
|
|
||||||
-
|
|
||||||
install: doxywizard_install doxysearch_install
|
|
||||||
$(INSTTOOL) -d $(DESTDIR)$(INSTALL)/bin
|
|
||||||
$(INSTTOOL) -m 755 bin/doxygen $(DESTDIR)$(INSTALL)/bin
|
|
||||||
diff -up doxygen-1.8.9.1/tmake/lib/linux-g++/tmake.conf.config doxygen-1.8.9.1/tmake/lib/linux-g++/tmake.conf
|
|
||||||
--- doxygen-1.8.9.1/tmake/lib/linux-g++/tmake.conf.config 2014-10-24 11:51:54.000000000 +0200
|
|
||||||
+++ doxygen-1.8.9.1/tmake/lib/linux-g++/tmake.conf 2015-01-21 16:28:28.488140021 +0100
|
|
||||||
@@ -11,7 +11,7 @@ TMAKE_CC = gcc
|
|
||||||
TMAKE_CFLAGS = -pipe -fsigned-char
|
|
||||||
TMAKE_CFLAGS_WARN_ON = -Wall -W
|
|
||||||
TMAKE_CFLAGS_WARN_OFF =
|
|
||||||
-TMAKE_CFLAGS_RELEASE = -O3
|
|
||||||
+TMAKE_CFLAGS_RELEASE = $(RPM_OPT_FLAGS)
|
|
||||||
TMAKE_CFLAGS_DEBUG = -g
|
|
||||||
TMAKE_CFLAGS_SHLIB = -fPIC
|
|
||||||
TMAKE_CFLAGS_YACC = -Wno-unused -Wno-parentheses
|
|
||||||
@@ -27,12 +27,12 @@ TMAKE_CXXFLAGS_YACC = $$TMAKE_CFLAGS_YAC
|
|
||||||
|
|
||||||
TMAKE_INCDIR =
|
|
||||||
TMAKE_LIBDIR =
|
|
||||||
-TMAKE_INCDIR_X11 = /usr/X11R6/include
|
|
||||||
-TMAKE_LIBDIR_X11 = /usr/X11R6/lib
|
|
||||||
-TMAKE_INCDIR_QT = $(QTDIR)/include
|
|
||||||
-TMAKE_LIBDIR_QT = $(QTDIR)/lib
|
|
||||||
-TMAKE_INCDIR_OPENGL = /usr/X11R6/include
|
|
||||||
-TMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
|
|
||||||
+TMAKE_INCDIR_X11 =
|
|
||||||
+TMAKE_LIBDIR_X11 =
|
|
||||||
+TMAKE_INCDIR_QT =
|
|
||||||
+TMAKE_LIBDIR_QT =
|
|
||||||
+TMAKE_INCDIR_OPENGL =
|
|
||||||
+TMAKE_LIBDIR_OPENGL =
|
|
||||||
|
|
||||||
TMAKE_LINK = g++
|
|
||||||
TMAKE_LINK_SHLIB = g++
|
|
@ -1,21 +0,0 @@
|
|||||||
diff -up doxygen-1.8.9.1/src/config.xml.html_timestamp_default_false doxygen-1.8.9.1/src/config.xml
|
|
||||||
--- doxygen-1.8.9.1/src/config.xml.html_timestamp_default_false 2014-12-25 13:43:29.000000000 +0100
|
|
||||||
+++ doxygen-1.8.9.1/src/config.xml 2015-01-21 16:31:37.221391259 +0100
|
|
||||||
@@ -1624,7 +1624,7 @@ to disable this feature.
|
|
||||||
</option>
|
|
||||||
</group>
|
|
||||||
<group name='HTML' docs='Configuration options related to the HTML output'>
|
|
||||||
- <option type='bool' id='GENERATE_HTML' defval='1'>
|
|
||||||
+ <option type='bool' id='GENERATE_HTML' defval='0'>
|
|
||||||
<docs>
|
|
||||||
<![CDATA[
|
|
||||||
If the \c GENERATE_HTML tag is set to \c YES, doxygen will
|
|
||||||
@@ -1887,7 +1887,7 @@ hr.footer {
|
|
||||||
]]>
|
|
||||||
</docs>
|
|
||||||
</option>
|
|
||||||
- <option type='bool' id='HTML_TIMESTAMP' defval='1' depends='GENERATE_HTML'>
|
|
||||||
+ <option type='bool' id='HTML_TIMESTAMP' defval='0' depends='GENERATE_HTML'>
|
|
||||||
<docs>
|
|
||||||
<![CDATA[
|
|
||||||
If the \c HTML_TIMESTAMP tag is set to \c YES then the footer of
|
|
@ -1,26 +0,0 @@
|
|||||||
diff --git a/src/latexgen.cpp b/src/latexgen.cpp
|
|
||||||
index d4d8fae..de2ed22 100644
|
|
||||||
--- a/src/latexgen.cpp
|
|
||||||
+++ b/src/latexgen.cpp
|
|
||||||
@@ -535,14 +535,18 @@ static void writeDefaultFooter(FTextStream &t)
|
|
||||||
Doxygen::citeDict->writeLatexBibliography(t);
|
|
||||||
|
|
||||||
// Index
|
|
||||||
+ t << "% Index\n";
|
|
||||||
QCString unit;
|
|
||||||
if (Config_getBool("COMPACT_LATEX"))
|
|
||||||
+ {
|
|
||||||
unit = "section";
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
+ {
|
|
||||||
unit = "chapter";
|
|
||||||
- t << "% Index\n"
|
|
||||||
- "\\backmatter\n"
|
|
||||||
- "\\newpage\n"
|
|
||||||
+ t << "\\backmatter\n";
|
|
||||||
+ }
|
|
||||||
+ t << "\\newpage\n"
|
|
||||||
"\\phantomsection\n"
|
|
||||||
"\\clearemptydoublepage\n"
|
|
||||||
"\\addcontentsline{toc}{" << unit << "}{" << theTranslator->trRTFGeneralIndex() << "}\n"
|
|
66
doxygen.spec
66
doxygen.spec
@ -1,8 +1,8 @@
|
|||||||
Summary: A documentation system for C/C++
|
Summary: A documentation system for C/C++
|
||||||
Name: doxygen
|
Name: doxygen
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.8.9.1
|
Version: 1.8.10
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
# No version is specified.
|
# No version is specified.
|
||||||
License: GPL+
|
License: GPL+
|
||||||
@ -11,23 +11,24 @@ Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
|||||||
# this icon is part of kdesdk
|
# this icon is part of kdesdk
|
||||||
Source1: doxywizard.png
|
Source1: doxywizard.png
|
||||||
Source2: doxywizard.desktop
|
Source2: doxywizard.desktop
|
||||||
|
Patch1: doxygen-1.8.10-install.patch
|
||||||
Patch1: doxygen-1.8.9.1-config.patch
|
|
||||||
Patch2: doxygen-1.8.9.1-html_timestamp_default_false.patch
|
|
||||||
Patch3: doxygen-bz#1198355.patch
|
|
||||||
|
|
||||||
BuildRequires: perl
|
BuildRequires: perl
|
||||||
BuildRequires: tex(dvips)
|
BuildRequires: tex(dvips)
|
||||||
BuildRequires: tex(latex)
|
BuildRequires: tex(latex)
|
||||||
# arg, no safe/virtual provides for these
|
BuildRequires: tex(multirow.sty)
|
||||||
|
BuildRequires: tex(sectsty.sty)
|
||||||
|
BuildRequires: tex(tocloft.sty)
|
||||||
|
BuildRequires: tex(xtab.sty)
|
||||||
BuildRequires: /usr/bin/epstopdf
|
BuildRequires: /usr/bin/epstopdf
|
||||||
# Work around strange dependences in epstopdf packages (RHBZ#991699)
|
|
||||||
BuildRequires: texlive-epstopdf
|
BuildRequires: texlive-epstopdf
|
||||||
BuildRequires: ghostscript
|
BuildRequires: ghostscript
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRequires: graphviz
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Doxygen can generate an online class browser (in HTML) and/or a
|
Doxygen can generate an online class browser (in HTML) and/or a
|
||||||
@ -61,53 +62,47 @@ Requires: texlive-epstopdf-bin
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1 -b .config
|
%patch1 -p1 -b .config
|
||||||
%patch2 -p1 -b .html_timestamp_default_false
|
|
||||||
%patch3 -p1 -b .bz#1198355
|
|
||||||
|
|
||||||
# convert into utf-8
|
# convert into utf-8
|
||||||
iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
|
iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
|
||||||
touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
|
touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
|
||||||
mv LANGUAGE.HOWTO.new LANGUAGE.HOWT
|
mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
unset QTDIR
|
|
||||||
|
|
||||||
# not autoconf-based, can't use %%configure macro
|
mkdir -p %{_target_platform}
|
||||||
./configure \
|
pushd %{_target_platform}
|
||||||
--prefix %{_prefix} \
|
%cmake \
|
||||||
--shared \
|
-Dbuild_doc=ON \
|
||||||
--with-doxywizard \
|
-Dbuild_wizard=ON \
|
||||||
--release
|
-Dbuild_xmlparser=ON \
|
||||||
|
-DMAN_INSTALL_DIR=%{_mandir}/man1 \
|
||||||
# workaround for "Error: operand out of range", language.cpp needs to be splitted
|
-DDOC_INSTALL_DIR=%{_docdir}/doxygen \
|
||||||
%ifarch ppc64
|
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
||||||
make -C src Makefile.libdoxygen
|
..
|
||||||
sed -i -e "s|-o ../objects/language.o|-fno-merge-constants -fsection-anchors -o ../objects/language.o|" src/Makefile.libdoxygen
|
popd
|
||||||
%endif
|
|
||||||
|
|
||||||
make %{?_smp_mflags} all
|
|
||||||
make docs
|
|
||||||
|
|
||||||
|
make %{?_smp_mflags} -C %{_target_platform}
|
||||||
|
make docs -C %{_target_platform}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make install DESTDIR=%{buildroot}
|
make install \
|
||||||
make doxywizard_install DESTDIR=%{buildroot}
|
DESTDIR=%{buildroot} \
|
||||||
|
-C %{_target_platform}
|
||||||
|
|
||||||
install -m644 -p -D %{SOURCE1} %{buildroot}%{_datadir}/pixmaps/doxywizard.png
|
install -m644 -p -D %{SOURCE1} %{buildroot}%{_datadir}/pixmaps/doxywizard.png
|
||||||
install -m644 -p doc/doxywizard.1 %{buildroot}%{_mandir}/man1/
|
|
||||||
|
|
||||||
desktop-file-install \
|
desktop-file-install \
|
||||||
--dir=%{buildroot}%{_datadir}/applications %{SOURCE2}
|
--dir=%{buildroot}%{_datadir}/applications %{SOURCE2}
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc LANGUAGE.HOWTO README.md examples
|
%doc LANGUAGE.HOWTO README.md
|
||||||
%doc html
|
|
||||||
%{_bindir}/doxygen
|
%{_bindir}/doxygen
|
||||||
%{_mandir}/man1/doxygen.1*
|
%{_mandir}/man1/doxygen.1*
|
||||||
|
%{_mandir}/man1/doxyindexer.1.gz
|
||||||
|
%{_mandir}/man1/doxysearch.1.gz
|
||||||
|
|
||||||
%files doxywizard
|
%files doxywizard
|
||||||
%{_bindir}/doxywizard
|
%{_bindir}/doxywizard
|
||||||
@ -120,6 +115,9 @@ desktop-file-install \
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 28 2015 Than Ngo <than@redhat.com> - 1.8.10-1
|
||||||
|
- update to 1.8.10
|
||||||
|
|
||||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.8.9.1-4
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.8.9.1-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user