fix #2208417, rebase to 1.9.7
This commit is contained in:
parent
cc385e03b0
commit
1c01074635
@ -1,40 +0,0 @@
|
|||||||
--- doxygen-1.9.6.orig/templates/latex/latexmakefile.tpl 2023-03-09 10:29:08.772377871 +0100
|
|
||||||
+++ doxygen-1.9.6/templates/latex/latexmakefile.tpl 2023-03-09 10:29:23.754555476 +0100
|
|
||||||
@@ -9,7 +9,7 @@
|
|
||||||
{# TODO: generateBib #}
|
|
||||||
pdflatex refman
|
|
||||||
latex_count=8 ; \
|
|
||||||
- while egrep -s 'Rerun (LaTeX|to get cross-references right)' refman.log && [ $$latex_count -gt 0 ] ;\
|
|
||||||
+ while grep -E -s 'Rerun (LaTeX|to get cross-references right)' refman.log && [ $$latex_count -gt 0 ] ;\
|
|
||||||
do \
|
|
||||||
echo "Rerunning latex...." ;\
|
|
||||||
pdflatex refman ;\
|
|
||||||
@@ -43,7 +43,7 @@
|
|
||||||
echo "Rerunning latex...."
|
|
||||||
{{ config.LATEX_CMD_NAME }} refman.tex
|
|
||||||
latex_count=8 ; \
|
|
||||||
- while egrep -s 'Rerun (LaTeX|to get cross-references right)' refman.log && [ $$latex_count -gt 0 ] ;\
|
|
||||||
+ while grep -E -s 'Rerun (LaTeX|to get cross-references right)' refman.log && [ $$latex_count -gt 0 ] ;\
|
|
||||||
do \
|
|
||||||
echo "Rerunning latex...." ;\
|
|
||||||
{{ config.LATEX_CMD_NAME }} refman.tex ;\
|
|
||||||
--- doxygen-1.9.6.orig/src/latexgen.cpp 2023-03-09 11:10:52.092688592 +0100
|
|
||||||
+++ doxygen-1.9.6/src/latexgen.cpp 2023-03-09 11:11:07.666867516 +0100
|
|
||||||
@@ -346,7 +346,7 @@
|
|
||||||
t << "\techo \"Rerunning latex....\"\n"
|
|
||||||
<< "\t$(LATEX_CMD) $(MANUAL_FILE).tex\n"
|
|
||||||
<< "\tlatex_count=$(LATEX_COUNT) ; \\\n"
|
|
||||||
- << "\twhile egrep -s 'Rerun (LaTeX|to get cross-references right|to get bibliographical references right)' $(MANUAL_FILE).log && [ $$latex_count -gt 0 ] ;\\\n"
|
|
||||||
+ << "\twhile grep -E -s 'Rerun (LaTeX|to get cross-references right|to get bibliographical references right)' $(MANUAL_FILE).log && [ $$latex_count -gt 0 ] ;\\\n"
|
|
||||||
<< "\t do \\\n"
|
|
||||||
<< "\t echo \"Rerunning latex....\" ;\\\n"
|
|
||||||
<< "\t $(LATEX_CMD) $(MANUAL_FILE).tex ; \\\n"
|
|
||||||
@@ -374,7 +374,7 @@
|
|
||||||
}
|
|
||||||
t << "\t$(LATEX_CMD) $(MANUAL_FILE)\n"
|
|
||||||
<< "\tlatex_count=$(LATEX_COUNT) ; \\\n"
|
|
||||||
- << "\twhile egrep -s 'Rerun (LaTeX|to get cross-references right|to get bibliographical references right)' $(MANUAL_FILE).log && [ $$latex_count -gt 0 ] ;\\\n"
|
|
||||||
+ << "\twhile grep -E -s 'Rerun (LaTeX|to get cross-references right|to get bibliographical references right)' $(MANUAL_FILE).log && [ $$latex_count -gt 0 ] ;\\\n"
|
|
||||||
<< "\t do \\\n"
|
|
||||||
<< "\t echo \"Rerunning latex....\" ;\\\n"
|
|
||||||
<< "\t $(LATEX_CMD) $(MANUAL_FILE) ;\\\n"
|
|
11
doxygen.spec
11
doxygen.spec
@ -20,9 +20,9 @@
|
|||||||
Summary: A documentation system for C/C++
|
Summary: A documentation system for C/C++
|
||||||
Name: doxygen
|
Name: doxygen
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Version: 1.9.6
|
Version: 1.9.7
|
||||||
%if 0%{?stable}
|
%if 0%{?stable}
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
%else
|
%else
|
||||||
%global commit e18f715eb55121a4219d00bc4d824cebf1fb504b
|
%global commit e18f715eb55121a4219d00bc4d824cebf1fb504b
|
||||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
@ -41,8 +41,8 @@ Source0: https://github.com/%{name}/%{name}/archive/%{commit}/%{name}-%{commit}.
|
|||||||
Source1: doxywizard.desktop
|
Source1: doxywizard.desktop
|
||||||
# these icons are part of doxygen and converted from doxywizard.ico
|
# these icons are part of doxygen and converted from doxywizard.ico
|
||||||
Source2: doxywizard-icons.tar.xz
|
Source2: doxywizard-icons.tar.xz
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
Patch0: doxygen-obsolete-egrep.patch
|
|
||||||
|
|
||||||
BuildRequires: %{_bindir}/python3
|
BuildRequires: %{_bindir}/python3
|
||||||
BuildRequires: gcc-c++ gcc
|
BuildRequires: gcc-c++ gcc
|
||||||
@ -232,6 +232,8 @@ iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
|
|||||||
touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
|
touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
|
||||||
mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
|
mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
|
||||||
|
|
||||||
|
# disable unicode test temporary
|
||||||
|
rm -rf testing/061*
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if ! 0%{?_module_build}
|
%if ! 0%{?_module_build}
|
||||||
@ -321,6 +323,9 @@ desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE1}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 19 2023 Than Ngo <than@redhat.com> - 2:1.9.7-1
|
||||||
|
- fix #2208417, rebase to 1.9.7
|
||||||
|
|
||||||
* Fri Mar 10 2023 Than Ngo <than@redhat.com> - 2:1.9.6-7
|
* Fri Mar 10 2023 Than Ngo <than@redhat.com> - 2:1.9.6-7
|
||||||
- replace obsolescent egrep with grep -E
|
- replace obsolescent egrep with grep -E
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user