import RHEL 10 Beta doxygen-1.11.0-2.el10
This commit is contained in:
parent
074538b79c
commit
11cd138c79
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,4 +1,2 @@
|
||||
SOURCES/doxygen-1.8.14.src.tar.gz
|
||||
SOURCES/doxywizard.png
|
||||
/doxygen-1.8.14.src.tar.gz
|
||||
/doxywizard.png
|
||||
doxygen-1.11.0.src.tar.gz
|
||||
doxywizard-icons.tar.xz
|
||||
|
38
doxygen-1.11.0-buffer-overflow.patch
Normal file
38
doxygen-1.11.0-buffer-overflow.patch
Normal file
@ -0,0 +1,38 @@
|
||||
commit 28b51a7f199d003b309e9dab52457759d5fd7691
|
||||
Author: Jakub Klinkovský <1289205+lahwaacz@users.noreply.github.com>
|
||||
Date: Thu May 23 21:05:56 2024 +0200
|
||||
|
||||
Fix buffer overflow in Markdown parser
|
||||
|
||||
This fixes a buffer overflow that happened when parsing a bad Markdown
|
||||
file with an unclosed emphasis nested in other elements, such as
|
||||
|
||||
```markdown
|
||||
> __af_err af_flip(af_array *out, const af_array in, const unsigned dim)__
|
||||
```
|
||||
|
||||
This snippet comes from the ArrayFire repository [1]. The problem was
|
||||
found after the refactoring [2] that introduced std::string_view in the
|
||||
code. The `std::string_view::operator[]` has bounds checking enabled
|
||||
when the macro `_GLIBCXX_ASSERTIONS` is defined, which is the case of
|
||||
Arch Linux build system.
|
||||
|
||||
[1] https://github.com/arrayfire/arrayfire/blob/0a25d36238aa1eee3b775d3584937ca65b0a1807/docs/pages/matrix_manipulation.md
|
||||
[2] https://github.com/doxygen/doxygen/commit/f4e37514325abe4aa6aeecbc96e9e3e027885aef
|
||||
|
||||
diff --git a/src/markdown.cpp b/src/markdown.cpp
|
||||
index 10429edd5..df00900b0 100644
|
||||
--- a/src/markdown.cpp
|
||||
+++ b/src/markdown.cpp
|
||||
@@ -661,6 +661,11 @@ size_t Markdown::Private::findEmphasisChar(std::string_view data, char c, size_t
|
||||
data[i]!='\\' && data[i]!='@' &&
|
||||
!(data[i]=='/' && data[i-1]=='<') && // html end tag also ends emphasis
|
||||
data[i]!='\n') i++;
|
||||
+ // avoid overflow (unclosed emph token)
|
||||
+ if (i==size)
|
||||
+ {
|
||||
+ return 0;
|
||||
+ }
|
||||
//printf("findEmphasisChar: data=[%s] i=%d c=%c\n",data,i,data[i]);
|
||||
|
||||
// not counting escaped chars or characters that are unlikely
|
447
doxygen.spec
447
doxygen.spec
@ -1,55 +1,114 @@
|
||||
%if 0%{?fedora}
|
||||
%global xapian_core_support ON
|
||||
%global clang_support OFF
|
||||
%global build_wizard ON
|
||||
%else
|
||||
%global xapian_core_support OFF
|
||||
%global clang_support OFF
|
||||
%global build_wizard OFF
|
||||
%endif
|
||||
|
||||
Summary: A documentation system for C/C++
|
||||
Name: doxygen
|
||||
Epoch: 1
|
||||
Version: 1.8.14
|
||||
Release: 12%{?dist}
|
||||
|
||||
Epoch: 2
|
||||
Version: 1.11.0
|
||||
Release: 2%{?dist}
|
||||
# No version is specified.
|
||||
License: GPL+
|
||||
Url: http://www.stack.nl/~dimitri/doxygen/index.html
|
||||
Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
||||
License: GPL-1.0-or-later
|
||||
Url: https://github.com/doxygen
|
||||
Source0: https://www.doxygen.nl/files/%{name}-%{version}.src.tar.gz
|
||||
# this icon is part of kdesdk
|
||||
Source1: doxywizard.png
|
||||
Source2: doxywizard.desktop
|
||||
Source1: doxywizard.desktop
|
||||
# these icons are part of doxygen and converted from doxywizard.ico
|
||||
Source2: doxywizard-icons.tar.xz
|
||||
|
||||
# upstream patches
|
||||
Patch100: doxygen-1.11.0-buffer-overflow.patch
|
||||
|
||||
BuildRequires: %{_bindir}/python3
|
||||
BuildRequires: perl-interpreter, perl-open
|
||||
BuildRequires: texlive-bibtex
|
||||
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: perl-interpreter
|
||||
%if ! 0%{?_module_build}
|
||||
BuildRequires: tex(dvips)
|
||||
BuildRequires: tex(latex)
|
||||
BuildRequires: tex(multirow.sty)
|
||||
# From doc/manual.sty
|
||||
BuildRequires: tex(helvet.sty)
|
||||
BuildRequires: tex(sectsty.sty)
|
||||
BuildRequires: tex(tocloft.sty)
|
||||
BuildRequires: tex(xtab.sty)
|
||||
BuildRequires: tex(import.sty)
|
||||
BuildRequires: tex(tabu.sty)
|
||||
BuildRequires: tex(appendix.sty)
|
||||
BuildRequires: tex(fontenc.sty)
|
||||
BuildRequires: tex(fancyhdr.sty)
|
||||
# From templates/latex/doxygen.sty
|
||||
BuildRequires: tex(alltt.sty)
|
||||
BuildRequires: tex(calc.sty)
|
||||
BuildRequires: tex(float.sty)
|
||||
BuildRequires: tex(verbatim.sty)
|
||||
BuildRequires: tex(xcolor.sty)
|
||||
BuildRequires: tex(fancyvrb.sty)
|
||||
BuildRequires: tex(tabularx.sty)
|
||||
BuildRequires: tex(multirow.sty)
|
||||
BuildRequires: tex(hanging.sty)
|
||||
BuildRequires: tex(ifpdf.sty)
|
||||
BuildRequires: tex(adjustbox.sty)
|
||||
BuildRequires: tex(amssymb.sty)
|
||||
BuildRequires: tex(stackengine.sty)
|
||||
BuildRequires: tex(ulem.sty)
|
||||
# From doc/doxygen_manual.tex
|
||||
BuildRequires: tex(ifthen.sty)
|
||||
BuildRequires: tex(array.sty)
|
||||
BuildRequires: tex(geometry.sty)
|
||||
BuildRequires: tex(makeidx.sty)
|
||||
BuildRequires: tex(natbib.sty)
|
||||
BuildRequires: tex(graphicx.sty)
|
||||
BuildRequires: tex(multicol.sty)
|
||||
BuildRequires: tex(float.sty)
|
||||
BuildRequires: tex(geometry.sty)
|
||||
BuildRequires: tex(listings.sty)
|
||||
BuildRequires: tex(color.sty)
|
||||
BuildRequires: tex(xcolor.sty)
|
||||
BuildRequires: tex(textcomp.sty)
|
||||
BuildRequires: tex(wasysym.sty)
|
||||
BuildRequires: tex(import.sty)
|
||||
BuildRequires: tex(appendix.sty)
|
||||
BuildRequires: tex(hyperref.sty)
|
||||
BuildRequires: tex(pspicture.sty)
|
||||
BuildRequires: tex(inputenc.sty)
|
||||
BuildRequires: tex(mathptmx.sty)
|
||||
BuildRequires: tex(courier.sty)
|
||||
# From src/latexgen.cpp
|
||||
BuildRequires: tex(fixltx2e.sty)
|
||||
BuildRequires: tex(ifxetex.sty)
|
||||
BuildRequires: tex(caption.sty)
|
||||
BuildRequires: tex(etoc.sty)
|
||||
# From src/util.cpp
|
||||
BuildRequires: tex(newunicodechar.sty)
|
||||
# From templates/latex/tabu_doxygen.sty
|
||||
BuildRequires: tex(varwidth.sty)
|
||||
BuildRequires: tex(xtab.sty)
|
||||
BuildRequires: tex(tabu.sty)
|
||||
BuildRequires: /usr/bin/epstopdf
|
||||
BuildRequires: texlive-epstopdf
|
||||
BuildRequires: ghostscript
|
||||
BuildRequires: gettext
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: graphviz
|
||||
%else
|
||||
BuildRequires: zlib-devel
|
||||
%endif
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: flex
|
||||
BuildRequires: bison
|
||||
BuildRequires: cmake
|
||||
%if %{xapian_core_support} == "ON"
|
||||
BuildRequires: git
|
||||
%if "x%{?xapian_core_support}" == "xON"
|
||||
BuildRequires: xapian-core-devel
|
||||
%endif
|
||||
%if "x%{?clang_support}" == "xON"
|
||||
BuildRequires: llvm-devel
|
||||
BuildRequires: clang-devel
|
||||
%else
|
||||
BuildRequires: gcc-c++ gcc
|
||||
%endif
|
||||
Requires: perl-interpreter
|
||||
Requires: platform-python
|
||||
Requires: graphviz
|
||||
|
||||
%description
|
||||
Doxygen can generate an online class browser (in HTML) and/or a
|
||||
@ -58,7 +117,7 @@ documentation is extracted directly from the sources. Doxygen can
|
||||
also be configured to extract the code structure from undocumented
|
||||
source files.
|
||||
|
||||
%if ! 0%{?_module_build}
|
||||
%if "x%{build_wizard}" == "xON"
|
||||
%package doxywizard
|
||||
Summary: A GUI for creating and editing configuration files
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
@ -67,20 +126,77 @@ BuildRequires: qt5-qtbase-devel
|
||||
%description doxywizard
|
||||
Doxywizard is a GUI for creating and editing configuration files that
|
||||
are used by doxygen.
|
||||
%endif
|
||||
|
||||
%if ! 0%{?_module_build}
|
||||
%package latex
|
||||
Summary: Support for producing latex/pdf output from doxygen
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
Requires: tex(latex)
|
||||
Requires: tex(dvips)
|
||||
Requires: texlive-wasy
|
||||
%if 0%{?fedora} > 17 || 0%{?rhel} > 6
|
||||
Requires: tex(multirow.sty)
|
||||
# From doc/manual.sty
|
||||
Requires: tex(helvet.sty)
|
||||
Requires: tex(sectsty.sty)
|
||||
Requires: tex(tocloft.sty)
|
||||
Requires: tex(xtab.sty)
|
||||
Requires: tex(fontenc.sty)
|
||||
Requires: tex(fancyhdr.sty)
|
||||
# From templates/latex/doxygen.sty
|
||||
Requires: tex(alltt.sty)
|
||||
Requires: tex(calc.sty)
|
||||
Requires: tex(float.sty)
|
||||
Requires: tex(verbatim.sty)
|
||||
Requires: tex(xcolor.sty)
|
||||
Requires: tex(fancyvrb.sty)
|
||||
Requires: tex(tabularx.sty)
|
||||
Requires: tex(multirow.sty)
|
||||
Requires: tex(hanging.sty)
|
||||
Requires: tex(ifpdf.sty)
|
||||
Requires: tex(adjustbox.sty)
|
||||
Requires: tex(amssymb.sty)
|
||||
Requires: tex(stackengine.sty)
|
||||
Requires: tex(ulem.sty)
|
||||
# From doc/doxygen_manual.tex
|
||||
Requires: tex(ifthen.sty)
|
||||
Requires: tex(array.sty)
|
||||
Requires: tex(geometry.sty)
|
||||
Requires: tex(makeidx.sty)
|
||||
Requires: tex(natbib.sty)
|
||||
Requires: tex(graphicx.sty)
|
||||
Requires: tex(multicol.sty)
|
||||
Requires: tex(float.sty)
|
||||
Requires: tex(geometry.sty)
|
||||
Requires: tex(listings.sty)
|
||||
Requires: tex(color.sty)
|
||||
Requires: tex(xcolor.sty)
|
||||
Requires: tex(textcomp.sty)
|
||||
Requires: tex(wasysym.sty)
|
||||
Requires: tex(import.sty)
|
||||
Requires: tex(tabu.sty)
|
||||
Requires: tex(appendix.sty)
|
||||
Requires: texlive-epstopdf-bin
|
||||
Requires: tex(hyperref.sty)
|
||||
Requires: tex(pspicture.sty)
|
||||
Requires: tex(inputenc.sty)
|
||||
Requires: tex(mathptmx.sty)
|
||||
Requires: tex(courier.sty)
|
||||
# From src/latexgen.cpp
|
||||
Requires: tex(fixltx2e.sty)
|
||||
Requires: tex(ifxetex.sty)
|
||||
Requires: tex(caption.sty)
|
||||
Requires: tex(etoc.sty)
|
||||
# From src/util.cpp
|
||||
Requires: tex(newunicodechar.sty)
|
||||
# From templates/latex/tabu_doxygen.sty
|
||||
Requires: tex(varwidth.sty)
|
||||
# I'm 99% sure this isn't needed anymore since
|
||||
# doxygen has a local fork of tabu... but it doesn't seem to be hurting anything.
|
||||
Requires: tex(tabu.sty)
|
||||
# There also does not seem to be any references to xtab in the code... but eh.
|
||||
Requires: tex(xtab.sty)
|
||||
# Explicitly called binaries
|
||||
Requires: texlive-bibtex
|
||||
Requires: texlive-makeindex
|
||||
Requires: texlive-epstopdf
|
||||
%endif
|
||||
|
||||
%description latex
|
||||
@ -89,20 +205,18 @@ Requires: texlive-epstopdf-bin
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
%autosetup -p1 -a2
|
||||
|
||||
# convert into utf-8
|
||||
iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
|
||||
touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
|
||||
mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
|
||||
|
||||
|
||||
%build
|
||||
|
||||
mkdir -p %{_target_platform}
|
||||
pushd %{_target_platform}
|
||||
%if ! 0%{?_module_build}
|
||||
%if "x%{build_wizard}" == "xON"
|
||||
%cmake \
|
||||
-DPYTHON_EXECUTABLE=%{_bindir}/python3 \
|
||||
-Duse_libclang=%{clang_support} \
|
||||
-Dbuild_doc=OFF \
|
||||
-Dbuild_wizard=ON \
|
||||
-Dbuild_xmlparser=ON \
|
||||
@ -110,9 +224,10 @@ pushd %{_target_platform}
|
||||
-DMAN_INSTALL_DIR=%{_mandir}/man1 \
|
||||
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
||||
-DBUILD_SHARED_LIBS=OFF \
|
||||
..
|
||||
%else
|
||||
%cmake \
|
||||
-DPYTHON_EXECUTABLE=%{_bindir}/python3 \
|
||||
-Duse_libclang=%{clang_support} \
|
||||
-Dbuild_doc=OFF \
|
||||
-Dbuild_wizard=OFF \
|
||||
-Dbuild_xmlparser=ON \
|
||||
@ -120,57 +235,62 @@ pushd %{_target_platform}
|
||||
-DMAN_INSTALL_DIR=%{_mandir}/man1 \
|
||||
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
||||
-DBUILD_SHARED_LIBS=OFF \
|
||||
..
|
||||
%endif
|
||||
popd
|
||||
|
||||
make %{?_smp_mflags} -C %{_target_platform}
|
||||
%cmake_build %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot} -C %{_target_platform}
|
||||
|
||||
install -m644 -p -D %{SOURCE1} %{buildroot}%{_datadir}/pixmaps/doxywizard.png
|
||||
%cmake_install
|
||||
|
||||
# install man pages
|
||||
mkdir -p %{buildroot}/%{_mandir}/man1
|
||||
cp doc/*.1 %{buildroot}/%{_mandir}/man1/
|
||||
%if 0%{?_module_build}
|
||||
|
||||
%if "x%{build_wizard}" == "xOFF"
|
||||
rm -f %{buildroot}/%{_mandir}/man1/doxywizard.1*
|
||||
%else
|
||||
# install icons
|
||||
icondir=%{buildroot}%{_datadir}/icons/hicolor
|
||||
mkdir -m755 -p $icondir/{16x16,32x32,48x48,128x128}/apps
|
||||
install -m644 -p -D doxywizard-6.png $icondir/16x16/apps/doxywizard.png
|
||||
install -m644 -p -D doxywizard-5.png $icondir/32x32/apps/doxywizard.png
|
||||
install -m644 -p -D doxywizard-4.png $icondir/48x48/apps/doxywizard.png
|
||||
install -m644 -p -D doxywizard-3.png $icondir/128x128/apps/doxywizard.png
|
||||
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE1}
|
||||
%endif
|
||||
|
||||
%if %{xapian_core_support} == "OFF"
|
||||
%if "x%{?xapian_core_support}" == "xOFF"
|
||||
rm -f %{buildroot}/%{_mandir}/man1/doxyindexer.1* %{buildroot}/%{_mandir}/man1/doxysearch.1*
|
||||
%endif
|
||||
|
||||
# remove duplicate
|
||||
rm -rf %{buildroot}/%{_docdir}/packages
|
||||
|
||||
%if ! 0%{?_module_build}
|
||||
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE2}
|
||||
%endif
|
||||
%check
|
||||
%ctest
|
||||
|
||||
%files
|
||||
%doc LANGUAGE.HOWTO README.md
|
||||
%license LICENSE
|
||||
%if ! 0%{?_module_build}
|
||||
%if %{xapian_core_support} == "ON"
|
||||
%if "x%{?xapian_core_support}" == "xON"
|
||||
%{_bindir}/doxyindexer
|
||||
%{_bindir}/doxysearch*
|
||||
%endif
|
||||
%endif
|
||||
%{_bindir}/doxygen
|
||||
%{_mandir}/man1/doxygen.1*
|
||||
%if %{xapian_core_support} == "ON"
|
||||
%if "x%{?xapian_core_support}" == "xON"
|
||||
%{_mandir}/man1/doxyindexer.1*
|
||||
%{_mandir}/man1/doxysearch.1*
|
||||
%endif
|
||||
%if ! 0%{?_module_build}
|
||||
%if "x%{build_wizard}" == "xON"
|
||||
%files doxywizard
|
||||
%{_bindir}/doxywizard
|
||||
%{_mandir}/man1/doxywizard*
|
||||
%{_datadir}/applications/doxywizard.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/doxywizard.png
|
||||
%endif
|
||||
%{_datadir}/pixmaps/doxywizard.png
|
||||
|
||||
%if ! 0%{?_module_build}
|
||||
%files latex
|
||||
@ -178,35 +298,232 @@ desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE2}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon May 13 2019 Than Ngo <than@redhat.com> - 1:1.8.14-12
|
||||
- Related: #1693329 - rpmdiff execshield failures, rebuilt against new annobin
|
||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 2:1.11.0-2
|
||||
- Bump release for June 2024 mass rebuild
|
||||
|
||||
* Thu May 09 2019 Than Ngo <than@redhat.com> - 1:1.8.14-11
|
||||
- Resolves: #1681518, gating tests
|
||||
* Wed Jun 05 2024 Than Ngo <than@redhat.com> - 1.11.0-1
|
||||
- Resolves: RHEL-40092, update doxygen to 1.11.0
|
||||
|
||||
* Thu Apr 18 2019 Than Ngo <than@redhat.com> - 1:1.8.14-10
|
||||
- Resolves: #1693329, include license file
|
||||
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.10.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Wed Oct 24 2018 Than Ngo <than@redhat.com> - 1:1.8.14-9
|
||||
- Related: #1633618, multilib regressions
|
||||
* Fri Jan 19 2024 Than Ngo <than@redhat.com> - 2:1.10.0-2
|
||||
- don't use clang to build doxygen as workaround for a bug in gcc-14
|
||||
|
||||
* Tue Oct 09 2018 Than Ngo <than@redhat.com> - 1:1.8.14-8
|
||||
- Related: #1633618, rebuild
|
||||
* Tue Dec 26 2023 Than Ngo <than@redhat.com> - 1.10.0-1
|
||||
- bz#2255826, update to 1.10
|
||||
|
||||
* Thu Sep 27 2018 Than Ngo <than@redhat.com> - 1:1.8.14-7
|
||||
- Resolves: #1633618, switch Requires from python3 to platform-python
|
||||
* Mon Sep 11 2023 Than Ngo <than@redhat.com> - 1.9.8-1
|
||||
- fix bz#2235035, update to 1.9.8
|
||||
|
||||
* Tue Aug 14 2018 Than Ngo <than@redhat.com> - 1:1.8.14-6
|
||||
- Resolves: #1615513 - doxygen FTBFS on rhel-8.0
|
||||
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.9.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Tue May 30 2023 Than Ngo <than@redhat.com> - 2:1.9.7-2
|
||||
- disable build_wizard for eln
|
||||
- fixed broken unicode test
|
||||
|
||||
* Fri May 19 2023 Than Ngo <than@redhat.com> - 2:1.9.7-1
|
||||
- fix #2208417, rebase to 1.9.7
|
||||
|
||||
* Fri Mar 10 2023 Than Ngo <than@redhat.com> - 2:1.9.6-7
|
||||
- replace obsolescent egrep with grep -E
|
||||
|
||||
* Fri Feb 17 2023 Than Ngo <than@redhat.com> - 2:1.9.6-6
|
||||
- migrated to SPDX license
|
||||
|
||||
* Wed Jan 25 2023 Than Ngo <than@redhat.com> - 2:1.9.6-5
|
||||
- rebuilt against new ghostscript-10
|
||||
|
||||
* Fri Jan 20 2023 Than Ngo <than@redhat.com> - 2:1.9.6-4
|
||||
- fixed bz#2162170, add Require on texlive-wasy
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.9.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Wed Jan 18 2023 Than Ngo <than@redhat.com> - 2:1.9.6-2
|
||||
- fixed bz#2161515 - doxygen FTBFS if _module_build is 1
|
||||
|
||||
* Tue Jan 03 2023 Than Ngo <than@redhat.com> - 2:1.9.6-1
|
||||
- fixed bz#2156564, update to 1.9.6
|
||||
|
||||
* Sun Sep 18 2022 Pete Walter <pwalter@fedoraproject.org> - 2:1.9.5-2
|
||||
- Rebuild for llvm 15
|
||||
|
||||
* Fri Sep 09 2022 Than Ngo <than@redhat.com> - 2:1.9.5-1
|
||||
- 1.9.5
|
||||
|
||||
* Thu Aug 04 2022 Than Ngo <than@redhat.com> - 2:1.9.4-2
|
||||
- Fixed #2113876, Failed to build LaTex output
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.9.4-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri May 06 2022 Than Ngo <than@redhat.com> - 2:1.9.4-1
|
||||
- 1.9.4
|
||||
|
||||
* Thu Feb 17 2022 Than Ngo <than@redhat.com> - 2:1.9.4-0.20220217gite18f715e
|
||||
- update to 1.9.4 snapshot
|
||||
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.9.1-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Wed Oct 27 2021 Than Ngo <than@redhat.com> - 2:1.9.1-12
|
||||
- revert 1.9.1, noarch package built differently on different architectures
|
||||
|
||||
* Wed Oct 27 2021 Than Ngo <than@redhat.com> - 1:1.9.2-4
|
||||
- update
|
||||
|
||||
* Thu Oct 07 2021 Tom Stellard <tstellar@redhat.com> - 1:1.9.2-3
|
||||
- Rebuild for llvm-13.0.0
|
||||
|
||||
* Sun Sep 12 2021 Mattias Ellert <mattias.ellert@physics.uu.se> - 1:1.9.2-2
|
||||
- Use predictable and reproducible filenames (rhbz#2000138)
|
||||
|
||||
* Thu Aug 19 2021 Than Ngo <than@redhat.com> - 1:1.9.2-1
|
||||
- rebase to 1.9.2
|
||||
|
||||
* Tue Aug 17 2021 Björn Esser <besser82@fedoraproject.org> - 1:1.9.1-11
|
||||
- Rebuild for clang-13.0.0
|
||||
|
||||
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9.1-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Tue Mar 30 2021 Jonathan Wakely <jwakely@redhat.com> - 1:1.9.1-9
|
||||
- Rebuilt for removed libstdc++ symbol (#1937698)
|
||||
|
||||
* Sun Mar 21 2021 Than Ngo <than@redhat.com> - 1:1.9.1-8
|
||||
- update source
|
||||
|
||||
* Mon Feb 22 2021 Than Ngo <than@redhat.com> - 1:1.9.1-7
|
||||
- drop test-suite
|
||||
|
||||
* Wed Feb 10 2021 Than Ngo <than@redhat.com> - 1:1.9.1-6
|
||||
- fixed Coverity issues
|
||||
- fixed crash in docparser
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Fri Jan 22 2021 Tom Stellard <tstellar@redhat.com> - 1:1.9.1-4
|
||||
- Rebuild for clang-11.1.0
|
||||
|
||||
* Tue Jan 19 2021 Than Ngo <than@redhat.com> - 1.9.1-3
|
||||
- fixed doxygen crashes when parsing config file part2
|
||||
|
||||
|
||||
* Tue Jan 19 2021 Than Ngo <than@redhat.com> - 1.9.1-2
|
||||
- fixed bz#1916161, crashes when parsing config file
|
||||
|
||||
* Mon Jan 11 2021 Than Ngo <than@redhat.com> - 1.9.1-1
|
||||
- update to 1.9.1
|
||||
|
||||
* Mon Jan 11 2021 Than Ngo <than@redhat.com> - 1.8.20-6
|
||||
- drop BR on ImageMagick in RHEL
|
||||
|
||||
* Tue Sep 29 2020 Than Ngo <than@redhat.com> - 1.8.20-5
|
||||
- backport upstream patches
|
||||
|
||||
* Thu Sep 17 2020 Than Ngo <than@redhat.com> - 1.8.20-4
|
||||
- Fix doxygen crash
|
||||
|
||||
* Tue Sep 15 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 1:1.8.20-3
|
||||
- Fix doxygen producing different results on 32 and 64 bit architectures
|
||||
|
||||
* Fri Aug 28 2020 Scott Talbert <swt@techie.net> - 1:1.8.20-2
|
||||
- Fix issue with enums being defined in multiple files
|
||||
|
||||
* Tue Aug 25 2020 Than Ngo <than@redhat.com> - 1.8.20-1
|
||||
- update to 1.8.20
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.8.18-6
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.8.18-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jul 08 2020 Than Ngo <than@redhat.com> - 1.8.18-4
|
||||
- fixed link issue against new clang
|
||||
|
||||
* Thu Jun 18 2020 Than Ngo <than@redhat.com> - 1.8.18-3
|
||||
- fixed bz#1834591, enable clang support in fedora
|
||||
|
||||
* Wed May 27 2020 Tom Callaway <spot@fedoraproject.org> - 1.8.18-2
|
||||
- update tex dependencies
|
||||
|
||||
* Mon May 25 2020 Than Ngo <than@redhat.com> - 1.8.18-1
|
||||
- update to 1.8.18
|
||||
- backport fixes: buffer-overflow, memory leeks and md5 hash does not match for
|
||||
2 diffferent runs
|
||||
|
||||
* Thu Apr 02 2020 Björn Esser <besser82@fedoraproject.org> - 1:1.8.17-3
|
||||
- Fix string quoting for rpm >= 4.16
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.8.17-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Jan 14 2020 Than Ngo <than@redhat.com> - 1:1.8.17-1
|
||||
- resolves #1786799, update to 1.8.17
|
||||
|
||||
* Tue Dec 10 2019 Than Ngo <than@redhat.com> - 1:1.8.16-3
|
||||
- fixed covscan issues
|
||||
|
||||
* Mon Sep 16 2019 Than Ngo <than@redhat.com> - 1:1.8.16-2
|
||||
- backpored upstream patch to fix #7248
|
||||
|
||||
* Wed Sep 11 2019 Than Ngo <than@redhat.com> - 1:1.8.16-1
|
||||
- resolves #1742614, update to 1.8.16
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.8.15-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Tue Mar 19 2019 Christoph Junghans <junghans@votca.org> - 1:1.8.15-9
|
||||
- Incl. xml fix for c++11
|
||||
|
||||
* Sat Mar 16 2019 Than Ngo <than@redhat.com> - 1:1.8.15-8
|
||||
- added license file
|
||||
|
||||
* Wed Mar 13 2019 Than Ngo <than@redhat.com> - 1:1.8.15-7
|
||||
- added Requirement on dot
|
||||
|
||||
* Thu Feb 14 2019 Than Ngo <than@redhat.com> - 1:1.8.15-6
|
||||
- fixed bz#1677000, fixed multilib issue
|
||||
|
||||
* Tue Feb 12 2019 Than Ngo <than@redhat.com> - 1:1.8.15-5
|
||||
- fixed bz#1675288, doxygen 1.8.15 segfault
|
||||
|
||||
* Fri Feb 08 2019 Than Ngo <than@redhat.com> - 1:1.8.15-4
|
||||
- fixed bz#673228 - operator whitespace changes cause wxpython FTBFS
|
||||
- fixed bz#1673230 - BR on tex(newunicodechar.sty) in doxygen-latex
|
||||
|
||||
* Tue Feb 05 2019 Than Ngo <than@redhat.com> - 1:1.8.15-3
|
||||
- fixed bz#1671999, backported from upstream
|
||||
- added test for XML output with an empty TOC
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.8.15-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Mon Jan 28 2019 Than Ngo <than@redhat.com> - 1:1.8.15-1
|
||||
- update to 1.8.15
|
||||
|
||||
* Thu Dec 06 2018 Than Ngo <than@redhat.com> - 1:1.8.14-8
|
||||
- enable testing
|
||||
|
||||
* Mon Jul 23 2018 Than Ngo <than@redhat.com> - 1:1.8.14-7
|
||||
- add BR: gcc-c++ gcc
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.8.14-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Jun 27 2018 Than Ngo <than@redhat.com> - 1:1.8.14-5
|
||||
- support Qt5
|
||||
|
||||
* Wed Jun 20 2018 Than Ngo <than@redhat.com> - 1:1.8.14-4
|
||||
- added missing BR on adjustbox.sty for refman
|
||||
* Wed Jun 20 2018 Than Ngo <than@redhat.com> - 1.8.14-4
|
||||
- enble search addon on fedora
|
||||
|
||||
* Wed Jun 20 2018 Than Ngo <than@redhat.com> - 1:1.8.14-3
|
||||
- disable search addon
|
||||
* Mon Apr 30 2018 Than Ngo <than@redhat.com> - 1.8.14-3
|
||||
- added missing BR on adjustbox.sty for refman
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.8.14-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
@ -1,6 +0,0 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-8
|
||||
decision_context: osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (doxygen-1.8.14.src.tar.gz) = 5fac7e457a51b1f8e39fb65de5e0c07633e573f74e876580e7bcad5693540d6970fde1b2cb799a4df6ab9dfca951ece15b76b3010134d7658db3500183bea85c
|
||||
SHA512 (doxywizard.png) = 42a7e5903bf27463d3b072cf043aef071b519b53054bbe647c522d5e499e02f554867ab5e9971b06493769cc17b9d1588462aeade284de1f9d579cf9f99e8851
|
||||
SHA512 (doxygen-1.11.0.src.tar.gz) = 54f4a15e459d1d9cc3b4f021b5264191146bd8e0e780b57c4c31f4f9dcbfc7fe7a9db58e8cda4c6df1b4b354dd432dac0b3089fd547afe7cbe313771b2c6aaa4
|
||||
SHA512 (doxywizard-icons.tar.xz) = 865a86d7535e64ad92e36ba1f901d51cd6b603e762e5c68761a45bc1f965a36e6a6c8d29468ecb2ec799f0add2347537723832aff6660c76af453f80a0a370ad
|
||||
|
Loading…
Reference in New Issue
Block a user