dovecot/dovecot-conf.patch

98 lines
2.2 KiB
Diff

diff -r -u dovecot-0.99.13.orig/configure.in dovecot-0.99.13/configure.in
--- dovecot-0.99.13.orig/configure.in 2004-12-19 23:58:19.000000000 -0500
+++ dovecot-0.99.13/configure.in 2005-01-06 18:17:36.000000000 -0500
@@ -21,6 +21,13 @@
# check posix headers
AC_CHECK_HEADERS(sys/time.h)
+AC_ARG_WITH(docdir,
+[ --with-docdir=DIR directory for documentation (DATADIR/doc/dovecot)],
+ docdir="$withval",
+ docdir=\${datadir}/doc/dovecot
+)
+AC_SUBST(docdir)
+
AC_ARG_ENABLE(ipv6,
[ --enable-ipv6 Enable IPv6 support (default)],
if test x$enableval = xno; then
diff -r -u dovecot-0.99.13.orig/doc/Makefile.am dovecot-0.99.13/doc/Makefile.am
--- dovecot-0.99.13.orig/doc/Makefile.am 2004-12-29 12:35:07.000000000 -0500
+++ dovecot-0.99.13/doc/Makefile.am 2005-01-06 18:26:44.000000000 -0500
@@ -1,20 +1,28 @@
-docdir = $(datadir)/doc/dovecot
+exampledir=$(docdir)/examples
-doc_DATA = \
- USE-WIKI-INSTEAD \
- auth.txt \
- configuration.txt \
- design.txt \
- index.txt \
- mail-storages.txt \
- multiaccess.txt \
- nfs.txt \
+doc_DATA = \
+ USE-WIKI-INSTEAD \
+ auth.txt \
+ configuration.txt \
+ design.txt \
+ index.txt \
+ mail-storages.txt \
+ multiaccess.txt \
+ nfs.txt \
securecoding.txt
-EXTRA_DIST = \
- mkcert.sh \
- dovecot-openssl.cnf \
- dovecot-ldap.conf \
- dovecot-mysql.conf \
- dovecot-pgsql.conf \
+example_DATA = \
+ ../dovecot-example.conf \
+ mkcert.sh \
+ dovecot-openssl.cnf \
+ dovecot-ldap.conf \
+ dovecot-mysql.conf \
+ dovecot-pgsql.conf
+
+ssl_DATA = \
+ dovecot-openssl.cnf
+
+EXTRA_DIST = \
+ $(example_DATA) \
+ $(ssl_DATA) \
$(doc_DATA)
diff -r -u dovecot-0.99.13.orig/Makefile.am dovecot-0.99.13/Makefile.am
--- dovecot-0.99.13.orig/Makefile.am 2003-05-05 12:46:57.000000000 -0400
+++ dovecot-0.99.13/Makefile.am 2005-01-06 18:17:36.000000000 -0500
@@ -1,11 +1,22 @@
SUBDIRS = src doc
confdir = $(sysconfdir)
-conf_DATA = dovecot-example.conf
+conf_DATA = dovecot.conf
-EXTRA_DIST = \
- config.rpath \
- dovecot.spec \
- dovecot.spec.in \
- COPYING.LGPL \
+
+doc_DATA = \
+ AUTHORS \
+ COPYING \
+ COPYING.LGPL \
+ ChangeLog \
+ INSTALL \
+ NEWS \
+ README \
+ TODO
+
+EXTRA_DIST = \
+ config.rpath \
+ dovecot.spec \
+ dovecot.spec.in \
+ COPYING.LGPL \
$(conf_DATA)