- fix sqlite detection in upstream configure checks, second part of #182240

This commit is contained in:
prockai 2006-03-17 10:56:29 +00:00
parent 95594b0470
commit f93e9dc0c3
2 changed files with 24 additions and 2 deletions

View File

@ -0,0 +1,17 @@
--- dovecot-1.0.beta2/configure.in.sqlite-check 2006-03-06 12:05:24.000000000 +0100
+++ dovecot-1.0.beta2/configure.in 2006-03-06 12:04:35.000000000 +0100
@@ -1462,12 +1462,12 @@
for i in /usr /usr/local /usr/local; do
for j in include ""; do
if test -r "$i/$j/sqlite3.h"; then
- MYSQL_INCLUDE=$i/$j
+ SQLITE_INCLUDE=$i/$j
fi
done
for lib in lib64 lib; do for j in $lib $lib/sqlite3 ""; do
if test -f "$i/$j/libsqlite3.so" || test -f "$i/$j/libsqlite3.a"; then
- MYSQL_LIBDIR=$i/$j
+ SQLITE_LIBDIR=$i/$j
fi
done; done
done

View File

@ -1,7 +1,7 @@
Summary: Dovecot Secure imap server
Name: dovecot
Version: 1.0
Release: 0.beta2.7
Release: 0.beta2.8
License: LGPL
Group: System Environment/Daemons
@ -22,6 +22,7 @@ Patch101: dovecot-1.0.beta2-pam-tty.patch
Patch102: dovecot-1.0.beta2-pam-setcred.patch
Patch103: dovecot-1.0.beta2-mkcert-permissions.patch
Patch104: dovecot-1.0.beta2-lib64.patch
Patch105: dovecot-1.0.beta2-sqlite-check.patch
# XXX this patch needs review and forward porting
#Patch105: dovecot-auth-log.patch
@ -67,7 +68,7 @@ in either of maildir or mbox formats.
%patch102 -p2 -b .pam-setcred
%patch103 -p1 -b .mkcert-permissions
%patch104 -p1 -b .lib64
#%patch105 -p1 -b .auth-log
%patch105 -p1 -b .sqlite-check
%build
rm -f ./configure
@ -209,6 +210,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
- fix sqlite detection in upstream configure checks, second part
of #182240
* Wed Mar 8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
- fix scriplet noise some more