dbox: Fixes to handling external attachments
dsync: More fixes to avoid hanging with remote syncs dsync: Many other syncing/correctness fixes doveconf: v2.0.10 and v2.0.11 didn't output plugin {} section right
This commit is contained in:
parent
ff80e23dbf
commit
e597886c59
1
.gitignore
vendored
1
.gitignore
vendored
@ -25,3 +25,4 @@ pigeonhole-snap0592366457df.tar.bz2
|
||||
/dovecot-2.0-pigeonhole-0.2.2.tar.gz
|
||||
/dovecot-2.0.9.tar.gz
|
||||
/dovecot-2.0.11.tar.gz
|
||||
/dovecot-2.0.12.tar.gz
|
||||
|
@ -1,25 +0,0 @@
|
||||
|
||||
--- a/src/lib-settings/settings-parser.c Fri Mar 04 20:53:46 2011 +0200
|
||||
+++ b/src/lib-settings/settings-parser.c Sat Mar 26 01:10:59 2011 +0200
|
||||
@@ -693,8 +693,15 @@
|
||||
if (!settings_find_key_nth(ctx, parent_key, &parent_n,
|
||||
&parent_def, &parent_link))
|
||||
return FALSE;
|
||||
- if (parent_def->type != SET_STRLIST)
|
||||
- return FALSE;
|
||||
+ if (parent_def == NULL) {
|
||||
+ /* we'll get here with e.g. "plugin/a/b=val".
|
||||
+ not sure if we should ever do anything here.. */
|
||||
+ if (strcmp(parent_link->full_key, parent_key) != 0)
|
||||
+ return FALSE;
|
||||
+ } else {
|
||||
+ if (parent_def->type != SET_STRLIST)
|
||||
+ return FALSE;
|
||||
+ }
|
||||
|
||||
/* setting parent_key=0 adds it to links list */
|
||||
if (settings_parse_keyvalue(ctx, parent_key, "0") <= 0)
|
||||
|
||||
|
||||
|
||||
|
14
dovecot.spec
14
dovecot.spec
@ -1,8 +1,8 @@
|
||||
Summary: Secure imap and pop3 server
|
||||
Name: dovecot
|
||||
Epoch: 1
|
||||
Version: 2.0.11
|
||||
Release: 5%{?dist}
|
||||
Version: 2.0.12
|
||||
Release: 1%{?dist}
|
||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||
License: MIT and LGPLv2
|
||||
Group: System Environment/Daemons
|
||||
@ -26,9 +26,6 @@ Patch1: dovecot-2.0-defaultconfig.patch
|
||||
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
|
||||
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
|
||||
|
||||
#for < 2.0.12, rhbz#690401
|
||||
Patch4: dovecot-2.0.11-settings.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: openssl-devel, pam-devel, zlib-devel, bzip2-devel, libcap-devel
|
||||
BuildRequires: libtool, autoconf, automake, pkgconfig
|
||||
@ -105,7 +102,6 @@ This package provides the development files for dovecot.
|
||||
%patch1 -p1 -b .default-settings
|
||||
%patch2 -p1 -b .mkcert-permissions
|
||||
%patch3 -p1 -b .mkcert-paths
|
||||
%patch4 -p1 -b .settings
|
||||
|
||||
%build
|
||||
#required for fdpass.c line 125,190: dereferencing type-punned pointer will break strict-aliasing rules
|
||||
@ -398,6 +394,12 @@ make check
|
||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||
|
||||
%changelog
|
||||
* Wed Apr 13 2011 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0.12-1
|
||||
- dbox: Fixes to handling external attachments
|
||||
- dsync: More fixes to avoid hanging with remote syncs
|
||||
- dsync: Many other syncing/correctness fixes
|
||||
- doveconf: v2.0.10 and v2.0.11 didn't output plugin {} section right
|
||||
|
||||
* Mon Mar 28 2011 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0.11-5
|
||||
- rebuild with new patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user