fixed bz#1403760, big endian issue

This commit is contained in:
Than Ngo 2016-12-14 17:09:11 +01:00
parent 3203a05c7d
commit e50e991859
2 changed files with 19 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -up dovecot-2.2.27/src/lib/sha3.c.than dovecot-2.2.27/src/lib/sha3.c
--- dovecot-2.2.27/src/lib/sha3.c.than 2016-12-13 07:46:26.173797063 -0500
+++ dovecot-2.2.27/src/lib/sha3.c 2016-12-13 07:45:47.693129174 -0500
@@ -232,7 +232,7 @@ sha3_finalize(struct sha3_ctx *ctx)
SHA3_CONST(0x8000000000000000UL);
keccakf(ctx->s);
-#ifndef WORDS_BIGENDIAN
+#ifdef WORDS_BIGENDIAN
{
unsigned i;
for(i = 0; i < SHA3_KECCAK_SPONGE_WORDS; i++) {

View File

@ -5,7 +5,7 @@ Name: dovecot
Epoch: 1
Version: 2.2.27
%global prever %{nil}
Release: 1%{?dist}
Release: 2%{?dist}
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
License: MIT and LGPLv2
Group: System Environment/Daemons
@ -33,6 +33,7 @@ Patch7: dovecot-2.2.13-online.patch
Patch8: dovecot-2.2.20-initbysystemd.patch
Patch9: dovecot-2.2.22-systemd_w_protectsystem.patch
Patch10: dovecot-2.2.27-endian.patch
Source15: prestartscript
@ -129,6 +130,8 @@ This package provides the development files for dovecot.
%patch7 -p1 -b .online
%patch8 -p1 -b .initbysystemd
%patch9 -p1 -b .systemd_w_protectsystem
%patch10 -p1 -b .endian
#pushd dovecot-2*2-pigeonhole-%{pigeonholever}
#popd
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
@ -484,6 +487,9 @@ make check
%{_libdir}/%{name}/dict/libdriver_pgsql.so
%changelog
* Wed Dec 14 2016 Than Ngo <than@redhat.com> - 1:2.2.27-2
- fixed bz#1403760, big endian issue
* Mon Dec 05 2016 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.27-1
- Fixed crash in auth process when auth-policy was configured and
authentication was aborted/failed without a username set.