- updated dovecot and pigeonhole
- a lot of dsync fixes - improved (m)dbox recovery
This commit is contained in:
parent
18ecba13ac
commit
d555ceed10
@ -1,3 +1,2 @@
|
|||||||
dovecot-20100626.tar.gz
|
dovecot-20100707.tar.gz
|
||||||
pigeonhole-snap1def8519d775.tar.bz2
|
pigeonhole-snape6c049bf72a9.tar.bz2
|
||||||
dovecot-2.0-man-bda145878452.tar.bz2
|
|
||||||
|
@ -0,0 +1,46 @@
|
|||||||
|
diff -up dovecot-2.0.rc1/src/dsync/test-dsync-brain.c.betahotfix dovecot-2.0.rc1/src/dsync/test-dsync-brain.c
|
||||||
|
--- dovecot-2.0.rc1/src/dsync/test-dsync-brain.c.betahotfix 2010-07-02 04:00:08.000000000 +0200
|
||||||
|
+++ dovecot-2.0.rc1/src/dsync/test-dsync-brain.c 2010-07-07 13:45:59.887603676 +0200
|
||||||
|
@@ -211,9 +211,9 @@ static void test_dsync_brain(void)
|
||||||
|
test_assert(!test_dsync_worker_next_box_event(src_test_worker, &box_event));
|
||||||
|
test_assert(!test_dsync_worker_next_box_event(dest_test_worker, &box_event));
|
||||||
|
|
||||||
|
+ dsync_brain_deinit(&brain);
|
||||||
|
dsync_worker_deinit(&src_worker);
|
||||||
|
dsync_worker_deinit(&dest_worker);
|
||||||
|
- dsync_brain_deinit(&brain);
|
||||||
|
|
||||||
|
test_end();
|
||||||
|
}
|
||||||
|
@@ -268,9 +268,9 @@ static void test_dsync_brain_full(void)
|
||||||
|
test_assert(!test_dsync_worker_next_box_event(src_test_worker, &box_event));
|
||||||
|
test_assert(!test_dsync_worker_next_box_event(dest_test_worker, &box_event));
|
||||||
|
|
||||||
|
+ dsync_brain_deinit(&brain);
|
||||||
|
dsync_worker_deinit(&src_worker);
|
||||||
|
dsync_worker_deinit(&dest_worker);
|
||||||
|
- dsync_brain_deinit(&brain);
|
||||||
|
|
||||||
|
test_end();
|
||||||
|
}
|
||||||
|
diff -up dovecot-2.0.rc1/src/plugins/fts-solr/fts-backend-solr.c.betahotfix dovecot-2.0.rc1/src/plugins/fts-solr/fts-backend-solr.c
|
||||||
|
--- dovecot-2.0.rc1/src/plugins/fts-solr/fts-backend-solr.c.betahotfix 2010-06-23 04:00:03.000000000 +0200
|
||||||
|
+++ dovecot-2.0.rc1/src/plugins/fts-solr/fts-backend-solr.c 2010-07-07 13:39:18.847854145 +0200
|
||||||
|
@@ -57,7 +57,7 @@ static void fts_box_name_get_root(struct
|
||||||
|
*ns = (*ns)->alias_for;
|
||||||
|
|
||||||
|
if (**name == '\0' && *ns != orig_ns &&
|
||||||
|
- ((*ns)->flags & NAMESPACE_FLAG_INBOX) != 0) {
|
||||||
|
+ ((*ns)->flags & NAMESPACE_FLAG_INBOX_USER) != 0) {
|
||||||
|
/* ugly workaround to allow selecting INBOX from a Maildir/
|
||||||
|
when it's not in the inbox=yes namespace. */
|
||||||
|
*name = "INBOX";
|
||||||
|
@@ -747,7 +747,7 @@ static bool solr_virtual_uid_map(const c
|
||||||
|
bool convert_inbox;
|
||||||
|
|
||||||
|
ns = solr_get_namespaces(ctx->backend, ctx->box, ns_prefix);
|
||||||
|
- convert_inbox = (ns->flags & NAMESPACE_FLAG_INBOX) != 0 &&
|
||||||
|
+ convert_inbox = (ns->flags & NAMESPACE_FLAG_INBOX_USER) != 0 &&
|
||||||
|
strcmp(mailbox, "INBOX") == 0;
|
||||||
|
for (; ns != NULL; ns = ns->alias_chain_next) {
|
||||||
|
vname = convert_inbox ? ns->prefix :
|
13
dovecot.spec
13
dovecot.spec
@ -1,11 +1,11 @@
|
|||||||
%global betasuffix .beta6
|
%global betasuffix .rc1
|
||||||
%global snapsuffix 20100629
|
%global snapsuffix 20100707
|
||||||
|
|
||||||
Summary: Secure imap and pop3 server
|
Summary: Secure imap and pop3 server
|
||||||
Name: dovecot
|
Name: dovecot
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.0
|
Version: 2.0
|
||||||
Release: 0.15%{?betasuffix}.%{?snapsuffix}%{?dist}
|
Release: 0.16%{?betasuffix}.%{?snapsuffix}%{?dist}
|
||||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||||
License: MIT and LGPLv2
|
License: MIT and LGPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -20,7 +20,7 @@ Source1: dovecot.init
|
|||||||
Source2: dovecot.pam
|
Source2: dovecot.pam
|
||||||
#Source8: http://hg.rename-it.nl/dovecot-2.0-pigeonhole/archive/tip.tar.bz2
|
#Source8: http://hg.rename-it.nl/dovecot-2.0-pigeonhole/archive/tip.tar.bz2
|
||||||
#we use this ^^^ repository snapshost just renamed to contain last commit in name
|
#we use this ^^^ repository snapshost just renamed to contain last commit in name
|
||||||
%global phsnap 1def8519d775
|
%global phsnap e6c049bf72a9
|
||||||
Source8: pigeonhole-snap%{phsnap}.tar.bz2
|
Source8: pigeonhole-snap%{phsnap}.tar.bz2
|
||||||
Source9: dovecot.sysconfig
|
Source9: dovecot.sysconfig
|
||||||
|
|
||||||
@ -364,6 +364,11 @@ make check
|
|||||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 07 2010 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0-0.16.rc1.20100707
|
||||||
|
- updated dovecot and pigeonhole
|
||||||
|
- a lot of dsync fixes
|
||||||
|
- improved (m)dbox recovery
|
||||||
|
|
||||||
* Mon Jun 28 2010 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0-0.15.beta6.20100626
|
* Mon Jun 28 2010 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0-0.15.beta6.20100626
|
||||||
- updated dovecot, pigeonhole and man pages
|
- updated dovecot, pigeonhole and man pages
|
||||||
- moved disable_plaintext_auth to 10-auth.conf
|
- moved disable_plaintext_auth to 10-auth.conf
|
||||||
|
5
sources
5
sources
@ -1,3 +1,2 @@
|
|||||||
ff439e7dc88c4b56048be53794a1ecba dovecot-20100626.tar.gz
|
f7c1f1e1a88773512eed8047f28a1f1b dovecot-20100707.tar.gz
|
||||||
0431e36f0858323547cca0787d2e9ea4 pigeonhole-snap1def8519d775.tar.bz2
|
e4f1bf79760b2ff58fa4c84eb886d5fe pigeonhole-snape6c049bf72a9.tar.bz2
|
||||||
621307ab5ebab62d8df68107258adbec dovecot-2.0-man-bda145878452.tar.bz2
|
|
||||||
|
Loading…
Reference in New Issue
Block a user