fix build for s390x and ppc64 (#1232650)
This commit is contained in:
parent
65cfd5ffb0
commit
c761f78337
11
dovecot-2.2.18-fixbuild.patch
Normal file
11
dovecot-2.2.18-fixbuild.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- dovecot-2.2.18/src/lib/test-net.c 2015-05-03 05:12:11.000000000 -0400
|
||||
+++ dovecot-2.2.18/src/lib/test-net.c 2015-06-17 03:18:02.571420401 -0400
|
||||
@@ -56,7 +56,7 @@ static void test_net_ip2addr(void)
|
||||
test_begin("net_ip2addr()");
|
||||
test_assert(net_addr2ip("127.0.0.1", &ip) == 0 &&
|
||||
ip.family == AF_INET &&
|
||||
- ip.u.ip4.s_addr == (127 | (1 << 24)));
|
||||
+ ntohl(ip.u.ip4.s_addr) == (0x7f000001));
|
||||
#ifdef HAVE_IPV6
|
||||
test_assert(net_addr2ip("::5", &ip) == 0 &&
|
||||
ip.family == AF_INET6 &&
|
@ -5,7 +5,7 @@ Name: dovecot
|
||||
Epoch: 1
|
||||
Version: 2.2.18
|
||||
%global prever %{nil}
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||
License: MIT and LGPLv2
|
||||
Group: System Environment/Daemons
|
||||
@ -36,6 +36,7 @@ Patch5: dovecot-2.1-privatetmp.patch
|
||||
#wait for network
|
||||
Patch6: dovecot-2.1.10-waitonline.patch
|
||||
Patch7: dovecot-2.2.13-online.patch
|
||||
Patch8: dovecot-2.2.18-fixbuild.patch
|
||||
|
||||
Source15: prestartscript
|
||||
|
||||
@ -133,6 +134,7 @@ This package provides the development files for dovecot.
|
||||
%patch5 -p1 -b .privatetmp
|
||||
%patch6 -p1 -b .waitonline
|
||||
%patch7 -p1 -b .online
|
||||
%patch8 -p1 -b .fixbuild
|
||||
#pushd dovecot-2*2-pigeonhole-%{pigeonholever}
|
||||
#popd
|
||||
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
|
||||
@ -495,6 +497,9 @@ make check
|
||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||
|
||||
%changelog
|
||||
* Fri Jun 19 2015 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.18-4
|
||||
- fix build for s390x and ppc64 (#1232650)
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.2.18-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user