dovecot updated to 2.2.16
- auth: Don't crash if master user login is attempted without any configured master=yes passdbs - Parsing UTF-8 text for mails could have caused broken results sometimes if buffering was split in the middle of a UTF-8 character. This affected at least searching messages. - String sanitization for some logged output wasn't done properly: UTF-8 text could have been truncated wrongly or the truncation may not have happened at all. - fts-lucene: Lookups from virtual mailbox consisting of over 32 physical mailboxes could have caused crashes.
This commit is contained in:
parent
14512a3359
commit
c4ef51f5aa
1
.gitignore
vendored
1
.gitignore
vendored
@ -85,3 +85,4 @@ pigeonhole-snap0592366457df.tar.bz2
|
||||
/dovecot-2.2.15.tar.gz
|
||||
/pigeonhole-snapded0c5a467aa.tar.bz2
|
||||
/dovecot-2.2-pigeonhole-0.4.6.tar.gz
|
||||
/dovecot-2.2.16.tar.gz
|
||||
|
@ -1,23 +0,0 @@
|
||||
|
||||
# HG changeset patch
|
||||
# User Timo Sirainen <tss@iki.fi>
|
||||
# Date 1416386238 -32400
|
||||
# Node ID 31262a892ba7302bfea6e70e17d3acd468736d70
|
||||
# Parent 8973329d1ceb949247dd7b852d707215bfe6af17
|
||||
mbox: istream_raw_mbox_seek() needs to reset all corruption errors.
|
||||
We now reset all errors, but it doesn't really matter.
|
||||
|
||||
diff -r 8973329d1ceb -r 31262a892ba7 src/lib-storage/index/mbox/istream-raw-mbox.c
|
||||
--- a/src/lib-storage/index/mbox/istream-raw-mbox.c Sat Nov 15 03:26:16 2014 +0200
|
||||
+++ b/src/lib-storage/index/mbox/istream-raw-mbox.c Wed Nov 19 17:37:18 2014 +0900
|
||||
@@ -688,6 +688,9 @@
|
||||
|
||||
i_assert(rstream->locked);
|
||||
|
||||
+ /* reset any (corruption) errors */
|
||||
+ stream->stream_errno = 0;
|
||||
+ i_free_and_null(stream->real_stream->iostream.error);
|
||||
rstream->corrupted = FALSE;
|
||||
rstream->eof = FALSE;
|
||||
rstream->istream.istream.eof = FALSE;
|
||||
|
@ -1,24 +0,0 @@
|
||||
|
||||
# HG changeset patch
|
||||
# User Timo Sirainen <tss@iki.fi>
|
||||
# Date 1414434274 -7200
|
||||
# Node ID 03889e81929ef19653fe8842abac515f7764a526
|
||||
# Parent c77d602d4be48f705977cf0d4eca963408b7c1f0
|
||||
master: Don't send broken BYE notifications to log process.
|
||||
|
||||
diff -r c77d602d4be4 -r 03889e81929e src/master/service-log.c
|
||||
--- a/src/master/service-log.c Mon Oct 27 20:14:47 2014 +0200
|
||||
+++ b/src/master/service-log.c Mon Oct 27 20:24:34 2014 +0200
|
||||
@@ -55,6 +55,11 @@
|
||||
{
|
||||
const char *data;
|
||||
|
||||
+ if (process->service->log_process_internal_fd == -1) {
|
||||
+ /* another log process was just destroyed */
|
||||
+ return 0;
|
||||
+ }
|
||||
+
|
||||
data = t_strdup_printf("%d %s BYE\n",
|
||||
process->service->log_process_internal_fd,
|
||||
dec2str(process->pid));
|
||||
|
23
dovecot.spec
23
dovecot.spec
@ -3,9 +3,9 @@
|
||||
Summary: Secure imap and pop3 server
|
||||
Name: dovecot
|
||||
Epoch: 1
|
||||
Version: 2.2.15
|
||||
Version: 2.2.16
|
||||
%global prever %{nil}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||
License: MIT and LGPLv2
|
||||
Group: System Environment/Daemons
|
||||
@ -36,9 +36,6 @@ Patch5: dovecot-2.1-privatetmp.patch
|
||||
#wait for network
|
||||
Patch6: dovecot-2.1.10-waitonline.patch
|
||||
Patch7: dovecot-2.2.13-online.patch
|
||||
Patch9: dovecot-2.2.15-03889e81929e.patch
|
||||
Patch10: dovecot-2.2-31262a892ba7.patch
|
||||
Patch11: dovecot-2.2-80ed82a93c1a.patch
|
||||
|
||||
Source15: prestartscript
|
||||
|
||||
@ -136,9 +133,6 @@ This package provides the development files for dovecot.
|
||||
%patch5 -p1 -b .privatetmp
|
||||
%patch6 -p1 -b .waitonline
|
||||
%patch7 -p1 -b .online
|
||||
%patch9 -p1 -b .03889e81929e
|
||||
%patch10 -p1 -b .31262a892ba7
|
||||
%patch11 -p1 -b .80ed82a93c1a
|
||||
#pushd dovecot-2*2-pigeonhole-%{pigeonholever}
|
||||
#popd
|
||||
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
|
||||
@ -496,6 +490,19 @@ make check
|
||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||
|
||||
%changelog
|
||||
* Mon Mar 16 2015 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.16-1
|
||||
- dovecot updated to 2.2.16
|
||||
- auth: Don't crash if master user login is attempted without
|
||||
any configured master=yes passdbs
|
||||
- Parsing UTF-8 text for mails could have caused broken results
|
||||
sometimes if buffering was split in the middle of a UTF-8 character.
|
||||
This affected at least searching messages.
|
||||
- String sanitization for some logged output wasn't done properly:
|
||||
UTF-8 text could have been truncated wrongly or the truncation may
|
||||
not have happened at all.
|
||||
- fts-lucene: Lookups from virtual mailbox consisting of over 32
|
||||
physical mailboxes could have caused crashes.
|
||||
|
||||
* Thu Feb 05 2015 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.15-3
|
||||
- fix mbox istream crashes (#1189198, #1186504)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user