add reload command to service file
This commit is contained in:
parent
3ba26e9288
commit
c07c17e2c8
@ -1,11 +1,11 @@
|
|||||||
diff -up dovecot-2.1.rc5/dovecot.service.in.privatetmp dovecot-2.1.rc5/dovecot.service.in
|
diff -up dovecot-2.1.10/dovecot.service.in.privatetmp dovecot-2.1.10/dovecot.service.in
|
||||||
--- dovecot-2.1.rc5/dovecot.service.in.privatetmp 2012-02-07 15:15:54.977571774 +0100
|
--- dovecot-2.1.10/dovecot.service.in.privatetmp 2012-11-02 10:27:38.000000000 +0100
|
||||||
+++ dovecot-2.1.rc5/dovecot.service.in 2012-02-07 15:15:54.977571775 +0100
|
+++ dovecot-2.1.10/dovecot.service.in 2012-11-02 10:28:04.079320857 +0100
|
||||||
@@ -6,6 +6,7 @@ After=local-fs.target network.target
|
@@ -6,6 +6,7 @@ After=local-fs.target network.target
|
||||||
Type=simple
|
Type=simple
|
||||||
ExecStart=@sbindir@/dovecot -F
|
ExecStart=@sbindir@/dovecot -F
|
||||||
NonBlocking=yes
|
ExecReload=/bin/kill -HUP $MAINPID
|
||||||
+PrivateTmp=true
|
+PrivateTmp=true
|
||||||
|
NonBlocking=yes
|
||||||
|
|
||||||
[Install]
|
[Install]
|
||||||
WantedBy=multi-user.target
|
|
||||||
|
11
dovecot-2.1.10-reload.patch
Normal file
11
dovecot-2.1.10-reload.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up dovecot-2.1.10/dovecot.service.in.reload dovecot-2.1.10/dovecot.service.in
|
||||||
|
--- dovecot-2.1.10/dovecot.service.in.reload 2012-11-02 10:25:41.416181031 +0100
|
||||||
|
+++ dovecot-2.1.10/dovecot.service.in 2012-11-02 10:26:17.014467872 +0100
|
||||||
|
@@ -5,6 +5,7 @@ After=local-fs.target network.target
|
||||||
|
[Service]
|
||||||
|
Type=simple
|
||||||
|
ExecStart=@sbindir@/dovecot -F
|
||||||
|
+ExecReload=/bin/kill -HUP $MAINPID
|
||||||
|
NonBlocking=yes
|
||||||
|
|
||||||
|
[Install]
|
15
dovecot.spec
15
dovecot.spec
@ -3,7 +3,7 @@ Name: dovecot
|
|||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.1.10
|
Version: 2.1.10
|
||||||
#global prever .rc6
|
#global prever .rc6
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||||
License: MIT and LGPLv2
|
License: MIT and LGPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -22,11 +22,14 @@ Source10: dovecot.tmpfilesd
|
|||||||
#our own
|
#our own
|
||||||
Source14: dovecot.conf.5
|
Source14: dovecot.conf.5
|
||||||
|
|
||||||
# 4x Fedora/RHEL specific
|
# 3x Fedora/RHEL specific
|
||||||
Patch1: dovecot-2.0-defaultconfig.patch
|
Patch1: dovecot-2.0-defaultconfig.patch
|
||||||
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
|
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
|
||||||
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
|
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
|
||||||
Patch4: dovecot-2.1-privatetmp.patch
|
|
||||||
|
|
||||||
|
Patch4: dovecot-2.1.10-reload.patch
|
||||||
|
Patch5: dovecot-2.1-privatetmp.patch
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: openssl-devel, pam-devel, zlib-devel, bzip2-devel, libcap-devel
|
BuildRequires: openssl-devel, pam-devel, zlib-devel, bzip2-devel, libcap-devel
|
||||||
@ -119,7 +122,8 @@ This package provides the development files for dovecot.
|
|||||||
%patch1 -p1 -b .default-settings
|
%patch1 -p1 -b .default-settings
|
||||||
%patch2 -p1 -b .mkcert-permissions
|
%patch2 -p1 -b .mkcert-permissions
|
||||||
%patch3 -p1 -b .mkcert-paths
|
%patch3 -p1 -b .mkcert-paths
|
||||||
%patch4 -p1 -b .privatetmp
|
%patch4 -p1 -b .reload
|
||||||
|
%patch5 -p1 -b .privatetmp
|
||||||
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
|
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -460,6 +464,9 @@ make check
|
|||||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 02 2012 Michal Hlavinka <mhlavink@redhat.com> - 1:2.1.10-2
|
||||||
|
- add reload command to service file
|
||||||
|
|
||||||
* Wed Sep 19 2012 Michal Hlavinka <mhlavink@redhat.com> - 1:2.1.10-1
|
* Wed Sep 19 2012 Michal Hlavinka <mhlavink@redhat.com> - 1:2.1.10-1
|
||||||
- dovecot updated to 2.1.10, pigeonhole updated to 0.3.3
|
- dovecot updated to 2.1.10, pigeonhole updated to 0.3.3
|
||||||
- director: In some conditions director may have disconnected from
|
- director: In some conditions director may have disconnected from
|
||||||
|
Loading…
Reference in New Issue
Block a user