- updated to snapshot 20100406
- auth: If userdb lookup fails internally, don't cache the result. - Added support for userdb lookup to fail with a reason - sdbox: mailbox_update() could have changed UIDVALIDITY incorrectly - layout=maildir++: Fixed deleting mailboxes with mailbox=file storages - Fixed potential problems with parsing invalid address groups. - dsync: Don't repeatedly try to keep opening the same failing mailbox - lib-storage: Don't crash if root mail directory isn't given.
This commit is contained in:
parent
cfab5631c0
commit
adc8d02ea9
@ -1,2 +1,2 @@
|
|||||||
dovecot-20100330.tar.gz
|
dovecot-20100406.tar.gz
|
||||||
pigeonhole-snap940554ef4a55.tar.bzip2
|
pigeonhole-snap940554ef4a55.tar.bzip2
|
||||||
|
28
dovecot-2.0-betahotfix.patch
Normal file
28
dovecot-2.0-betahotfix.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
diff -up dovecot-2.0.beta4/dovecot-2-0-pigeonhole-940554ef4a55/src/managesieve/main.c.betahotfix dovecot-2.0.beta4/dovecot-2-0-pigeonhole-940554ef4a55/src/managesieve/main.c
|
||||||
|
--- dovecot-2.0.beta4/dovecot-2-0-pigeonhole-940554ef4a55/src/managesieve/main.c.betahotfix 2010-04-06 11:00:28.995085479 +0200
|
||||||
|
+++ dovecot-2.0.beta4/dovecot-2-0-pigeonhole-940554ef4a55/src/managesieve/main.c 2010-04-06 11:13:50.448016048 +0200
|
||||||
|
@@ -231,6 +231,14 @@ static void client_connected(const struc
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
+static void login_client_failed(const struct master_login_client *client,
|
||||||
|
+ const char *errormsg)
|
||||||
|
+{
|
||||||
|
+ const char *msg;
|
||||||
|
+ msg = t_strdup_printf("* BAD %s\r\n", errormsg);
|
||||||
|
+ (void)write(client->fd, msg, strlen(msg));
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
int main(int argc, char *argv[])
|
||||||
|
{
|
||||||
|
static const struct setting_parser_info *set_roots[] = {
|
||||||
|
@@ -284,7 +292,8 @@ int main(int argc, char *argv[])
|
||||||
|
} else {
|
||||||
|
master_login = master_login_init(master_service, "auth-master",
|
||||||
|
postlogin_socket_path,
|
||||||
|
- login_client_connected);
|
||||||
|
+ login_client_connected,
|
||||||
|
+ login_client_failed);
|
||||||
|
io_loop_set_running(current_ioloop);
|
||||||
|
}
|
||||||
|
|
17
dovecot.spec
17
dovecot.spec
@ -1,11 +1,11 @@
|
|||||||
%global betasuffix .beta4
|
%global betasuffix .beta4
|
||||||
%global snapsuffix 20100330
|
%global snapsuffix 20100406
|
||||||
|
|
||||||
Summary: Secure imap and pop3 server
|
Summary: Secure imap and pop3 server
|
||||||
Name: dovecot
|
Name: dovecot
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.0
|
Version: 2.0
|
||||||
Release: 0.3%{?betasuffix}.%{?snapsuffix}%{?dist}
|
Release: 0.4%{?betasuffix}.%{?snapsuffix}%{?dist}
|
||||||
#dovecot itself is MIT, a few sources are PD, (manage)sieve is LGPLv2, perfect_maildir.pl is GPLv2+
|
#dovecot itself is MIT, a few sources are PD, (manage)sieve is LGPLv2, perfect_maildir.pl is GPLv2+
|
||||||
License: MIT and LGPLv2 and GPLv2+
|
License: MIT and LGPLv2 and GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -41,6 +41,8 @@ Patch1: dovecot-2.0-defaultconfig.patch
|
|||||||
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
|
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
|
||||||
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
|
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
|
||||||
|
|
||||||
|
Patch4: dovecot-2.0-betahotfix.patch
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: openssl-devel, pam-devel, zlib-devel, bzip2-devel, libcap-devel
|
BuildRequires: openssl-devel, pam-devel, zlib-devel, bzip2-devel, libcap-devel
|
||||||
BuildRequires: libtool, autoconf, automake, pkgconfig
|
BuildRequires: libtool, autoconf, automake, pkgconfig
|
||||||
@ -112,6 +114,7 @@ This package provides the development files for dovecot.
|
|||||||
#%patch1 -p1 -b .default-settings
|
#%patch1 -p1 -b .default-settings
|
||||||
%patch2 -p1 -b .mkcert-permissions
|
%patch2 -p1 -b .mkcert-permissions
|
||||||
%patch3 -p1 -b .mkcert-paths
|
%patch3 -p1 -b .mkcert-paths
|
||||||
|
%patch4 -p1 -b .betahotfix
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#autotools hacks can be removed later, nightly does not support --docdir
|
#autotools hacks can be removed later, nightly does not support --docdir
|
||||||
@ -362,6 +365,16 @@ fi
|
|||||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 30 2010 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0-0.4.beta4.20100406
|
||||||
|
- updated to snapshot 20100406
|
||||||
|
- auth: If userdb lookup fails internally, don't cache the result.
|
||||||
|
- Added support for userdb lookup to fail with a reason
|
||||||
|
- sdbox: mailbox_update() could have changed UIDVALIDITY incorrectly
|
||||||
|
- layout=maildir++: Fixed deleting mailboxes with mailbox=file storages
|
||||||
|
- Fixed potential problems with parsing invalid address groups.
|
||||||
|
- dsync: Don't repeatedly try to keep opening the same failing mailbox
|
||||||
|
- lib-storage: Don't crash if root mail directory isn't given.
|
||||||
|
|
||||||
* Tue Mar 30 2010 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0-0.3.beta4.20100330
|
* Tue Mar 30 2010 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0-0.3.beta4.20100330
|
||||||
- fix certs location in ssl.conf
|
- fix certs location in ssl.conf
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user