dovecot updated to 2.2.15
- various race condition fixes to LAYOUT=index - v2.2.14 virtual plugin crashed in some situations
This commit is contained in:
parent
4beaca435e
commit
a0c43f9f3e
2
.gitignore
vendored
2
.gitignore
vendored
@ -82,3 +82,5 @@ pigeonhole-snap0592366457df.tar.bz2
|
||||
/dovecot-2.2.13.tar.gz
|
||||
/dovecot-2.2.14.tar.gz
|
||||
/dovecot-2.2-pigeonhole-0.4.3.tar.gz
|
||||
/dovecot-2.2.15.tar.gz
|
||||
/pigeonhole-snapded0c5a467aa.tar.bz2
|
||||
|
31
d-2.2.15-pigeonbuildfix.patch
Normal file
31
d-2.2.15-pigeonbuildfix.patch
Normal file
@ -0,0 +1,31 @@
|
||||
|
||||
# HG changeset patch
|
||||
# User Stephan Bosch <stephan@rename-it.nl>
|
||||
# Date 1414266676 -7200
|
||||
# Node ID 15b2910b145c5e16fb9967d16387fc24104b0925
|
||||
# Parent 819b8fb22034a761b45c88f021a1e8b857ccacb4
|
||||
Adjusted to datastack-related changes in Dovecot lib-storage.
|
||||
|
||||
diff -r 819b8fb22034 -r 15b2910b145c src/lib-sieve/util/edit-mail.c
|
||||
--- a/src/lib-sieve/util/edit-mail.c Sun Oct 19 22:50:23 2014 +0200
|
||||
+++ b/src/lib-sieve/util/edit-mail.c Sat Oct 25 21:51:16 2014 +0200
|
||||
@@ -1473,7 +1473,7 @@
|
||||
(&edmail->wrapped->mail, field_name, decode_to_utf8, value_r);
|
||||
}
|
||||
|
||||
- t_array_init(&header_values, 1);
|
||||
+ p_array_init(&header_values, edmail->mail.pool, 1);
|
||||
(void)array_append_space(&header_values);
|
||||
*value_r = array_idx(&header_values, 0);
|
||||
return 0;
|
||||
@@ -1489,7 +1489,7 @@
|
||||
}
|
||||
|
||||
/* Fill result array */
|
||||
- t_array_init(&header_values, 32);
|
||||
+ p_array_init(&header_values, edmail->mail.pool, 32);
|
||||
field_idx = header_idx->first;
|
||||
while ( field_idx != NULL ) {
|
||||
|
||||
|
||||
|
11
dovecot.spec
11
dovecot.spec
@ -3,7 +3,7 @@
|
||||
Summary: Secure imap and pop3 server
|
||||
Name: dovecot
|
||||
Epoch: 1
|
||||
Version: 2.2.14
|
||||
Version: 2.2.15
|
||||
%global prever %{nil}
|
||||
Release: 1%{?dist}
|
||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||
@ -36,6 +36,7 @@ Patch5: dovecot-2.1-privatetmp.patch
|
||||
#wait for network
|
||||
Patch6: dovecot-2.1.10-waitonline.patch
|
||||
Patch7: dovecot-2.2.13-online.patch
|
||||
Patch8: d-2.2.15-pigeonbuildfix.patch
|
||||
|
||||
Source15: prestartscript
|
||||
|
||||
@ -133,6 +134,9 @@ This package provides the development files for dovecot.
|
||||
%patch5 -p1 -b .privatetmp
|
||||
%patch6 -p1 -b .waitonline
|
||||
%patch7 -p1 -b .online
|
||||
pushd dovecot-2*2-pigeonhole-%{pigeonholever}
|
||||
%patch8 -p1 -b .pigeonbuildfix
|
||||
popd
|
||||
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
|
||||
|
||||
%build
|
||||
@ -487,6 +491,11 @@ make check
|
||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||
|
||||
%changelog
|
||||
* Thu Oct 30 2014 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.15-1
|
||||
- dovecot updated to 2.2.15
|
||||
- various race condition fixes to LAYOUT=index
|
||||
- v2.2.14 virtual plugin crashed in some situations
|
||||
|
||||
* Fri Oct 17 2014 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.14-1
|
||||
- dovecot updated to 2.2.14, pigeonhole updated to 0.4.3
|
||||
- fixed several race conditions with dovecot.index.cache handling that
|
||||
|
Loading…
Reference in New Issue
Block a user