strip version for pigeonhole src dir for simplifying the rest of code/patches

This commit is contained in:
Michal Hlavinka 2023-09-18 16:51:08 +02:00
parent b0924ff71d
commit 97e16a026d
2 changed files with 13 additions and 9 deletions

View File

@ -1,6 +1,6 @@
diff -up dovecot-2.3.17/dovecot-2.3-pigeonhole-0.5.19/src/lib-sieve/storage/dict/sieve-dict-script.c.fixvalcond dovecot-2.3.17/dovecot-2.3-pigeonhole-0.5.19/src/lib-sieve/storage/dict/sieve-dict-script.c
--- dovecot-2.3.17/dovecot-2.3-pigeonhole-0.5.20/src/lib-sieve/storage/dict/sieve-dict-script.c.fixvalcond 2021-11-02 21:51:36.109032050 +0100
+++ dovecot-2.3.17/dovecot-2.3-pigeonhole-0.5.20/src/lib-sieve/storage/dict/sieve-dict-script.c 2021-11-02 21:52:28.409344118 +0100
diff -up dovecot-2.3.17/dovecot-pigeonhole/src/lib-sieve/storage/dict/sieve-dict-script.c.fixvalcond dovecot-2.3.17/dovecot-pigeonhole/src/lib-sieve/storage/dict/sieve-dict-script.c
--- dovecot-2.3.17/dovecot-pigeonhole/src/lib-sieve/storage/dict/sieve-dict-script.c.fixvalcond 2021-11-02 21:51:36.109032050 +0100
+++ dovecot-2.3.17/dovecot-pigeonhole/src/lib-sieve/storage/dict/sieve-dict-script.c 2021-11-02 21:52:28.409344118 +0100
@@ -114,7 +114,7 @@ static int sieve_dict_script_get_stream
(struct sieve_dict_script *)script;
struct sieve_dict_storage *dstorage =

View File

@ -137,6 +137,10 @@ This package provides the development files for dovecot.
%prep
%setup -q -n %{name}-%{version}%{?prever} -a 8
# standardize name, so we don't have to update patches and scripts
mv dovecot-2.3-pigeonhole-%{pigeonholever} dovecot-pigeonhole
%patch -P1 -p1 -b .default-settings
%patch -P2 -p1 -b .mkcert-permissions
%patch -P3 -p1 -b .mkcert-paths
@ -151,11 +155,11 @@ This package provides the development files for dovecot.
%patch -P21 -p1 -b .7bad6a24
%patch -P22 -p1 -b .c99
%patch -P23 -p1 -b .nolibotp
cp run-test-valgrind.supp dovecot-2.3-pigeonhole-%{pigeonholever}/
cp run-test-valgrind.supp dovecot-pigeonhole/
# valgrind would fail with shell wrapper
echo "testsuite" >dovecot-2.3-pigeonhole-%{pigeonholever}/run-test-valgrind.exclude
echo "testsuite" >dovecot-pigeonhole/run-test-valgrind.exclude
#pushd dovecot-2*3-pigeonhole-%{pigeonholever}
#pushd dovecot-pigeonhole
#popd
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
@ -205,7 +209,7 @@ sed -i 's|/etc/ssl|/etc/pki/dovecot|' doc/mkcert.sh doc/example-config/conf.d/10
%make_build
#pigeonhole
pushd dovecot-2*3-pigeonhole-%{pigeonholever}
pushd dovecot-pigeonhole
# required for snapshot
[ -f configure ] || autoreconf -fiv
@ -231,7 +235,7 @@ mv $RPM_BUILD_ROOT/%{_docdir}/%{name} %{_builddir}/%{name}-%{version}%{?prever}/
# fix multilib issues
%multilib_fix_c_header --file %{_includedir}/dovecot/config.h
pushd dovecot-2*3-pigeonhole-%{pigeonholever}
pushd dovecot-pigeonhole
%make_install
mv $RPM_BUILD_ROOT/%{_docdir}/%{name} $RPM_BUILD_ROOT/%{_docdir}/%{name}-pigeonhole
@ -338,7 +342,7 @@ fi
%ifnarch aarch64
# some aarch64 tests timeout, skip for now
make check
cd dovecot-2*3-pigeonhole-%{pigeonholever}
cd dovecot-pigeonhole
make check
%endif