IMAP: Fixed hangs with COMPRESS extension
IMAP: Fixed a hang when trying to COPY to a nonexistent mailbox. IMAP: Fixed hang/crash with SEARCHRES + pipelining $. IMAP: Fixed assert-crash if IDLE+DONE is sent in same TCP packet.
This commit is contained in:
parent
e90ec7f134
commit
80c17acc4b
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@ pigeonhole-snap0592366457df.tar.bz2
|
|||||||
/pigeonhole-snap67d2240966ec.tar.bz2
|
/pigeonhole-snap67d2240966ec.tar.bz2
|
||||||
/dovecot-2.0-pigeonhole-0.2.2.tar.gz
|
/dovecot-2.0-pigeonhole-0.2.2.tar.gz
|
||||||
/dovecot-2.0.9.tar.gz
|
/dovecot-2.0.9.tar.gz
|
||||||
|
/dovecot-2.0.11.tar.gz
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
diff -up dovecot-2.0.9/dovecot.service.in.systd dovecot-2.0.9/dovecot.service.in
|
|
||||||
--- dovecot-2.0.9/dovecot.service.in.systd 2011-02-17 11:57:04.921366472 +0100
|
|
||||||
+++ dovecot-2.0.9/dovecot.service.in 2011-02-17 11:57:04.922366479 +0100
|
|
||||||
@@ -6,3 +6,6 @@ After=local-fs.target network.target
|
|
||||||
Type=simple
|
|
||||||
ExecStart=@sbindir@/dovecot -F
|
|
||||||
NonBlocking=yes
|
|
||||||
+
|
|
||||||
+[Install]
|
|
||||||
+WantedBy=multi-user.target
|
|
13
dovecot.spec
13
dovecot.spec
@ -1,8 +1,8 @@
|
|||||||
Summary: Secure imap and pop3 server
|
Summary: Secure imap and pop3 server
|
||||||
Name: dovecot
|
Name: dovecot
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.0.9
|
Version: 2.0.11
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||||
License: MIT and LGPLv2
|
License: MIT and LGPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -26,8 +26,6 @@ Patch1: dovecot-2.0-defaultconfig.patch
|
|||||||
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
|
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
|
||||||
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
|
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
|
||||||
|
|
||||||
Patch4: dovecot-2.0.9-systd.patch
|
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: openssl-devel, pam-devel, zlib-devel, bzip2-devel, libcap-devel
|
BuildRequires: openssl-devel, pam-devel, zlib-devel, bzip2-devel, libcap-devel
|
||||||
BuildRequires: libtool, autoconf, automake, pkgconfig
|
BuildRequires: libtool, autoconf, automake, pkgconfig
|
||||||
@ -104,7 +102,6 @@ This package provides the development files for dovecot.
|
|||||||
%patch1 -p1 -b .default-settings
|
%patch1 -p1 -b .default-settings
|
||||||
%patch2 -p1 -b .mkcert-permissions
|
%patch2 -p1 -b .mkcert-permissions
|
||||||
%patch3 -p1 -b .mkcert-paths
|
%patch3 -p1 -b .mkcert-paths
|
||||||
%patch4 -p1 -b .systd
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#required for fdpass.c line 125,190: dereferencing type-punned pointer will break strict-aliasing rules
|
#required for fdpass.c line 125,190: dereferencing type-punned pointer will break strict-aliasing rules
|
||||||
@ -397,6 +394,12 @@ make check
|
|||||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 07 2011 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0.11-1
|
||||||
|
- IMAP: Fixed hangs with COMPRESS extension
|
||||||
|
- IMAP: Fixed a hang when trying to COPY to a nonexistent mailbox.
|
||||||
|
- IMAP: Fixed hang/crash with SEARCHRES + pipelining $.
|
||||||
|
- IMAP: Fixed assert-crash if IDLE+DONE is sent in same TCP packet.
|
||||||
|
|
||||||
* Thu Feb 17 2011 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0.9-3
|
* Thu Feb 17 2011 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0.9-3
|
||||||
- add missing section to dovecot's systemd service file
|
- add missing section to dovecot's systemd service file
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user