dovecot updated to 2.2.19

- mdbox: Rebuilding could have caused message's reference count to
  overflow the 16bit number in some situations, causing problems when
  trying to expunge the duplicates.
- Various search fixes (fts, solr, tika, lib-charset, indexer)
- Various virtual plugin fixes
- Various fixes and optimizations to dsync, imapc and pop3-migration
- imap: Various RFC compliancy and crash fixes to NOTIFY
- pigeonhole updated to 0.4.9
- ManageSieve: Fixed an assert failure occurring when a client
  disconnects during the GETSCRIPT command.
- doveadm sieve plugin: Fixed incorrect initialization (mem leaks) of mail user.
- sieve-filter command line tool: Fixed handling of failure-related
  implicit keep when there is an explicit default destination folder.
- lib-sieve: Fixed bug in RFC5322 header folding.
This commit is contained in:
Michal Hlavinka 2015-10-05 13:02:53 +02:00
parent e8c10d3eba
commit 7e0f121e5e
8 changed files with 42 additions and 49 deletions

2
.gitignore vendored
View File

@ -90,3 +90,5 @@ pigeonhole-snap0592366457df.tar.bz2
/dovecot-2.2.18.tar.gz
/dovecot-2.2-pigeonhole-0.4.7.tar.gz
/dovecot-2.2-pigeonhole-0.4.8.tar.gz
/dovecot-2.2.19.tar.gz
/dovecot-2.2-pigeonhole-0.4.9.tar.gz

View File

@ -1,10 +1,10 @@
diff -up dovecot-2.1.10/dovecot.service.in.privatetmp dovecot-2.1.10/dovecot.service.in
--- dovecot-2.1.10/dovecot.service.in.privatetmp 2012-11-02 10:27:38.000000000 +0100
+++ dovecot-2.1.10/dovecot.service.in 2012-11-02 10:28:04.079320857 +0100
@@ -6,6 +6,7 @@ After=local-fs.target network.target
diff -up dovecot-2.2.19/dovecot.service.in.privatetmp dovecot-2.2.19/dovecot.service.in
--- dovecot-2.2.19/dovecot.service.in.privatetmp 2015-10-05 12:50:24.273780394 +0200
+++ dovecot-2.2.19/dovecot.service.in 2015-10-05 12:50:56.281621589 +0200
@@ -26,6 +26,7 @@ After=local-fs.target network.target
Type=simple
ExecStart=@sbindir@/dovecot -F
ExecReload=/bin/kill -HUP $MAINPID
ExecStart=@sbindir@/dovecot -F $OPTIONS
ExecReload=@sbindir@/dovecot reload
+PrivateTmp=true
NonBlocking=yes

View File

@ -1,11 +0,0 @@
diff -up dovecot-2.1.10/dovecot.service.in.reload dovecot-2.1.10/dovecot.service.in
--- dovecot-2.1.10/dovecot.service.in.reload 2012-11-02 10:25:41.416181031 +0100
+++ dovecot-2.1.10/dovecot.service.in 2012-11-02 10:26:17.014467872 +0100
@@ -5,6 +5,7 @@ After=local-fs.target network.target
[Service]
Type=simple
ExecStart=@sbindir@/dovecot -F
+ExecReload=/bin/kill -HUP $MAINPID
NonBlocking=yes
[Install]

View File

@ -1,11 +1,11 @@
diff -up dovecot-2.1.10/dovecot.service.in.waitonline dovecot-2.1.10/dovecot.service.in
--- dovecot-2.1.10/dovecot.service.in.waitonline 2012-11-20 14:19:47.000000000 +0100
+++ dovecot-2.1.10/dovecot.service.in 2012-11-20 14:20:29.245076250 +0100
@@ -4,6 +4,7 @@ After=local-fs.target network.target
diff -up dovecot-2.2.19/dovecot.service.in.waitonline dovecot-2.2.19/dovecot.service.in
--- dovecot-2.2.19/dovecot.service.in.waitonline 2015-10-05 12:51:42.578391891 +0200
+++ dovecot-2.2.19/dovecot.service.in 2015-10-05 12:53:20.143907826 +0200
@@ -24,6 +24,7 @@ After=local-fs.target network.target
[Service]
Type=simple
+ExecStartPre=/usr/libexec/dovecot/prestartscript
ExecStart=@sbindir@/dovecot -F
ExecReload=/bin/kill -HUP $MAINPID
ExecStart=@sbindir@/dovecot -F $OPTIONS
ExecReload=@sbindir@/dovecot reload
PrivateTmp=true

View File

@ -1,9 +1,10 @@
diff -up dovecot-2.2.13/dovecot.service.in.online dovecot-2.2.13/dovecot.service.in
--- dovecot-2.2.13/dovecot.service.in.online 2014-08-21 13:40:37.998225041 +0200
+++ dovecot-2.2.13/dovecot.service.in 2014-08-21 13:40:49.903167774 +0200
@@ -1,6 +1,6 @@
[Unit]
diff -up dovecot-2.2.19/dovecot.service.in.online dovecot-2.2.19/dovecot.service.in
--- dovecot-2.2.19/dovecot.service.in.online 2015-10-05 12:53:55.985729999 +0200
+++ dovecot-2.2.19/dovecot.service.in 2015-10-05 12:54:36.951526750 +0200
@@ -20,7 +20,7 @@
Description=Dovecot IMAP/POP3 email server
Documentation=man:dovecot(1)
Documentation=http://wiki2.dovecot.org/
-After=local-fs.target network.target
+After=local-fs.target network-online.target

View File

@ -1,11 +0,0 @@
--- dovecot-2.2.18/src/lib/test-net.c 2015-05-03 05:12:11.000000000 -0400
+++ dovecot-2.2.18/src/lib/test-net.c 2015-06-17 03:18:02.571420401 -0400
@@ -56,7 +56,7 @@ static void test_net_ip2addr(void)
test_begin("net_ip2addr()");
test_assert(net_addr2ip("127.0.0.1", &ip) == 0 &&
ip.family == AF_INET &&
- ip.u.ip4.s_addr == (127 | (1 << 24)));
+ ntohl(ip.u.ip4.s_addr) == (0x7f000001));
#ifdef HAVE_IPV6
test_assert(net_addr2ip("::5", &ip) == 0 &&
ip.family == AF_INET6 &&

View File

@ -3,9 +3,9 @@
Summary: Secure imap and pop3 server
Name: dovecot
Epoch: 1
Version: 2.2.18
Version: 2.2.19
%global prever %{nil}
Release: 5%{?dist}
Release: 1%{?dist}
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
License: MIT and LGPLv2
Group: System Environment/Daemons
@ -14,7 +14,7 @@ URL: http://www.dovecot.org/
Source: http://www.dovecot.org/releases/2.2/%{name}-%{version}%{?prever}.tar.gz
Source1: dovecot.init
Source2: dovecot.pam
%global pigeonholever 0.4.8
%global pigeonholever 0.4.9
Source8: http://www.rename-it.nl/dovecot/2.2/dovecot-2.2-pigeonhole-%{pigeonholever}.tar.gz
#wget http://hg.rename-it.nl/dovecot-2.2-pigeonhole/archive/%{pigeonholever}.tar.bz2 -O dovecot-2.2-pigeonhole-%{pigeonholever}.tar.bz2
#Source8: dovecot-2.2-pigeonhole-%{pigeonholever}.tar.bz2
@ -29,14 +29,11 @@ Patch1: dovecot-2.0-defaultconfig.patch
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
Patch4: dovecot-2.1.10-reload.patch
Patch5: dovecot-2.1-privatetmp.patch
#wait for network
Patch6: dovecot-2.1.10-waitonline.patch
Patch7: dovecot-2.2.13-online.patch
Patch8: dovecot-2.2.18-fixbuild.patch
Source15: prestartscript
@ -130,11 +127,9 @@ This package provides the development files for dovecot.
%patch1 -p1 -b .default-settings
%patch2 -p1 -b .mkcert-permissions
%patch3 -p1 -b .mkcert-paths
%patch4 -p1 -b .reload
%patch5 -p1 -b .privatetmp
%patch6 -p1 -b .waitonline
%patch7 -p1 -b .online
%patch8 -p1 -b .fixbuild
#pushd dovecot-2*2-pigeonhole-%{pigeonholever}
#popd
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
@ -497,6 +492,23 @@ make check
%{_libdir}/%{name}/dict/libdriver_pgsql.so
%changelog
* Mon Oct 05 2015 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.19-1
- dovecot updated to 2.2.19
- mdbox: Rebuilding could have caused message's reference count to
overflow the 16bit number in some situations, causing problems when
trying to expunge the duplicates.
- Various search fixes (fts, solr, tika, lib-charset, indexer)
- Various virtual plugin fixes
- Various fixes and optimizations to dsync, imapc and pop3-migration
- imap: Various RFC compliancy and crash fixes to NOTIFY
- pigeonhole updated to 0.4.9
- ManageSieve: Fixed an assert failure occurring when a client
disconnects during the GETSCRIPT command.
- doveadm sieve plugin: Fixed incorrect initialization (mem leaks) of mail user.
- sieve-filter command line tool: Fixed handling of failure-related
implicit keep when there is an explicit default destination folder.
- lib-sieve: Fixed bug in RFC5322 header folding.
* Mon Aug 24 2015 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.18-5
- use the system crypto policy (#1109114)

View File

@ -1,2 +1,2 @@
1e42eb3b69544c447ad882d7858f3630 dovecot-2.2.18.tar.gz
3568ede2c3607e239ad9801034ba2a5d dovecot-2.2-pigeonhole-0.4.8.tar.gz
95591b6556413edc2f0b160fb469d04c dovecot-2.2.19.tar.gz
3a2d856c1c50557d098536b687efc5f8 dovecot-2.2-pigeonhole-0.4.9.tar.gz