dovecot updated to 2.2.29.1
dict-sql: Merging multiple UPDATEs to a single statement wasn't actually working. pigeonhole updated to 0.4.18 imapsieve plugin: Implemented the copy_source_after rule action. When this is enabled for a mailbox rule, the specified Sieve script is executed for the message in the source mailbox during a "COPY" event. This happens only after the Sieve script that is executed for the corresponding message in the destination mailbox finishes running successfully. imapsieve plugin: Added non-standard Sieve environment items for the source and destination mailbox. multiscript: The execution of the discard script had an implicit "keep", rather than an implicit "discard".
This commit is contained in:
parent
8be51b99fe
commit
47787255f7
2
.gitignore
vendored
2
.gitignore
vendored
@ -109,3 +109,5 @@ pigeonhole-snap0592366457df.tar.bz2
|
||||
/dovecot-2.2.28.tar.gz
|
||||
/dovecot-2.2-pigeonhole-0.4.17.tar.gz
|
||||
/dovecot-2.2.29.tar.gz
|
||||
/dovecot-2.2.29.1.tar.gz
|
||||
/dovecot-2.2-pigeonhole-0.4.18.tar.gz
|
||||
|
@ -1,76 +0,0 @@
|
||||
From 3a1c64363a64cdfe9153eb6292d8923f38955d82 Mon Sep 17 00:00:00 2001
|
||||
From: Timo Sirainen <timo.sirainen@dovecot.fi>
|
||||
Date: Mon, 10 Apr 2017 17:07:28 +0300
|
||||
Subject: [PATCH] lib-imap-client: Fix reconnection
|
||||
|
||||
There was already code for reconnection. We just shouldn't have gone very
|
||||
far in imapc_connection_connect() if we were still waiting for reconnection
|
||||
delay to pass.
|
||||
---
|
||||
src/lib-imap-client/imapc-connection.c | 25 +++++++++----------------
|
||||
1 file changed, 9 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/src/lib-imap-client/imapc-connection.c b/src/lib-imap-client/imapc-connection.c
|
||||
index 95067e6..6eaf1ab 100644
|
||||
--- a/src/lib-imap-client/imapc-connection.c
|
||||
+++ b/src/lib-imap-client/imapc-connection.c
|
||||
@@ -130,6 +130,7 @@ struct imapc_connection {
|
||||
struct timeout *to_throttle, *to_throttle_shrink;
|
||||
|
||||
unsigned int reconnecting:1;
|
||||
+ unsigned int reconnect_waiting:1;
|
||||
unsigned int reconnect_ok:1;
|
||||
unsigned int idling:1;
|
||||
unsigned int idle_stopping:1;
|
||||
@@ -504,6 +505,7 @@ static bool imapc_connection_can_reconnect(struct imapc_connection *conn)
|
||||
static void imapc_connection_reconnect(struct imapc_connection *conn)
|
||||
{
|
||||
conn->reconnect_ok = FALSE;
|
||||
+ conn->reconnect_waiting = FALSE;
|
||||
|
||||
if (conn->selected_box != NULL)
|
||||
imapc_client_mailbox_reconnect(conn->selected_box);
|
||||
@@ -536,6 +538,7 @@ imapc_connection_try_reconnect(struct imapc_connection *conn,
|
||||
imapc_connection_disconnect_full(conn, TRUE);
|
||||
conn->to = timeout_add(delay_msecs, imapc_connection_reconnect, conn);
|
||||
conn->reconnect_count++;
|
||||
+ conn->reconnect_waiting = TRUE;
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -1785,6 +1788,12 @@ void imapc_connection_connect(struct imapc_connection *conn)
|
||||
|
||||
if (conn->fd != -1 || conn->dns_lookup != NULL)
|
||||
return;
|
||||
+ if (conn->reconnect_waiting) {
|
||||
+ /* wait for the reconnection delay to finish before
|
||||
+ doing anything. */
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
conn->reconnecting = FALSE;
|
||||
/* if we get disconnected before we've finished all the pending
|
||||
commands, don't reconnect */
|
||||
@@ -1792,22 +1801,6 @@ void imapc_connection_connect(struct imapc_connection *conn)
|
||||
array_count(&conn->cmd_send_queue);
|
||||
|
||||
imapc_connection_input_reset(conn);
|
||||
-
|
||||
- int msecs_since_last_connect =
|
||||
- timeval_diff_msecs(&ioloop_timeval, &conn->last_connect);
|
||||
- if (!conn->reconnect_ok &&
|
||||
- msecs_since_last_connect < (int)conn->client->set.connect_retry_interval_msecs) {
|
||||
- if (conn->to != NULL)
|
||||
- timeout_remove(&conn->to);
|
||||
- conn->reconnecting = TRUE;
|
||||
- imapc_connection_set_disconnected(conn);
|
||||
- /* don't wait longer than necessary */
|
||||
- unsigned int delay_msecs =
|
||||
- conn->client->set.connect_retry_interval_msecs -
|
||||
- msecs_since_last_connect;
|
||||
- conn->to = timeout_add(delay_msecs, imapc_connection_reconnect, conn);
|
||||
- return;
|
||||
- }
|
||||
conn->last_connect = ioloop_timeval;
|
||||
|
||||
if (conn->client->set.debug) {
|
21
dovecot.spec
21
dovecot.spec
@ -3,7 +3,7 @@
|
||||
Summary: Secure imap and pop3 server
|
||||
Name: dovecot
|
||||
Epoch: 1
|
||||
Version: 2.2.29
|
||||
Version: 2.2.29.1
|
||||
%global prever %{nil}
|
||||
Release: 1%{?dist}
|
||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||
@ -14,7 +14,7 @@ URL: http://www.dovecot.org/
|
||||
Source: http://www.dovecot.org/releases/2.2/%{name}-%{version}%{?prever}.tar.gz
|
||||
Source1: dovecot.init
|
||||
Source2: dovecot.pam
|
||||
%global pigeonholever 0.4.17
|
||||
%global pigeonholever 0.4.18
|
||||
Source8: http://pigeonhole.dovecot.org/releases/2.2/dovecot-2.2-pigeonhole-%{pigeonholever}.tar.gz
|
||||
Source9: dovecot.sysconfig
|
||||
Source10: dovecot.tmpfilesd
|
||||
@ -33,7 +33,6 @@ Patch7: dovecot-2.2.13-online.patch
|
||||
|
||||
Patch8: dovecot-2.2.20-initbysystemd.patch
|
||||
Patch9: dovecot-2.2.22-systemd_w_protectsystem.patch
|
||||
Patch10: dovecot-2.2.29-3a1c64363a64cdfe9153eb6292d8923f38955d82.patch
|
||||
|
||||
Source15: prestartscript
|
||||
|
||||
@ -130,7 +129,6 @@ This package provides the development files for dovecot.
|
||||
%patch7 -p1 -b .online
|
||||
%patch8 -p1 -b .initbysystemd
|
||||
%patch9 -p1 -b .systemd_w_protectsystem
|
||||
%patch10 -p1 -b .3a1c64363a64cdfe9153eb6292d8923f38955d82
|
||||
|
||||
#pushd dovecot-2*2-pigeonhole-%{pigeonholever}
|
||||
#popd
|
||||
@ -490,6 +488,21 @@ make check
|
||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||
|
||||
%changelog
|
||||
* Wed Apr 12 2017 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.29.1-1
|
||||
- dovecot updated to 2.2.29.1
|
||||
- dict-sql: Merging multiple UPDATEs to a single statement wasn't
|
||||
actually working.
|
||||
- pigeonhole updated to 0.4.18
|
||||
- imapsieve plugin: Implemented the copy_source_after rule action. When this
|
||||
is enabled for a mailbox rule, the specified Sieve script is executed for
|
||||
the message in the source mailbox during a "COPY" event. This happens only
|
||||
after the Sieve script that is executed for the corresponding message in the
|
||||
destination mailbox finishes running successfully.
|
||||
- imapsieve plugin: Added non-standard Sieve environment items for the source
|
||||
and destination mailbox.
|
||||
- multiscript: The execution of the discard script had an implicit "keep",
|
||||
rather than an implicit "discard".
|
||||
|
||||
* Tue Apr 11 2017 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.29-1
|
||||
- dovecot updated to 2.2.29
|
||||
- fts-tika: Fixed crash when parsing attachment without
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (dovecot-2.2.29.tar.gz) = 75d3160d7ad5c4c753639bc0dc2eab4e91592e865081b94a71354a16a6ce3bb7a94dbb10191b9e4d18159eee95889fd4c07df2362637faa1357a5f5328ff002f
|
||||
SHA512 (dovecot-2.2-pigeonhole-0.4.17.tar.gz) = 3ea6faebf04154649c32612f204e909aa131582c99867865bff3d3a78a75593d96109586eeb6403bc915046b8b6f02e8bacbf6cb6733ea186d2e1a209a7e2b79
|
||||
SHA512 (dovecot-2.2.29.1.tar.gz) = 1e5ea6080ebe7dd4afe6fcfe8e98ed6d2ad2735655a18cc96e439dd044ccc3a1a6a80428bc746b4d6250820895d6a62121562e97e4b46c8b1cf88a19443bc111
|
||||
SHA512 (dovecot-2.2-pigeonhole-0.4.18.tar.gz) = 6f49a6a6435b0e4dcbe29f852ce17c016df2f367f5460301a2a2c6bd5f5ba6260b23bfe1c5e78b91c6041554ee67d1ce14ad3adf219505f692c61681d9e70cc4
|
||||
|
Loading…
Reference in New Issue
Block a user