fix crash related to logging BYE notifications (#1176282)
- update pigeonhole to 0.4.6
This commit is contained in:
parent
a0c43f9f3e
commit
36260035e4
1
.gitignore
vendored
1
.gitignore
vendored
@ -84,3 +84,4 @@ pigeonhole-snap0592366457df.tar.bz2
|
|||||||
/dovecot-2.2-pigeonhole-0.4.3.tar.gz
|
/dovecot-2.2-pigeonhole-0.4.3.tar.gz
|
||||||
/dovecot-2.2.15.tar.gz
|
/dovecot-2.2.15.tar.gz
|
||||||
/pigeonhole-snapded0c5a467aa.tar.bz2
|
/pigeonhole-snapded0c5a467aa.tar.bz2
|
||||||
|
/dovecot-2.2-pigeonhole-0.4.6.tar.gz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
|
|
||||||
# HG changeset patch
|
|
||||||
# User Stephan Bosch <stephan@rename-it.nl>
|
|
||||||
# Date 1414266676 -7200
|
|
||||||
# Node ID 15b2910b145c5e16fb9967d16387fc24104b0925
|
|
||||||
# Parent 819b8fb22034a761b45c88f021a1e8b857ccacb4
|
|
||||||
Adjusted to datastack-related changes in Dovecot lib-storage.
|
|
||||||
|
|
||||||
diff -r 819b8fb22034 -r 15b2910b145c src/lib-sieve/util/edit-mail.c
|
|
||||||
--- a/src/lib-sieve/util/edit-mail.c Sun Oct 19 22:50:23 2014 +0200
|
|
||||||
+++ b/src/lib-sieve/util/edit-mail.c Sat Oct 25 21:51:16 2014 +0200
|
|
||||||
@@ -1473,7 +1473,7 @@
|
|
||||||
(&edmail->wrapped->mail, field_name, decode_to_utf8, value_r);
|
|
||||||
}
|
|
||||||
|
|
||||||
- t_array_init(&header_values, 1);
|
|
||||||
+ p_array_init(&header_values, edmail->mail.pool, 1);
|
|
||||||
(void)array_append_space(&header_values);
|
|
||||||
*value_r = array_idx(&header_values, 0);
|
|
||||||
return 0;
|
|
||||||
@@ -1489,7 +1489,7 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Fill result array */
|
|
||||||
- t_array_init(&header_values, 32);
|
|
||||||
+ p_array_init(&header_values, edmail->mail.pool, 32);
|
|
||||||
field_idx = header_idx->first;
|
|
||||||
while ( field_idx != NULL ) {
|
|
||||||
|
|
||||||
|
|
||||||
|
|
24
dovecot-2.2.15-03889e81929e.patch
Normal file
24
dovecot-2.2.15-03889e81929e.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
|
||||||
|
# HG changeset patch
|
||||||
|
# User Timo Sirainen <tss@iki.fi>
|
||||||
|
# Date 1414434274 -7200
|
||||||
|
# Node ID 03889e81929ef19653fe8842abac515f7764a526
|
||||||
|
# Parent c77d602d4be48f705977cf0d4eca963408b7c1f0
|
||||||
|
master: Don't send broken BYE notifications to log process.
|
||||||
|
|
||||||
|
diff -r c77d602d4be4 -r 03889e81929e src/master/service-log.c
|
||||||
|
--- a/src/master/service-log.c Mon Oct 27 20:14:47 2014 +0200
|
||||||
|
+++ b/src/master/service-log.c Mon Oct 27 20:24:34 2014 +0200
|
||||||
|
@@ -55,6 +55,11 @@
|
||||||
|
{
|
||||||
|
const char *data;
|
||||||
|
|
||||||
|
+ if (process->service->log_process_internal_fd == -1) {
|
||||||
|
+ /* another log process was just destroyed */
|
||||||
|
+ return 0;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
data = t_strdup_printf("%d %s BYE\n",
|
||||||
|
process->service->log_process_internal_fd,
|
||||||
|
dec2str(process->pid));
|
||||||
|
|
17
dovecot.spec
17
dovecot.spec
@ -5,7 +5,7 @@ Name: dovecot
|
|||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.2.15
|
Version: 2.2.15
|
||||||
%global prever %{nil}
|
%global prever %{nil}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||||
License: MIT and LGPLv2
|
License: MIT and LGPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -14,7 +14,7 @@ URL: http://www.dovecot.org/
|
|||||||
Source: http://www.dovecot.org/releases/2.2/%{name}-%{version}%{?prever}.tar.gz
|
Source: http://www.dovecot.org/releases/2.2/%{name}-%{version}%{?prever}.tar.gz
|
||||||
Source1: dovecot.init
|
Source1: dovecot.init
|
||||||
Source2: dovecot.pam
|
Source2: dovecot.pam
|
||||||
%global pigeonholever 0.4.3
|
%global pigeonholever 0.4.6
|
||||||
Source8: http://www.rename-it.nl/dovecot/2.2/dovecot-2.2-pigeonhole-%{pigeonholever}.tar.gz
|
Source8: http://www.rename-it.nl/dovecot/2.2/dovecot-2.2-pigeonhole-%{pigeonholever}.tar.gz
|
||||||
#wget http://hg.rename-it.nl/dovecot-2.2-pigeonhole/archive/%{pigeonholever}.tar.bz2 -O dovecot-2.2-pigeonhole-%{pigeonholever}.tar.bz2
|
#wget http://hg.rename-it.nl/dovecot-2.2-pigeonhole/archive/%{pigeonholever}.tar.bz2 -O dovecot-2.2-pigeonhole-%{pigeonholever}.tar.bz2
|
||||||
#Source8: dovecot-2.2-pigeonhole-%{pigeonholever}.tar.bz2
|
#Source8: dovecot-2.2-pigeonhole-%{pigeonholever}.tar.bz2
|
||||||
@ -36,7 +36,7 @@ Patch5: dovecot-2.1-privatetmp.patch
|
|||||||
#wait for network
|
#wait for network
|
||||||
Patch6: dovecot-2.1.10-waitonline.patch
|
Patch6: dovecot-2.1.10-waitonline.patch
|
||||||
Patch7: dovecot-2.2.13-online.patch
|
Patch7: dovecot-2.2.13-online.patch
|
||||||
Patch8: d-2.2.15-pigeonbuildfix.patch
|
Patch9: dovecot-2.2.15-03889e81929e.patch
|
||||||
|
|
||||||
Source15: prestartscript
|
Source15: prestartscript
|
||||||
|
|
||||||
@ -134,9 +134,9 @@ This package provides the development files for dovecot.
|
|||||||
%patch5 -p1 -b .privatetmp
|
%patch5 -p1 -b .privatetmp
|
||||||
%patch6 -p1 -b .waitonline
|
%patch6 -p1 -b .waitonline
|
||||||
%patch7 -p1 -b .online
|
%patch7 -p1 -b .online
|
||||||
pushd dovecot-2*2-pigeonhole-%{pigeonholever}
|
%patch9 -p1 -b .03889e81929e
|
||||||
%patch8 -p1 -b .pigeonbuildfix
|
#pushd dovecot-2*2-pigeonhole-%{pigeonholever}
|
||||||
popd
|
#popd
|
||||||
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
|
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -471,6 +471,7 @@ make check
|
|||||||
%{_libdir}/dovecot/doveadm/*sieve*
|
%{_libdir}/dovecot/doveadm/*sieve*
|
||||||
%{_libdir}/dovecot/*_sieve_plugin.so
|
%{_libdir}/dovecot/*_sieve_plugin.so
|
||||||
%{_libdir}/dovecot/settings/libmanagesieve_*.so
|
%{_libdir}/dovecot/settings/libmanagesieve_*.so
|
||||||
|
%{_libdir}/dovecot/settings/libpigeonhole_*.so
|
||||||
%{_libdir}/dovecot/sieve/
|
%{_libdir}/dovecot/sieve/
|
||||||
|
|
||||||
%{_mandir}/man1/sieve-dump.1*
|
%{_mandir}/man1/sieve-dump.1*
|
||||||
@ -491,6 +492,10 @@ make check
|
|||||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 05 2015 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.15-2
|
||||||
|
- fix crash related to logging BYE notifications (#1176282)
|
||||||
|
- update pigeonhole to 0.4.6
|
||||||
|
|
||||||
* Thu Oct 30 2014 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.15-1
|
* Thu Oct 30 2014 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.15-1
|
||||||
- dovecot updated to 2.2.15
|
- dovecot updated to 2.2.15
|
||||||
- various race condition fixes to LAYOUT=index
|
- various race condition fixes to LAYOUT=index
|
||||||
|
Loading…
Reference in New Issue
Block a user