dovecot updated to 2.2.32
Modseq tracking didn't always work correctly. This could have caused imap unhibernation to fail or IMAP QRESYNC/CONDSTORE extensions to not work perfectly. mdbox: "Inconsistency in map index" wasn't fixed automatically dict-ldap: %variable values used in the LDAP filter weren't escaped. quota=count: quota_warning = -storage=.. was never executed (try #2). imapc: >= 32 kB mail bodies were supposed to be cached for subsequent FETCHes, but weren't. quota-status service didn't support recipient_delimiter acl: Don't access dovecot-acl-list files with acl_globals_only=yes mail_location: If INDEX dir is set, mailbox deletion deletes its childrens' indexes. director: v2.2.31 caused rapid reconnection loops to directors that were down.
This commit is contained in:
parent
45577f1282
commit
2d992c6f39
1
.gitignore
vendored
1
.gitignore
vendored
@ -115,3 +115,4 @@ pigeonhole-snap0592366457df.tar.bz2
|
||||
/dovecot-2.2.30.2.tar.gz
|
||||
/dovecot-2.2.31.tar.gz
|
||||
/dovecot-2.2-pigeonhole-0.4.19.tar.gz
|
||||
/dovecot-2.2.32.tar.gz
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 64d2efdc4b0bdf92249840e9db89b91c8dc0f3a3 Mon Sep 17 00:00:00 2001
|
||||
From: Timo Sirainen <timo.sirainen@dovecot.fi>
|
||||
Date: Sat, 17 Jun 2017 14:38:22 +0300
|
||||
Subject: [PATCH] imap: Fix NOTIFY to parse more than just the first
|
||||
event-group
|
||||
|
||||
---
|
||||
src/imap/cmd-notify.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/imap/cmd-notify.c b/src/imap/cmd-notify.c
|
||||
index 4c6aad975..94cf103b8 100644
|
||||
--- a/src/imap/cmd-notify.c
|
||||
+++ b/src/imap/cmd-notify.c
|
||||
@@ -292,10 +292,10 @@ cmd_notify_set(struct imap_notify_context *ctx, const struct imap_arg *args)
|
||||
ctx->send_immediate_status = TRUE;
|
||||
args++;
|
||||
}
|
||||
+ for (; args->type != IMAP_ARG_EOL; args++) {
|
||||
+ if (!imap_arg_get_list(args, &event_group))
|
||||
+ return -1;
|
||||
|
||||
- if (!imap_arg_get_list(args, &event_group))
|
||||
- return -1;
|
||||
- for (; event_group->type != IMAP_ARG_EOL; event_group++) {
|
||||
/* filter-mailboxes */
|
||||
if (!imap_arg_get_atom(event_group, &filter_mailboxes))
|
||||
return -1;
|
23
dovecot.spec
23
dovecot.spec
@ -3,9 +3,9 @@
|
||||
Summary: Secure imap and pop3 server
|
||||
Name: dovecot
|
||||
Epoch: 1
|
||||
Version: 2.2.31
|
||||
Version: 2.2.32
|
||||
%global prever %{nil}
|
||||
Release: 5%{?dist}
|
||||
Release: 1%{?dist}
|
||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||
License: MIT and LGPLv2
|
||||
Group: System Environment/Daemons
|
||||
@ -33,7 +33,6 @@ Patch7: dovecot-2.2.13-online.patch
|
||||
|
||||
Patch8: dovecot-2.2.20-initbysystemd.patch
|
||||
Patch9: dovecot-2.2.22-systemd_w_protectsystem.patch
|
||||
Patch10: dovecot-2.2.31-notifyrevert.patch
|
||||
|
||||
Source15: prestartscript
|
||||
|
||||
@ -131,7 +130,6 @@ This package provides the development files for dovecot.
|
||||
%patch7 -p1 -b .online
|
||||
%patch8 -p1 -b .initbysystemd
|
||||
%patch9 -p1 -b .systemd_w_protectsystem
|
||||
%patch10 -p1 -b .notifyrevert
|
||||
|
||||
#pushd dovecot-2*2-pigeonhole-%{pigeonholever}
|
||||
#popd
|
||||
@ -492,6 +490,23 @@ make check
|
||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||
|
||||
%changelog
|
||||
* Fri Aug 25 2017 Michal Hlavinka <mhlavink@redhat.com> - 1:2.2.32-1
|
||||
- dovecot updated to 2.2.32
|
||||
- Modseq tracking didn't always work correctly. This could have caused
|
||||
imap unhibernation to fail or IMAP QRESYNC/CONDSTORE extensions to
|
||||
not work perfectly.
|
||||
- mdbox: "Inconsistency in map index" wasn't fixed automatically
|
||||
- dict-ldap: %variable values used in the LDAP filter weren't escaped.
|
||||
- quota=count: quota_warning = -storage=.. was never executed (try #2).
|
||||
- imapc: >= 32 kB mail bodies were supposed to be cached for subsequent
|
||||
FETCHes, but weren't.
|
||||
- quota-status service didn't support recipient_delimiter
|
||||
- acl: Don't access dovecot-acl-list files with acl_globals_only=yes
|
||||
- mail_location: If INDEX dir is set, mailbox deletion deletes its
|
||||
childrens' indexes.
|
||||
- director: v2.2.31 caused rapid reconnection loops to directors
|
||||
that were down.
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:2.2.31-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (dovecot-2.2.31.tar.gz) = 071797e260a75de9117b03c0fa9d903de82b1f1c039c2aece2d7313587e6673c49174bfce17b80fe3f3725fcbc42ed3a1bd1f1c22efef5bc016752277eff3266
|
||||
SHA512 (dovecot-2.2.32.tar.gz) = a26ce763fdea7d72ff9801d3b7d57a1f0d00278e4a1aa60d1be070fe5a6d2c6a15f266a519119492bee7a3e7a6b7d0732e9879e5c5841adbab8c0952cd1b7c7c
|
||||
SHA512 (dovecot-2.2-pigeonhole-0.4.19.tar.gz) = c1211a3c65b25995770309c427ec5cd888ddb962f2f64884640163b492a11ffa8937aac1eb66d25e48f0e00131da1cc98c1cb307781576780de47b8816333ff1
|
||||
|
Loading…
Reference in New Issue
Block a user