use libxcrypt for Fedora >= 28, part of ftbfs fix (#1548520)
This commit is contained in:
parent
6f1094ca9f
commit
233f79dabd
11
dovecot-2.3.0.1-libxcrypt.patch
Normal file
11
dovecot-2.3.0.1-libxcrypt.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up dovecot-2.3.0.1/src/auth/mycrypt.c.libxcrypt dovecot-2.3.0.1/src/auth/mycrypt.c
|
||||||
|
--- dovecot-2.3.0.1/src/auth/mycrypt.c.libxcrypt 2018-02-28 15:28:58.000000000 +0100
|
||||||
|
+++ dovecot-2.3.0.1/src/auth/mycrypt.c 2018-03-27 10:57:38.447769201 +0200
|
||||||
|
@@ -14,6 +14,7 @@
|
||||||
|
# define _XPG6 /* Some Solaris versions require this, some break with this */
|
||||||
|
#endif
|
||||||
|
#include <unistd.h>
|
||||||
|
+#include <crypt.h>
|
||||||
|
|
||||||
|
#include "mycrypt.h"
|
||||||
|
|
11
dovecot.spec
11
dovecot.spec
@ -5,7 +5,7 @@ Name: dovecot
|
|||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.3.0.1
|
Version: 2.3.0.1
|
||||||
%global prever %{nil}
|
%global prever %{nil}
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||||
License: MIT and LGPLv2
|
License: MIT and LGPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -32,6 +32,7 @@ Patch6: dovecot-2.1.10-waitonline.patch
|
|||||||
|
|
||||||
Patch8: dovecot-2.2.20-initbysystemd.patch
|
Patch8: dovecot-2.2.20-initbysystemd.patch
|
||||||
Patch9: dovecot-2.2.22-systemd_w_protectsystem.patch
|
Patch9: dovecot-2.2.22-systemd_w_protectsystem.patch
|
||||||
|
Patch10: dovecot-2.3.0.1-libxcrypt.patch
|
||||||
|
|
||||||
Source15: prestartscript
|
Source15: prestartscript
|
||||||
|
|
||||||
@ -44,6 +45,7 @@ BuildRequires: mysql-devel
|
|||||||
BuildRequires: tcp_wrappers-devel
|
BuildRequires: tcp_wrappers-devel
|
||||||
%else
|
%else
|
||||||
BuildRequires: mariadb-connector-c-devel
|
BuildRequires: mariadb-connector-c-devel
|
||||||
|
BuildRequires: libxcrypt-devel
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: openldap-devel
|
BuildRequires: openldap-devel
|
||||||
BuildRequires: krb5-devel
|
BuildRequires: krb5-devel
|
||||||
@ -132,6 +134,7 @@ This package provides the development files for dovecot.
|
|||||||
%patch6 -p1 -b .waitonline
|
%patch6 -p1 -b .waitonline
|
||||||
%patch8 -p1 -b .initbysystemd
|
%patch8 -p1 -b .initbysystemd
|
||||||
%patch9 -p1 -b .systemd_w_protectsystem
|
%patch9 -p1 -b .systemd_w_protectsystem
|
||||||
|
%patch10 -p1 -b .libxcrypt
|
||||||
|
|
||||||
#pushd dovecot-2*3-pigeonhole-%{pigeonholever}
|
#pushd dovecot-2*3-pigeonhole-%{pigeonholever}
|
||||||
#popd
|
#popd
|
||||||
@ -382,6 +385,7 @@ make check
|
|||||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-imap.conf
|
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-imap.conf
|
||||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-lmtp.conf
|
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-lmtp.conf
|
||||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-pop3.conf
|
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-pop3.conf
|
||||||
|
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-submission.conf
|
||||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-acl.conf
|
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-acl.conf
|
||||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-quota.conf
|
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-quota.conf
|
||||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-plugin.conf
|
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-plugin.conf
|
||||||
@ -428,6 +432,8 @@ make check
|
|||||||
%{_libdir}/dovecot/libfs_mail_crypt.so
|
%{_libdir}/dovecot/libfs_mail_crypt.so
|
||||||
%{_libdir}/dovecot/libdcrypt_openssl.so
|
%{_libdir}/dovecot/libdcrypt_openssl.so
|
||||||
%{_libdir}/dovecot/lib20_var_expand_crypt.so
|
%{_libdir}/dovecot/lib20_var_expand_crypt.so
|
||||||
|
%{_libdir}/dovecot/old-stats/libold_stats_mail.so
|
||||||
|
%{_libdir}/dovecot/old-stats/libstats_auth.so
|
||||||
|
|
||||||
%dir %{_libdir}/dovecot/settings
|
%dir %{_libdir}/dovecot/settings
|
||||||
|
|
||||||
@ -491,6 +497,9 @@ make check
|
|||||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 27 2018 Michal Hlavinka <mhlavink@redhat.com> - 1:2.3.0.1-3
|
||||||
|
- use libxcrypt for Fedora >= 28, part of ftbfs fix (#1548520)
|
||||||
|
|
||||||
* Wed Mar 07 2018 Michal Hlavinka <mhlavink@redhat.com> - 1:2.3.0.1-2
|
* Wed Mar 07 2018 Michal Hlavinka <mhlavink@redhat.com> - 1:2.3.0.1-2
|
||||||
- add gcc buildrequire
|
- add gcc buildrequire
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user