updated to 2.1.rc5
- director: With >2 directors ring syncing might have stalled during director connect/disconnect, causing logins to fail. - LMTP client/proxy: Fixed potential hanging when sending (big) mails - Compressed mails with external attachments (dbox + SIS + zlib) failed sometimes with bogus "cached message size wrong" errors.
This commit is contained in:
parent
28b12314fc
commit
22b84f8ed2
2
.gitignore
vendored
2
.gitignore
vendored
@ -34,3 +34,5 @@ pigeonhole-snap0592366457df.tar.bz2
|
||||
/dovecot-2.1.rc1.tar.gz
|
||||
/dovecot-2.1-pigeonhole-b3bff60a18da.tar.bz2
|
||||
/dovecot-2.1.rc3.tar.gz
|
||||
/dovecot-2.1.rc5.tar.gz
|
||||
/dovecot-2.1-pigeonhole-a130a50f82e1.tar.bz2
|
||||
|
@ -1,55 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Timo Sirainen <tss@iki.fi>
|
||||
# Date 1289937106 0
|
||||
# Node ID eeaf30cfad368fd0311b87d874f2d5b27a504e0f
|
||||
# Parent f78260c108b0d86e5aa746e7e98a8015b8f691e7
|
||||
Fixed home=/home/./user style chrooting to work again.
|
||||
|
||||
--- a/src/lib-storage/mail-storage-service.c Tue Nov 16 19:32:51 2010 +0000
|
||||
+++ b/src/lib-storage/mail-storage-service.c Tue Nov 16 19:51:46 2010 +0000
|
||||
@@ -167,7 +167,9 @@
|
||||
const struct auth_user_reply *reply,
|
||||
const char **error_r)
|
||||
{
|
||||
- const char *const *str, *line;
|
||||
+ const char *home = reply->home;
|
||||
+ const char *chroot = reply->chroot;
|
||||
+ const char *const *str, *line, *p;
|
||||
unsigned int i, count;
|
||||
int ret = 0;
|
||||
|
||||
@@ -181,18 +183,26 @@
|
||||
if (reply->gid != (uid_t)-1)
|
||||
set_keyval(ctx, user, "mail_gid", dec2str(reply->gid));
|
||||
|
||||
- if (reply->home != NULL)
|
||||
+ if (home != NULL && chroot == NULL &&
|
||||
+ *user->user_set->valid_chroot_dirs != '\0' &&
|
||||
+ (p = strstr(home, "/./")) != NULL) {
|
||||
+ /* wu-ftpd like <chroot>/./<home> - check only if there's even
|
||||
+ a possibility of using them (non-empty valid_chroot_dirs) */
|
||||
+ chroot = t_strdup_until(home, p);
|
||||
+ home = p + 2;
|
||||
+ }
|
||||
+
|
||||
+ if (home != NULL)
|
||||
set_keyval(ctx, user, "mail_home", reply->home);
|
||||
|
||||
- if (reply->chroot != NULL) {
|
||||
- if (!validate_chroot(user->user_set, reply->chroot)) {
|
||||
+ if (chroot != NULL) {
|
||||
+ if (!validate_chroot(user->user_set, chroot)) {
|
||||
*error_r = t_strdup_printf(
|
||||
"userdb returned invalid chroot directory: %s "
|
||||
- "(see valid_chroot_dirs setting)",
|
||||
- reply->chroot);
|
||||
+ "(see valid_chroot_dirs setting)", chroot);
|
||||
return -1;
|
||||
}
|
||||
- set_keyval(ctx, user, "mail_chroot", reply->chroot);
|
||||
+ set_keyval(ctx, user, "mail_chroot", chroot);
|
||||
}
|
||||
|
||||
str = array_get(&reply->extra_fields, &count);
|
||||
|
||||
|
19
dovecot.spec
19
dovecot.spec
@ -2,8 +2,8 @@ Summary: Secure imap and pop3 server
|
||||
Name: dovecot
|
||||
Epoch: 1
|
||||
Version: 2.1
|
||||
%global prever .rc3
|
||||
Release: 0.4%{prever}%{?dist}
|
||||
%global prever .rc5
|
||||
Release: 0.5%{prever}%{?dist}
|
||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||
License: MIT and LGPLv2
|
||||
Group: System Environment/Daemons
|
||||
@ -14,8 +14,9 @@ URL: http://www.dovecot.org/
|
||||
Source: http://www.dovecot.org/releases/2.1/%{name}-%{version}%{?prever}.tar.gz
|
||||
Source1: dovecot.init
|
||||
Source2: dovecot.pam
|
||||
%global pigeonholever b3bff60a18da
|
||||
%global pigeonholever a130a50f82e1
|
||||
#Source8: http://www.rename-it.nl/dovecot/2.1/dovecot-2.1-pigeonhole-%{pigeonholever}.tar.gz
|
||||
#wget http://hg.rename-it.nl/dovecot-2.1-pigeonhole/archive/%{pigeonholever}.tar.bz2 -O dovecot-2.1-pigeonhole-%{pigeonholever}.tar.bz2
|
||||
Source8: dovecot-2.1-pigeonhole-%{pigeonholever}.tar.bz2
|
||||
Source9: dovecot.sysconfig
|
||||
Source10: dovecot.tmpfilesd
|
||||
@ -379,6 +380,7 @@ make check
|
||||
%files pigeonhole
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/sieve-dump
|
||||
%{_bindir}/sieve-filter
|
||||
%{_bindir}/sieve-test
|
||||
%{_bindir}/sievec
|
||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-sieve.conf
|
||||
@ -389,8 +391,9 @@ make check
|
||||
%dir %{_libdir}/dovecot/settings
|
||||
%{_libdir}/dovecot/settings/libmanagesieve_*.so
|
||||
|
||||
%{_mandir}/man1/sieve-test.1.gz
|
||||
%{_mandir}/man1/sieve-dump.1.gz
|
||||
%{_mandir}/man1/sieve-filter.1.gz
|
||||
%{_mandir}/man1/sieve-test.1.gz
|
||||
%{_mandir}/man1/sievec.1.gz
|
||||
%{_mandir}/man1/sieved.1.gz
|
||||
%{_mandir}/man7/pigeonhole.7.gz
|
||||
@ -408,6 +411,14 @@ make check
|
||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||
|
||||
%changelog
|
||||
* Tue Feb 07 2012 Michal Hlavinka <mhlavink@redhat.com> - 1:2.1-0.5.rc5
|
||||
- updated to 2.1.rc5
|
||||
- director: With >2 directors ring syncing might have stalled during
|
||||
director connect/disconnect, causing logins to fail.
|
||||
- LMTP client/proxy: Fixed potential hanging when sending (big) mails
|
||||
- Compressed mails with external attachments (dbox + SIS + zlib) failed
|
||||
sometimes with bogus "cached message size wrong" errors.
|
||||
|
||||
* Mon Jan 09 2012 Michal Hlavinka <mhlavink@redhat.com> - 1:2.1-0.4.rc3
|
||||
- updated to 2.1.rc3
|
||||
- dsync was merged into doveadm
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
40c813cffc375f27b035aa09893b58bd dovecot-2.1.rc3.tar.gz
|
||||
fb26d79aa43f5319b3d392bc1090df78 dovecot-2.1-pigeonhole-b3bff60a18da.tar.bz2
|
||||
400eecbfb9e9d8f82b98269f73685acc dovecot-2.1.rc5.tar.gz
|
||||
1d7d996cf64aaab89cc93e8a177fb8c0 dovecot-2.1-pigeonhole-a130a50f82e1.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user