update to 1.2.rc2
This commit is contained in:
parent
850e204943
commit
208c1a547e
@ -1,4 +1,4 @@
|
||||
dovecot-1.2-managesieve-0.11.3.tar.gz
|
||||
dovecot-1.2.beta4.tar.gz
|
||||
dovecot-1.2.beta4-managesieve-0.11.3.diff.gz
|
||||
dovecot-1.2.rc2.tar.gz
|
||||
dovecot-1.2.rc2-managesieve-0.11.3.diff.gz
|
||||
dovecot-sieve-1.1.6.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up dovecot-1.2.beta4/dovecot-example.conf.default-settings dovecot-1.2.beta4/dovecot-example.conf
|
||||
--- dovecot-1.2.beta4/dovecot-example.conf.default-settings 2009-03-30 15:56:26.941208108 +0200
|
||||
+++ dovecot-1.2.beta4/dovecot-example.conf 2009-03-30 15:56:26.969311839 +0200
|
||||
diff -up dovecot-1.2.rc2/dovecot-example.conf.default-settings dovecot-1.2.rc2/dovecot-example.conf
|
||||
--- dovecot-1.2.rc2/dovecot-example.conf.default-settings 2009-04-06 10:45:53.519651253 +0200
|
||||
+++ dovecot-1.2.rc2/dovecot-example.conf 2009-04-06 10:45:53.525647967 +0200
|
||||
@@ -10,17 +10,14 @@
|
||||
# value inside quotes, eg.: key = "# char and trailing whitespace "
|
||||
|
||||
@ -48,7 +48,7 @@ diff -up dovecot-1.2.beta4/dovecot-example.conf.default-settings dovecot-1.2.bet
|
||||
|
||||
# If key file is password protected, give the password here. Alternatively
|
||||
# give it when starting dovecot with -p parameter. Since this file is often
|
||||
@@ -481,7 +478,7 @@
|
||||
@@ -485,7 +482,7 @@
|
||||
# locking methods as well. Some operating systems don't allow using some of
|
||||
# them simultaneously.
|
||||
#mbox_read_locks = fcntl
|
||||
@ -57,9 +57,9 @@ diff -up dovecot-1.2.beta4/dovecot-example.conf.default-settings dovecot-1.2.bet
|
||||
|
||||
# Maximum time in seconds to wait for lock (all of them) before aborting.
|
||||
#mbox_lock_timeout = 300
|
||||
diff -up dovecot-1.2.beta4/src/master/master-settings.c.default-settings dovecot-1.2.beta4/src/master/master-settings.c
|
||||
--- dovecot-1.2.beta4/src/master/master-settings.c.default-settings 2009-03-30 15:56:26.966311559 +0200
|
||||
+++ dovecot-1.2.beta4/src/master/master-settings.c 2009-03-30 15:57:10.994066535 +0200
|
||||
diff -up dovecot-1.2.rc2/src/master/master-settings.c.default-settings dovecot-1.2.rc2/src/master/master-settings.c
|
||||
--- dovecot-1.2.rc2/src/master/master-settings.c.default-settings 2009-04-06 10:45:53.523648309 +0200
|
||||
+++ dovecot-1.2.rc2/src/master/master-settings.c 2009-04-06 10:48:05.630586332 +0200
|
||||
@@ -178,8 +178,8 @@ struct settings default_settings = {
|
||||
MEMBER(syslog_facility) "mail",
|
||||
|
||||
@ -80,9 +80,9 @@ diff -up dovecot-1.2.beta4/src/master/master-settings.c.default-settings dovecot
|
||||
MEMBER(verbose_ssl) FALSE,
|
||||
MEMBER(shutdown_clients) TRUE,
|
||||
MEMBER(nfs_check) TRUE,
|
||||
@@ -254,7 +254,7 @@ struct settings default_settings = {
|
||||
MEMBER(maildir_copy_with_hardlinks) TRUE,
|
||||
@@ -255,7 +255,7 @@ struct settings default_settings = {
|
||||
MEMBER(maildir_copy_preserve_filename) FALSE,
|
||||
MEMBER(maildir_very_dirty_syncs) FALSE,
|
||||
MEMBER(mbox_read_locks) "fcntl",
|
||||
- MEMBER(mbox_write_locks) "dotlock fcntl",
|
||||
+ MEMBER(mbox_write_locks) "fcntl",
|
||||
|
@ -1,104 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Timo Sirainen <tss@iki.fi>
|
||||
# Date 1238106996 14400
|
||||
# Node ID 643a96aec996a6da08e0c2850264872a4a98195d
|
||||
# Parent 7c21256e35986a8f7ddcf843eeee44dd4a08d272
|
||||
Fixed --with-ldap=plugin and --with-gssapi=plugin
|
||||
|
||||
--- a/src/auth/Makefile.am Thu Mar 26 18:17:09 2009 -0400
|
||||
+++ b/src/auth/Makefile.am Thu Mar 26 18:36:36 2009 -0400
|
||||
@@ -48,14 +48,6 @@ dovecot_auth_LDADD = \
|
||||
|
||||
ldap_sources = db-ldap.c passdb-ldap.c userdb-ldap.c
|
||||
|
||||
-if ! LDAP_PLUGIN
|
||||
-builtin_ldap_sources = $(ldap_sources)
|
||||
-endif
|
||||
-
|
||||
-if ! GSSAPI_PLUGIN
|
||||
-builtin_gssapi_sources = mech-gssapi.c
|
||||
-endif
|
||||
-
|
||||
dovecot_auth_SOURCES = \
|
||||
auth.c \
|
||||
auth-cache.c \
|
||||
@@ -77,6 +69,7 @@ dovecot_auth_SOURCES = \
|
||||
mech-login.c \
|
||||
mech-cram-md5.c \
|
||||
mech-digest-md5.c \
|
||||
+ mech-gssapi.c \
|
||||
mech-ntlm.c \
|
||||
mech-otp.c \
|
||||
mech-skey.c \
|
||||
@@ -107,8 +100,7 @@ dovecot_auth_SOURCES = \
|
||||
userdb-static.c \
|
||||
userdb-vpopmail.c \
|
||||
userdb-sql.c \
|
||||
- $(builtin_gssapi_sources) \
|
||||
- $(builtin_ldap_sources)
|
||||
+ $(ldap_sources)
|
||||
|
||||
headers = \
|
||||
auth.h \
|
||||
@@ -144,14 +136,14 @@ if GSSAPI_PLUGIN
|
||||
if GSSAPI_PLUGIN
|
||||
libmech_gssapi_la_LDFLAGS = -module -avoid-version
|
||||
libmech_gssapi_la_LIBADD = $(KRB5_LIBS)
|
||||
-libmech_gssapi_la_CPPFLAGS = $(AM_CPPFLAGS) $(KRB5_CFLAGS)
|
||||
+libmech_gssapi_la_CPPFLAGS = $(AM_CPPFLAGS) $(KRB5_CFLAGS) -DPLUGIN_BUILD
|
||||
libmech_gssapi_la_SOURCES = mech-gssapi.c
|
||||
endif
|
||||
|
||||
if LDAP_PLUGIN
|
||||
libauthdb_ldap_la_LDFLAGS = -module -avoid-version
|
||||
libauthdb_ldap_la_LIBADD = $(LDAP_LIBS)
|
||||
-libauthdb_ldap_la_CPPFLAGS = $(AM_CPPFLAGS)
|
||||
+libauthdb_ldap_la_CPPFLAGS = $(AM_CPPFLAGS) -DPLUGIN_BUILD
|
||||
libauthdb_ldap_la_SOURCES = $(ldap_sources)
|
||||
endif
|
||||
|
||||
--- a/src/auth/db-ldap.c Thu Mar 26 18:17:09 2009 -0400
|
||||
+++ b/src/auth/db-ldap.c Thu Mar 26 18:36:36 2009 -0400
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
#include "common.h"
|
||||
|
||||
-#if defined(PASSDB_LDAP) || defined(USERDB_LDAP)
|
||||
+#if defined(BUILTIN_LDAP) || defined(PLUGIN_BUILD)
|
||||
|
||||
#include "network.h"
|
||||
#include "ioloop.h"
|
||||
--- a/src/auth/mech-gssapi.c Thu Mar 26 18:17:09 2009 -0400
|
||||
+++ b/src/auth/mech-gssapi.c Thu Mar 26 18:36:36 2009 -0400
|
||||
@@ -23,7 +23,7 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
|
||||
-#ifdef HAVE_GSSAPI
|
||||
+#if defined(BUILTIN_GSSAPI) || defined(PLUGIN_BUILD)
|
||||
|
||||
#ifndef HAVE___GSS_USEROK
|
||||
# define USE_KRB5_USEROK
|
||||
--- a/src/auth/passdb-ldap.c Thu Mar 26 18:17:09 2009 -0400
|
||||
+++ b/src/auth/passdb-ldap.c Thu Mar 26 18:36:36 2009 -0400
|
||||
@@ -3,7 +3,7 @@
|
||||
#include "common.h"
|
||||
#include "passdb.h"
|
||||
|
||||
-#ifdef PASSDB_LDAP
|
||||
+#if defined(PASSDB_LDAP) && (defined(BUILTIN_LDAP) || defined(PLUGIN_BUILD))
|
||||
|
||||
#include "ioloop.h"
|
||||
#include "hash.h"
|
||||
--- a/src/auth/userdb-ldap.c Thu Mar 26 18:17:09 2009 -0400
|
||||
+++ b/src/auth/userdb-ldap.c Thu Mar 26 18:36:36 2009 -0400
|
||||
@@ -3,7 +3,7 @@
|
||||
#include "common.h"
|
||||
#include "userdb.h"
|
||||
|
||||
-#ifdef USERDB_LDAP
|
||||
+#if defined(USERDB_LDAP) && (defined(BUILTIN_LDAP) || defined(PLUGIN_BUILD))
|
||||
|
||||
#include "hash.h"
|
||||
#include "str.h"
|
||||
|
14
dovecot.spec
14
dovecot.spec
@ -2,8 +2,8 @@ Summary: Dovecot Secure imap server
|
||||
Name: dovecot
|
||||
Epoch: 1
|
||||
Version: 1.2
|
||||
%define betaver beta4
|
||||
Release: 0.%{betaver}.2%{?dist}
|
||||
%define betaver rc2
|
||||
Release: 0.%{betaver}.1%{?dist}
|
||||
License: MIT and LGPLv2 and BSD with advertising
|
||||
Group: System Environment/Daemons
|
||||
|
||||
@ -33,16 +33,12 @@ Source8: http://dovecot.org/releases/sieve/%{sieve_name}-%{sieve_version}.tar.gz
|
||||
Source9: dovecot.sysconfig
|
||||
Source10: http://www.rename-it.nl/dovecot/1.2/%{managesieve_name}-%{managesieve_version}.tar.gz
|
||||
Source11: http://www.rename-it.nl/dovecot/1.2/dovecot-%{version}.%{betaver}-managesieve-%{managesieve_version}.diff.gz
|
||||
Patch0: dovecot-%{version}.%{betaver}-managesieve-%{managesieve_version}.diff.gz
|
||||
|
||||
# 3x Fedora specific
|
||||
Patch1: dovecot-1.1-default-settings.patch
|
||||
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
|
||||
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
|
||||
|
||||
# from upstream, for dovecot <= 1.2.beta4
|
||||
Patch4: dovecot-1.2-ldap.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: openssl-devel, pam-devel, zlib-devel
|
||||
BuildRequires: libtool autoconf automake
|
||||
@ -171,11 +167,10 @@ This package provides the development files for dovecot.
|
||||
|
||||
%setup -q -n %{name}-%{version}.%{betaver}
|
||||
|
||||
%patch0 -p1 -b .managesieve
|
||||
zcat %{SOURCE11} | patch -p1 --fuzz=0 -s
|
||||
%patch1 -p1 -b .default-settings
|
||||
%patch2 -p1 -b .mkcert-permissions
|
||||
%patch3 -p1 -b .mkcert-paths
|
||||
%patch4 -p1 -b .ldap
|
||||
|
||||
%if %{build_sieve}
|
||||
%setup -q -n %{name}-%{version}.%{betaver} -D -T -a 8
|
||||
@ -434,6 +429,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Apr 06 2009 Michal Hlavinka <mhlavink@redhat.com> - 1:1.2-0.rc2.1
|
||||
- updated to 1.2.rc2
|
||||
|
||||
* Mon Mar 30 2009 Michal Hlavinka <mhlavink@redhat.com> - 1:1.2-0.beta4.2
|
||||
- fix typo and rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
a651e2f12a17157d716eedc622032fdc dovecot-1.2-managesieve-0.11.3.tar.gz
|
||||
9f2e1e0f0f18dbb3d31f255e61bbf722 dovecot-1.2.beta4.tar.gz
|
||||
f7458682b4e17a0b636068cf0daefd65 dovecot-1.2.beta4-managesieve-0.11.3.diff.gz
|
||||
0c568a2eb5170ab287f5f3ef38c13e1a dovecot-1.2.rc2.tar.gz
|
||||
0588f613de160dfee0234954666a6a68 dovecot-1.2.rc2-managesieve-0.11.3.diff.gz
|
||||
7acf3d98974a515b868addbdb73054eb dovecot-sieve-1.1.6.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user