- pigeonhole and dovecot updated to snapshot 20100505
- mdbox: Avoid rebuilding storage if another process already did it - lib-storage: Fixed () sublists in IMAP SEARCH parser - example-config: auth-checkpassword include wasn't listed in 10-auth.conf - doveadm: Added search command - lib-master: Don't crash after timeouting an auth-master request - master: If inet listener uses DNS name, which returns multiple IPs, listen in all of them
This commit is contained in:
parent
941d6dc3d3
commit
05f822bca9
@ -1,2 +1,2 @@
|
||||
dovecot-20100427.tar.gz
|
||||
pigeonhole-snapece958a18920.tar.bzip2
|
||||
dovecot-20100505.tar.gz
|
||||
pigeonhole-snap861ffb523cb9.tar.bzip2
|
||||
|
@ -1,17 +1,19 @@
|
||||
diff -up dovecot-2.0.beta4/dovecot-2-0-pigeonhole-ece958a18920/src/managesieve-login/client.c.betahotfix dovecot-2.0.beta4/dovecot-2-0-pigeonhole-ece958a18920/src/managesieve-login/client.c
|
||||
--- dovecot-2.0.beta4/dovecot-2-0-pigeonhole-ece958a18920/src/managesieve-login/client.c.betahotfix 2010-04-21 18:01:20.668855900 +0200
|
||||
+++ dovecot-2.0.beta4/dovecot-2-0-pigeonhole-ece958a18920/src/managesieve-login/client.c 2010-04-21 18:01:20.689708242 +0200
|
||||
@@ -32,6 +32,13 @@ const char *login_protocol = "managesiev
|
||||
const char *login_process_name = "managesieve-login";
|
||||
unsigned int login_default_port = 4190;
|
||||
diff -up dovecot-2.0.beta4/src/lib-sql/Makefile.am.betahotfix dovecot-2.0.beta4/src/lib-sql/Makefile.am
|
||||
--- dovecot-2.0.beta4/src/lib-sql/Makefile.am.betahotfix 2010-05-05 04:00:03.000000000 +0200
|
||||
+++ dovecot-2.0.beta4/src/lib-sql/Makefile.am 2010-05-05 11:34:17.286805721 +0200
|
||||
@@ -38,13 +38,13 @@ if ! SQL_PLUGINS
|
||||
driver_sources = \
|
||||
driver-mysql.c \
|
||||
driver-pgsql.c \
|
||||
- driver-sqlpool.c \
|
||||
driver-sqlite.c
|
||||
endif
|
||||
|
||||
+const struct login_binary login_binary = {
|
||||
+ .protocol = "managesieve",
|
||||
+ .process_name = "managesieve-login",
|
||||
+ .default_port = 4190,
|
||||
+ .default_ssl_port = 0
|
||||
+};
|
||||
+
|
||||
void login_process_preinit(void)
|
||||
{
|
||||
login_set_roots = managesieve_login_settings_set_roots;
|
||||
libsql_la_SOURCES = \
|
||||
$(dist_sources) \
|
||||
- $(driver_sources)
|
||||
+ $(driver_sources) \
|
||||
+ driver-sqlpool.c
|
||||
nodist_libsql_la_SOURCES = sql-drivers-register.c
|
||||
|
||||
if SQL_PLUGINS
|
||||
|
20
dovecot.spec
20
dovecot.spec
@ -1,11 +1,11 @@
|
||||
%global betasuffix .beta4
|
||||
%global snapsuffix 20100427
|
||||
%global snapsuffix 20100505
|
||||
|
||||
Summary: Secure imap and pop3 server
|
||||
Name: dovecot
|
||||
Epoch: 1
|
||||
Version: 2.0
|
||||
Release: 0.7%{?betasuffix}.%{?snapsuffix}%{?dist}
|
||||
Release: 0.8%{?betasuffix}.%{?snapsuffix}%{?dist}
|
||||
#dovecot itself is MIT, a few sources are PD, (manage)sieve is LGPLv2, perfect_maildir.pl is GPLv2+
|
||||
License: MIT and LGPLv2 and GPLv2+
|
||||
Group: System Environment/Daemons
|
||||
@ -24,7 +24,7 @@ Source1: dovecot.init
|
||||
Source2: dovecot.pam
|
||||
#Source8: http://hg.rename-it.nl/dovecot-2.0-pigeonhole/archive/tip.tar.bz2
|
||||
#we use this ^^^ repository snapshost just renamed to contain last commit in name
|
||||
%global phsnap ece958a18920
|
||||
%global phsnap 861ffb523cb9
|
||||
Source8: pigeonhole-snap%{phsnap}.tar.bzip2
|
||||
Source9: dovecot.sysconfig
|
||||
|
||||
@ -345,8 +345,8 @@ make check
|
||||
%{_bindir}/sieve-test
|
||||
%{_bindir}/sievec
|
||||
%{_bindir}/sieved
|
||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/sieve.conf
|
||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/managesieve.conf
|
||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-sieve.conf
|
||||
%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-managesieve.conf
|
||||
%{_libexecdir}/%{name}/managesieve
|
||||
%{_libexecdir}/%{name}/managesieve-login
|
||||
|
||||
@ -370,6 +370,16 @@ make check
|
||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||
|
||||
%changelog
|
||||
* Wed May 05 2010 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0-0.8.beta4.20100505
|
||||
- pigeonhole and dovecot updated to snapshot 20100505
|
||||
- mdbox: Avoid rebuilding storage if another process already did it
|
||||
- lib-storage: Fixed () sublists in IMAP SEARCH parser
|
||||
- example-config: auth-checkpassword include wasn't listed in 10-auth.conf
|
||||
- doveadm: Added search command
|
||||
- lib-master: Don't crash after timeouting an auth-master request
|
||||
- master: If inet listener uses DNS name, which returns multiple IPs,
|
||||
listen in all of them
|
||||
|
||||
* Wed Apr 28 2010 Michal Hlavinka <mhlavink@redhat.com> - 1:2.0-0.7.beta4.20100427
|
||||
- updated to snapshot 20100427
|
||||
- doveconf <setting name> now prints only the one setting's value
|
||||
|
Loading…
Reference in New Issue
Block a user