dovecot updated to 2.3.5, pigeonhole updated to 0.5.5
This commit is contained in:
parent
436dc795a1
commit
04058156dc
@ -1,69 +0,0 @@
|
|||||||
diff --git a/src/lib-master/test-event-stats.c b/src/lib-master/test-event-stats.c
|
|
||||||
index 8fcb3dd22d..2d8a13cd40 100644
|
|
||||||
--- a/src/lib-master/test-event-stats.c
|
|
||||||
+++ b/src/lib-master/test-event-stats.c
|
|
||||||
@@ -344,7 +344,7 @@ static void test_no_merging2(void)
|
|
||||||
event_unref(&child_ev);
|
|
||||||
test_assert(
|
|
||||||
compare_test_stats_to(
|
|
||||||
- "EVENT %lu 1 0 0"
|
|
||||||
+ "EVENT %"PRIu64" 1 0 0"
|
|
||||||
" stest-event-stats.c %d"
|
|
||||||
" l0 0 ctest2\n", id, l));
|
|
||||||
test_end();
|
|
||||||
@@ -370,12 +370,12 @@ static void test_no_merging3(void)
|
|
||||||
event_unref(&child_ev);
|
|
||||||
test_assert(
|
|
||||||
compare_test_stats_to(
|
|
||||||
- "BEGIN %lu 0 1 0 0"
|
|
||||||
+ "BEGIN %"PRIu64" 0 1 0 0"
|
|
||||||
" stest-event-stats.c %d ctest1\n"
|
|
||||||
- "EVENT %lu 1 1 0"
|
|
||||||
+ "EVENT %"PRIu64" 1 1 0"
|
|
||||||
" stest-event-stats.c %d"
|
|
||||||
" l1 0 ctest2\n"
|
|
||||||
- "END\t%lu\n", idp, lp, idp, l, idp));
|
|
||||||
+ "END\t%"PRIu64"\n", idp, lp, idp, l, idp));
|
|
||||||
test_end();
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -435,7 +435,7 @@ static void test_merge_events2(void)
|
|
||||||
event_unref(&merge_ev2);
|
|
||||||
test_assert(
|
|
||||||
compare_test_stats_to(
|
|
||||||
- "EVENT %lu 1 0 0"
|
|
||||||
+ "EVENT %"PRIu64" 1 0 0"
|
|
||||||
" stest-event-stats.c %d l0 0"
|
|
||||||
" ctest3 ctest2 ctest1 Tkey3"
|
|
||||||
" 10 0 Ikey2 20"
|
|
||||||
@@ -467,11 +467,11 @@ static void test_skip_parents(void)
|
|
||||||
event_unref(&child_ev);
|
|
||||||
test_assert(
|
|
||||||
compare_test_stats_to(
|
|
||||||
- "BEGIN %lu 0 1 0 0"
|
|
||||||
+ "BEGIN %"PRIu64" 0 1 0 0"
|
|
||||||
" stest-event-stats.c %d ctest1\n"
|
|
||||||
- "EVENT %lu 1 3 0 "
|
|
||||||
+ "EVENT %"PRIu64" 1 3 0 "
|
|
||||||
"stest-event-stats.c %d l3 0"
|
|
||||||
- " ctest2\nEND\t%lu\n", id, lp, id, l, id));
|
|
||||||
+ " ctest2\nEND\t%"PRIu64"\n", id, lp, id, l, id));
|
|
||||||
test_end();
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -509,12 +509,12 @@ static void test_merge_events_skip_parents(void)
|
|
||||||
event_unref(&child2_ev);
|
|
||||||
test_assert(
|
|
||||||
compare_test_stats_to(
|
|
||||||
- "BEGIN %lu 0 1 0 0"
|
|
||||||
+ "BEGIN %"PRIu64" 0 1 0 0"
|
|
||||||
" stest-event-stats.c %d ctest1\n"
|
|
||||||
- "EVENT %lu 1 3 0 "
|
|
||||||
+ "EVENT %"PRIu64" 1 3 0 "
|
|
||||||
"stest-event-stats.c %d l3 0 "
|
|
||||||
"ctest4 ctest5 Tkey3 10 0 Skey4"
|
|
||||||
- " str4\nEND\t%lu\n", id, lp, id, l, id));
|
|
||||||
+ " str4\nEND\t%"PRIu64"\n", id, lp, id, l, id));
|
|
||||||
test_end();
|
|
||||||
}
|
|
||||||
|
|
11
dovecot.spec
11
dovecot.spec
@ -3,9 +3,9 @@
|
|||||||
Summary: Secure imap and pop3 server
|
Summary: Secure imap and pop3 server
|
||||||
Name: dovecot
|
Name: dovecot
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.3.4
|
Version: 2.3.5
|
||||||
%global prever %{nil}
|
%global prever %{nil}
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||||
License: MIT and LGPLv2
|
License: MIT and LGPLv2
|
||||||
|
|
||||||
@ -13,7 +13,7 @@ URL: http://www.dovecot.org/
|
|||||||
Source: http://www.dovecot.org/releases/2.3/%{name}-%{version}%{?prever}.tar.gz
|
Source: http://www.dovecot.org/releases/2.3/%{name}-%{version}%{?prever}.tar.gz
|
||||||
Source1: dovecot.init
|
Source1: dovecot.init
|
||||||
Source2: dovecot.pam
|
Source2: dovecot.pam
|
||||||
%global pigeonholever 0.5.4
|
%global pigeonholever 0.5.5
|
||||||
Source8: http://pigeonhole.dovecot.org/releases/2.3/dovecot-2.3-pigeonhole-%{pigeonholever}.tar.gz
|
Source8: http://pigeonhole.dovecot.org/releases/2.3/dovecot-2.3-pigeonhole-%{pigeonholever}.tar.gz
|
||||||
Source9: dovecot.sysconfig
|
Source9: dovecot.sysconfig
|
||||||
Source10: dovecot.tmpfilesd
|
Source10: dovecot.tmpfilesd
|
||||||
@ -32,7 +32,6 @@ Patch6: dovecot-2.1.10-waitonline.patch
|
|||||||
Patch8: dovecot-2.2.20-initbysystemd.patch
|
Patch8: dovecot-2.2.20-initbysystemd.patch
|
||||||
Patch9: dovecot-2.2.22-systemd_w_protectsystem.patch
|
Patch9: dovecot-2.2.22-systemd_w_protectsystem.patch
|
||||||
Patch10: dovecot-2.3.0.1-libxcrypt.patch
|
Patch10: dovecot-2.3.0.1-libxcrypt.patch
|
||||||
Patch11: dovecot-2.3.4-de42b54.patch
|
|
||||||
|
|
||||||
Source15: prestartscript
|
Source15: prestartscript
|
||||||
|
|
||||||
@ -132,7 +131,6 @@ This package provides the development files for dovecot.
|
|||||||
%patch8 -p1 -b .initbysystemd
|
%patch8 -p1 -b .initbysystemd
|
||||||
%patch9 -p1 -b .systemd_w_protectsystem
|
%patch9 -p1 -b .systemd_w_protectsystem
|
||||||
#%patch10 -p1 -b .libxcrypt
|
#%patch10 -p1 -b .libxcrypt
|
||||||
%patch11 -p1 -b .de42b54
|
|
||||||
|
|
||||||
#pushd dovecot-2*3-pigeonhole-%{pigeonholever}
|
#pushd dovecot-2*3-pigeonhole-%{pigeonholever}
|
||||||
#popd
|
#popd
|
||||||
@ -495,6 +493,9 @@ make check
|
|||||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 06 2019 Michal Hlavinka <mhlavink@redhat.com> - 1:2.3.5-1
|
||||||
|
- dovecot updated to 2.3.5, pigeonhole updated to 0.5.5
|
||||||
|
|
||||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:2.3.4-3
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:2.3.4-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (dovecot-2.3.4.tar.gz) = 9e97eb08c319c417e8abcb430b3e6c87ed5aa820d6288656fdfd958ff34664f67202a66e4846763bfc85b309b116cea8012e49dab98b478c57974cc178a37a5a
|
SHA512 (dovecot-2.3.5.tar.gz) = 10513c371aeadd52184daaf8dbb9a7559c6db55e34182bbb2c9539dae0897ddcc76f6fe2ce6a81c7ce0cb94c7f79438ae3bb0e7db8ed46615feb337b4078ecc6
|
||||||
SHA512 (dovecot-2.3-pigeonhole-0.5.4.tar.gz) = 9c82cce7540f8ab66e2e370e0220c99048d6ac53ed680cd763e0b03d0200e2451cee4303ef97b87a16e7248e1c73b92ba91b47a2a20c75cb2cd62695a28046f3
|
SHA512 (dovecot-2.3-pigeonhole-0.5.5.tar.gz) = 21519fc9b1152a947b64ce4251e1a4bdbe003b48233b1856a32696f9c1e29f730268c56eb38f9431bbfac345e6cd42e8c78c87d0702f39ebf20c6d326dcdbb94
|
||||||
|
Loading…
Reference in New Issue
Block a user