21 lines
618 B
Diff
21 lines
618 B
Diff
diff --git a/src/installer/corehost/cli/apphost/static/CMakeLists.txt b/src/installer/corehost/cli/apphost/static/CMakeLists.txt
|
|
index 85ea6ffe642..e6369f6b9ad 100644
|
|
--- a/src/installer/corehost/cli/apphost/static/CMakeLists.txt
|
|
+++ b/src/installer/corehost/cli/apphost/static/CMakeLists.txt
|
|
@@ -204,11 +204,12 @@ target_link_libraries(singlefilehost
|
|
libhostcommon
|
|
${CORECLR_LIBRARIES}
|
|
|
|
+ ${START_WHOLE_ARCHIVE}
|
|
+ ${NATIVE_LIBS}
|
|
+ ${END_WHOLE_ARCHIVE}
|
|
+
|
|
${ZLIB_LIBRARIES}
|
|
${LIBGSS}
|
|
${NATIVE_LIBS_EXTRA}
|
|
|
|
- ${START_WHOLE_ARCHIVE}
|
|
- ${NATIVE_LIBS}
|
|
- ${END_WHOLE_ARCHIVE}
|
|
)
|