Update to .NET Core Runtime 3.1.2 and SDK 3.1.102
This commit is contained in:
parent
87d13ef02a
commit
afa7f9a38c
@ -92,6 +92,8 @@ if [ ! -f "${unmodified_tarball_name}.tar.gz" ]; then
|
|||||||
git submodule update --init --recursive
|
git submodule update --init --recursive
|
||||||
clean_dotnet_cache
|
clean_dotnet_cache
|
||||||
sed -i -e 's|cmakeargs -DCLR_CMAKE_USE_SYSTEM_LIBUNWIND=TRUE||' repos/coreclr.proj
|
sed -i -e 's|cmakeargs -DCLR_CMAKE_USE_SYSTEM_LIBUNWIND=TRUE||' repos/coreclr.proj
|
||||||
|
mkdir -p patches/coreclr/
|
||||||
|
cp ../../build-coreclr-clang10.patch patches/coreclr
|
||||||
./build-source-tarball.sh "${unmodified_tarball_name}"
|
./build-source-tarball.sh "${unmodified_tarball_name}"
|
||||||
popd
|
popd
|
||||||
popd
|
popd
|
||||||
@ -108,6 +110,7 @@ mv "${unmodified_tarball_name}" "${tarball_name}"
|
|||||||
pushd "${tarball_name}"
|
pushd "${tarball_name}"
|
||||||
# Remove files with funny licenses, crypto implementations and other
|
# Remove files with funny licenses, crypto implementations and other
|
||||||
# not-very-useful artifacts to reduce tarball size
|
# not-very-useful artifacts to reduce tarball size
|
||||||
|
find -type f -iname '*.tar.gz' -delete
|
||||||
rm -r src/AspNetCore.*/src/SignalR/clients/java/signalr/gradle*
|
rm -r src/AspNetCore.*/src/SignalR/clients/java/signalr/gradle*
|
||||||
find src/AspNetCore.*/src -type d -name samples -print0 | xargs -0 rm -r
|
find src/AspNetCore.*/src -type d -name samples -print0 | xargs -0 rm -r
|
||||||
rm -r src/NuGet.Client.*/test/EndToEnd/ProjectTemplates/NetCoreWebApplication1.0.zip
|
rm -r src/NuGet.Client.*/test/EndToEnd/ProjectTemplates/NetCoreWebApplication1.0.zip
|
||||||
|
@ -20,11 +20,11 @@
|
|||||||
%global dotnet_cflags %(echo %optflags | sed -e 's/-fstack-clash-protection//' | sed -re 's/-specs=[^ ]*//g')
|
%global dotnet_cflags %(echo %optflags | sed -e 's/-fstack-clash-protection//' | sed -re 's/-specs=[^ ]*//g')
|
||||||
%global dotnet_ldflags %(echo %{__global_ldflags} | sed -re 's/-specs=[^ ]*//g')
|
%global dotnet_ldflags %(echo %{__global_ldflags} | sed -re 's/-specs=[^ ]*//g')
|
||||||
|
|
||||||
%global host_version 3.1.1
|
%global host_version 3.1.2
|
||||||
%global runtime_version 3.1.1
|
%global runtime_version 3.1.2
|
||||||
%global aspnetcore_runtime_version %{runtime_version}
|
%global aspnetcore_runtime_version %{runtime_version}
|
||||||
%global sdk_version 3.1.101
|
%global sdk_version 3.1.102
|
||||||
%global templates_version %{runtime_version}
|
%global templates_version %(echo %{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
|
||||||
|
|
||||||
%global host_rpm_version %{host_version}
|
%global host_rpm_version %{host_version}
|
||||||
%global aspnetcore_runtime_rpm_version %{aspnetcore_runtime_version}
|
%global aspnetcore_runtime_rpm_version %{aspnetcore_runtime_version}
|
||||||
@ -56,7 +56,7 @@
|
|||||||
|
|
||||||
Name: dotnet3.1
|
Name: dotnet3.1
|
||||||
Version: %{sdk_rpm_version}
|
Version: %{sdk_rpm_version}
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: .NET Core Runtime and SDK
|
Summary: .NET Core Runtime and SDK
|
||||||
License: MIT and ASL 2.0 and BSD and LGPLv2+ and CC-BY and CC0 and MS-PL and EPL-1.0 and GPL+ and GPLv2 and ISC and OFL and zlib
|
License: MIT and ASL 2.0 and BSD and LGPLv2+ and CC-BY and CC0 and MS-PL and EPL-1.0 and GPL+ and GPLv2 and ISC and OFL and zlib
|
||||||
URL: https://github.com/dotnet/
|
URL: https://github.com/dotnet/
|
||||||
@ -83,8 +83,8 @@ Patch104: corefx-42871-fedora-33-rid.patch
|
|||||||
|
|
||||||
# Build with with hardening flags, including -pie
|
# Build with with hardening flags, including -pie
|
||||||
Patch200: coreclr-hardening-flags.patch
|
Patch200: coreclr-hardening-flags.patch
|
||||||
# Fix build with clang 10
|
# Fix build with clang 10; Already applied at tarball-build time
|
||||||
Patch201: coreclr-clang10.patch
|
# Patch201: coreclr-clang10.patch
|
||||||
|
|
||||||
# Build with with hardening flags, including -pie
|
# Build with with hardening flags, including -pie
|
||||||
Patch300: core-setup-hardening-flags.patch
|
Patch300: core-setup-hardening-flags.patch
|
||||||
@ -341,7 +341,7 @@ ln -s %{_libdir}/dotnet/reference-packages/Private.SourceBuild.ReferencePackages
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Fix bad hardcoded path in build
|
# Fix bad hardcoded path in build
|
||||||
sed -i 's|/usr/share/dotnet|%{_libdir}/dotnet|' src/dotnet-core-setup.*/src/corehost/common/pal.unix.cpp
|
sed -i 's|/usr/share/dotnet|%{_libdir}/dotnet|' src/core-setup.*/src/corehost/common/pal.unix.cpp
|
||||||
|
|
||||||
# Disable warnings
|
# Disable warnings
|
||||||
sed -i 's|skiptests|skiptests ignorewarnings|' repos/coreclr.proj
|
sed -i 's|skiptests|skiptests ignorewarnings|' repos/coreclr.proj
|
||||||
@ -356,14 +356,14 @@ popd
|
|||||||
|
|
||||||
pushd src/coreclr.*
|
pushd src/coreclr.*
|
||||||
%patch200 -p1
|
%patch200 -p1
|
||||||
%patch201 -p1
|
#%%patch201 -p1
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd src/dotnet-core-setup.*
|
pushd src/core-setup.*
|
||||||
%patch300 -p1
|
%patch300 -p1
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd src/dotnet-cli.*
|
pushd src/cli.*
|
||||||
%patch500 -p1
|
%patch500 -p1
|
||||||
popd
|
popd
|
||||||
|
|
||||||
@ -392,8 +392,16 @@ export CFLAGS="%{dotnet_cflags}"
|
|||||||
export CXXFLAGS="%{dotnet_cflags}"
|
export CXXFLAGS="%{dotnet_cflags}"
|
||||||
export LDFLAGS="%{dotnet_ldflags}"
|
export LDFLAGS="%{dotnet_ldflags}"
|
||||||
|
|
||||||
|
#%%if %%{without bootstrap}
|
||||||
|
# --with-ref-packages %%{_libdir}/dotnet/reference-packages/ \
|
||||||
|
# --with-packages %%{_libdir}/dotnet/source-built-artifacts/*.tar.gz \
|
||||||
|
# --with-sdk %%{_libdir}/dotnet \
|
||||||
|
#%%endif
|
||||||
|
|
||||||
VERBOSE=1 ./build.sh \
|
VERBOSE=1 ./build.sh \
|
||||||
|
-- \
|
||||||
/v:n \
|
/v:n \
|
||||||
|
/p:SkipPortableRuntimeBuild=true \
|
||||||
/p:LogVerbosity=n \
|
/p:LogVerbosity=n \
|
||||||
/p:MinimalConsoleLogOutput=false \
|
/p:MinimalConsoleLogOutput=false \
|
||||||
/p:ContinueOnPrebuiltBaselineError=true \
|
/p:ContinueOnPrebuiltBaselineError=true \
|
||||||
@ -421,15 +429,13 @@ chmod 0755 %{buildroot}/%{_libdir}/dotnet/sdk/%{sdk_version}/AppHostTemplate/app
|
|||||||
chmod 0755 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Host.%{runtime_id}/%{runtime_version}/runtimes/%{runtime_id}/native/libnethost.so
|
chmod 0755 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Host.%{runtime_id}/%{runtime_version}/runtimes/%{runtime_id}/native/libnethost.so
|
||||||
chmod 0755 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Host.%{runtime_id}/%{runtime_version}/runtimes/%{runtime_id}/native/apphost
|
chmod 0755 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Host.%{runtime_id}/%{runtime_version}/runtimes/%{runtime_id}/native/apphost
|
||||||
chmod 0644 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Host.%{runtime_id}/%{runtime_version}/runtimes/%{runtime_id}/native/nethost.h
|
chmod 0644 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Host.%{runtime_id}/%{runtime_version}/runtimes/%{runtime_id}/native/nethost.h
|
||||||
chmod 0644 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.AspNetCore.App.Ref/3.1.0/obj/Microsoft.AspNetCore.App.Ref.csproj.nuget.cache
|
|
||||||
chmod 0644 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.AspNetCore.App.Ref/3.1.0/Microsoft.AspNetCore.App.Ref/3.1.0/Debug/netstandard2.0/Microsoft.AspNetCore.App.Ref.assets.cache
|
|
||||||
|
|
||||||
install -dm 0755 %{buildroot}%{_sysconfdir}/profile.d/
|
install -dm 0755 %{buildroot}%{_sysconfdir}/profile.d/
|
||||||
install dotnet.sh %{buildroot}%{_sysconfdir}/profile.d/
|
install dotnet.sh %{buildroot}%{_sysconfdir}/profile.d/
|
||||||
|
|
||||||
install -dm 0755 %{buildroot}/%{_datadir}/bash-completion/completions
|
install -dm 0755 %{buildroot}/%{_datadir}/bash-completion/completions
|
||||||
# dynamic completion needs the file to be named the same as the base command
|
# dynamic completion needs the file to be named the same as the base command
|
||||||
install src/dotnet-cli.*/scripts/register-completions.bash %{buildroot}/%{_datadir}/bash-completion/completions/dotnet
|
install src/cli.*/scripts/register-completions.bash %{buildroot}/%{_datadir}/bash-completion/completions/dotnet
|
||||||
|
|
||||||
# TODO: the zsh completion script needs to be ported to use #compdef
|
# TODO: the zsh completion script needs to be ported to use #compdef
|
||||||
#install -dm 755 %%{buildroot}/%%{_datadir}/zsh/site-functions
|
#install -dm 755 %%{buildroot}/%%{_datadir}/zsh/site-functions
|
||||||
@ -506,6 +512,9 @@ echo "Testing build results for debug symbols..."
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 16 2020 Omair Majid <omajid@redhat.com> - 3.1.102-1
|
||||||
|
- Update to .NET Core Runtime 3.1.2 and SDK 3.1.102
|
||||||
|
|
||||||
* Fri Feb 28 2020 Omair Majid <omajid@redhat.com> - 3.1.101-4
|
* Fri Feb 28 2020 Omair Majid <omajid@redhat.com> - 3.1.101-4
|
||||||
- Disable bootstrap
|
- Disable bootstrap
|
||||||
|
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- .dotnet/sdk/3.1.101/RuntimeIdentifierGraph.json.orig 2020-02-27 19:48:57.286692828 -0500
|
--- .dotnet/sdk/3.1.101/RuntimeIdentifierGraph.json
|
||||||
+++ .dotnet/sdk/3.1.101/RuntimeIdentifierGraph.json 2020-02-27 19:49:17.185262594 -0500
|
+++ .dotnet/sdk/3.1.101/RuntimeIdentifierGraph.json
|
||||||
@@ -488,6 +488,23 @@
|
@@ -488,6 +488,23 @@
|
||||||
"fedora-x64"
|
"fedora-x64"
|
||||||
]
|
]
|
||||||
|
@ -1,14 +1,14 @@
|
|||||||
#!/bin/bash
|
#!/bin/bash
|
||||||
|
|
||||||
# Usage:
|
# Usage:
|
||||||
# ./update-release runtime-version sdk-version
|
# ./update-release sdk-version runtime-version
|
||||||
|
|
||||||
set -euo pipefail
|
set -euo pipefail
|
||||||
IFS=$'\n\t'
|
IFS=$'\n\t'
|
||||||
|
|
||||||
print_usage() {
|
print_usage() {
|
||||||
echo " Usage:"
|
echo " Usage:"
|
||||||
echo " ./update-release runtime-version sdk-version"
|
echo " ./update-release sdk-version runtime-version"
|
||||||
}
|
}
|
||||||
|
|
||||||
positional_args=()
|
positional_args=()
|
||||||
@ -28,19 +28,20 @@ done
|
|||||||
|
|
||||||
spec_file=dotnet3.1.spec
|
spec_file=dotnet3.1.spec
|
||||||
|
|
||||||
runtime_version=${positional_args[0]:-}
|
sdk_version=${positional_args[0]:-}
|
||||||
if [[ -z ${runtime_version} ]]; then
|
|
||||||
echo "error: missing runtime version"
|
|
||||||
exit 1
|
|
||||||
fi
|
|
||||||
host_version="$runtime_version"
|
|
||||||
|
|
||||||
sdk_version=${positional_args[1]:-}
|
|
||||||
if [[ -z ${sdk_version} ]]; then
|
if [[ -z ${sdk_version} ]]; then
|
||||||
echo "error: missing sdk version"
|
echo "error: missing sdk version"
|
||||||
exit 1
|
exit 1
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
runtime_version=${positional_args[1]:-}
|
||||||
|
if [[ -z ${runtime_version} ]]; then
|
||||||
|
echo "error: missing runtime version"
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
host_version="$runtime_version"
|
||||||
|
|
||||||
if [[ ! -f "dotnet-v${sdk_version}-SDK.tar.gz" ]]; then
|
if [[ ! -f "dotnet-v${sdk_version}-SDK.tar.gz" ]]; then
|
||||||
./build-dotnet-tarball "v${sdk_version}-SDK"
|
./build-dotnet-tarball "v${sdk_version}-SDK"
|
||||||
fi
|
fi
|
||||||
|
Loading…
Reference in New Issue
Block a user