diff --git a/.dotnet8.0.metadata b/.dotnet8.0.metadata
index 9ee3548..ac78cc5 100644
--- a/.dotnet8.0.metadata
+++ b/.dotnet8.0.metadata
@@ -1 +1 @@
-a3656c594207a2f92901d5ecc7c9a3bae6524e40 SOURCES/dotnet-v8.0.0.tar.gz
+63afe4d4947ec5eac76f5f39090da96d72020427 SOURCES/dotnet-v8.0.1.tar.gz
diff --git a/.gitignore b/.gitignore
index dee4901..6edf1d2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1 @@
-SOURCES/dotnet-v8.0.0.tar.gz
+SOURCES/dotnet-v8.0.1.tar.gz
diff --git a/SOURCES/dotnet-missing-pdbs-okay.patch b/SOURCES/dotnet-missing-pdbs-okay.patch
new file mode 100644
index 0000000..f239d17
--- /dev/null
+++ b/SOURCES/dotnet-missing-pdbs-okay.patch
@@ -0,0 +1,20 @@
+Allow builders to override failing on pdb mismatch
+--- a/build.proj
++++ b/build.proj
+@@ -114,6 +114,7 @@
+ $(OutputPath)dotnet-symbols-sdk-$(MicrosoftSourceBuildIntermediateInstallerVersion)-$(TargetRid).tar.gz
+ $(ArtifactsTmpDir)Sdk
+ %(SdkTarballItem.Identity)
++ true
+
+
+
+@@ -123,7 +124,7 @@
+
++ FailOnMissingPDBs="$(FailOnMissingPDBs)" />
+
+
diff --git a/SOURCES/release.json b/SOURCES/release.json
index bd833ad..4463ecb 100644
--- a/SOURCES/release.json
+++ b/SOURCES/release.json
@@ -1,9 +1,9 @@
{
- "release": "8.0.0",
+ "release": "8.0.1",
"channel": "8.0",
- "tag": "v8.0.0",
- "sdkVersion": "8.0.100",
- "runtimeVersion": "8.0.0",
+ "tag": "v8.0.1",
+ "sdkVersion": "8.0.101",
+ "runtimeVersion": "8.0.1",
"sourceRepository": "https://github.com/dotnet/dotnet",
- "sourceVersion": "40e7f014ff784457efffa58074549735e30772ae"
+ "sourceVersion": "b27976e5a6850466ee5b4ce24f91ee93bef645f7"
}
diff --git a/SPECS/dotnet8.0.spec b/SPECS/dotnet8.0.spec
index 3101ec9..4e274cd 100644
--- a/SPECS/dotnet8.0.spec
+++ b/SPECS/dotnet8.0.spec
@@ -8,16 +8,16 @@
%global dotnetver 8.0
-%global host_version 8.0.0
-%global runtime_version 8.0.0
-%global aspnetcore_runtime_version 8.0.0
-%global sdk_version 8.0.100
+%global host_version 8.0.1
+%global runtime_version 8.0.1
+%global aspnetcore_runtime_version %{runtime_version}
+%global sdk_version 8.0.101
%global sdk_feature_band_version %(echo %{sdk_version} | cut -d '-' -f 1 | sed -e 's|[[:digit:]][[:digit:]]$|00|')
-%global templates_version 8.0.0
+%global templates_version %{runtime_version}
#%%global templates_version %%(echo %%{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
# upstream can produce releases with a different tag than the SDK version
-%global upstream_tag v8.0.0
+%global upstream_tag v%{runtime_version}
%global upstream_tag_without_v %(echo %{upstream_tag} | sed -e 's|^v||')
%global host_rpm_version %{host_version}
@@ -54,7 +54,7 @@
Name: dotnet%{dotnetver}
Version: %{sdk_rpm_version}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: .NET Runtime and SDK
License: 0BSD AND Apache-2.0 AND (Apache-2.0 WITH LLVM-exception) AND APSL-2.0 AND BSD-2-Clause AND BSD-3-Clause AND BSD-4-Clause AND BSL-1.0 AND bzip2-1.0.6 AND CC0-1.0 AND CC-BY-3.0 AND CC-BY-4.0 AND CC-PDDC AND CNRI-Python AND EPL-1.0 AND GPL-2.0-only AND (GPL-2.0-only WITH GCC-exception-2.0) AND GPL-2.0-or-later AND GPL-3.0-only AND ICU AND ISC AND LGPL-2.1-only AND LGPL-2.1-or-later AND LicenseRef-Fedora-Public-Domain AND LicenseRef-ISO-8879 AND MIT AND MIT-Wu AND MS-PL AND MS-RL AND NCSA AND OFL-1.1 AND OpenSSL AND Unicode-DFS-2015 AND Unicode-DFS-2016 AND W3C-19980720 AND X11 AND Zlib
@@ -90,6 +90,8 @@ Source21: dotnet.sh.in
Patch1: roslyn-analyzers-ppc64le-apphost.patch
# https://github.com/dotnet/source-build/discussions/3481
Patch2: vstest-intent-net8.0.patch
+# We are failing to build 8.0.101 on s390x due to pdb errors that are under investigation
+Patch3: dotnet-missing-pdbs-okay.patch
ExclusiveArch: aarch64 ppc64le s390x x86_64
@@ -496,6 +498,9 @@ VERBOSE=1 ./build.sh \
%endif
--release-manifest %{SOURCE5} \
-- \
+%ifarch s390x
+ /p:FailOnMissingPDBs=false \
+%endif
/p:MinimalConsoleLogOutput=false \
/p:ContinueOnPrebuiltBaselineError=true \
/v:n \
@@ -655,6 +660,10 @@ export COMPlus_LTTng=0
%changelog
+* Wed Dec 20 2023 Omair Majid - 8.0.101-1
+- Update to .NET SDK 8.0.101 and Runtime 8.0.1
+- Resolves: RHEL-19806
+
* Mon Nov 06 2023 Omair Majid - 8.0.100-2
- Add more symbol files
- Related: RHEL-15863