Update to .NET SDK 8 Preview 6 and Runtime 8 Preview 6

This commit is contained in:
Omair Majid 2023-07-17 09:49:52 -04:00
parent e79c8a8673
commit 1db2dda2ae
7 changed files with 68 additions and 291 deletions

View File

@ -20,19 +20,17 @@ function parse-nuget-name-version-from-file() {
bootstrap_dir=$(readlink -f "$1")
version=${2:-$(jq -r '.tools.dotnet' "$bootstrap_dir"/global.json)}
sdk_version=${2:-$(jq -r '.tools.dotnet' "$bootstrap_dir"/global.json)}
date=$(date +%F)
mkdir -p "dotnet-prebuilts-${sdk_version}-arm64"
mkdir -p "dotnet-arm64-prebuilts-$date"
pushd "dotnet-arm64-prebuilts-$date"
pushd "dotnet-prebuilts-${sdk_version}-arm64"
# Binaries can be at one of several different URLs:
# GA releases:
if ! wget https://dotnetcli.azureedge.net/dotnet/Sdk/$version/dotnet-sdk-$version-linux-arm64.tar.gz; then
if ! wget "https://dotnetcli.azureedge.net/dotnet/Sdk/${sdk_version}/dotnet-sdk-${sdk_version}-linux-arm64.tar.gz" ; then
# Preview releases:
wget https://dotnetbuilds.azureedge.net/public/Sdk/$version/dotnet-sdk-$version-linux-arm64.tar.gz
wget "https://dotnetbuilds.azureedge.net/public/Sdk/${sdk_version}/dotnet-sdk-${sdk_version}-linux-arm64.tar.gz"
fi
for archive in "$bootstrap_dir"/prereqs/packages/archive/*.tar.gz; do
@ -55,4 +53,4 @@ done
popd
tar czf "dotnet-arm64-prebuilts-$date.tar.gz" "dotnet-arm64-prebuilts-$date"
tar czf "dotnet-prebuilts-${sdk_version}-arm64.tar.gz" "dotnet-prebuilts-${sdk_version}-arm64"

View File

@ -8,22 +8,22 @@
%global dotnetver 8.0
%global host_version 8.0.0-preview.5.23280.8
%global runtime_version 8.0.0-preview.5.23280.8
%global aspnetcore_runtime_version 8.0.0-preview.5.23302.2
%global sdk_version 8.0.100-preview.5.23303.1
%global host_version 8.0.0-preview.6.23329.7
%global runtime_version 8.0.0-preview.6.23329.7
%global aspnetcore_runtime_version 8.0.0-preview.6.23329.11
%global sdk_version 8.0.100-preview.6.23330.1
%global sdk_feature_band_version %(echo %{sdk_version} | cut -d '-' -f 1 | sed -e 's|[[:digit:]][[:digit:]]$|00|')
%global templates_version 8.0.0-preview.5.23302.2
%global templates_version 8.0.0-preview.6.23329.11
#%%global templates_version %%(echo %%{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
# upstream can update releases without revving the SDK version so these don't always match
%global upstream_tag v8.0.0-preview.5.23280.8
%global upstream_tag v8.0.0-preview.6.23329.7
%global upstream_tag_without_v %(echo %{upstream_tag} | sed -e 's|^v||')
%global host_rpm_version 8.0.0~preview.5
%global runtime_rpm_version 8.0.0~preview.5
%global aspnetcore_runtime_rpm_version 8.0.0~preview.5
%global sdk_rpm_version 8.0.100~preview.5
%global host_rpm_version 8.0.0~preview.6
%global runtime_rpm_version 8.0.0~preview.6
%global aspnetcore_runtime_rpm_version 8.0.0~preview.6
%global sdk_rpm_version 8.0.100~preview.6
%if 0%{?fedora} || 0%{?rhel} < 8
%global use_bundled_libunwind 0
@ -61,16 +61,17 @@ License: 0BSD AND Apache-2.0 AND (Apache-2.0 WITH LLVM-exception) AND APS
URL: https://github.com/dotnet/
%if %{with bootstrap}
%global bootstrap_sdk_version 8.0.100-preview.5.23303.2
%global tarball_name dotnet-%{upstream_tag}-x64-bootstrap
# The source is generated on a Fedora box via:
# ./build-dotnet-tarball --bootstrap %%{upstream_tag}
Source0: %{tarball_name}.tar.xz
# Generated via ./build-arm64-bootstrap-tarball
Source1: dotnet-arm64-prebuilts-2023-06-16.tar.gz
Source1: dotnet-prebuilts-%{bootstrap_sdk_version}-arm64.tar.gz
# Generated manually, same pattern as the arm64 tarball
Source2: dotnet-ppc64le-prebuilts-2023-06-16.tar.gz
Source2: dotnet-prebuilts-%{bootstrap_sdk_version}-ppc64le.tar.gz
# Generated manually, same pattern as the arm64 tarball
Source3: dotnet-s390x-prebuilts-2023-06-16.tar.gz
Source3: dotnet-prebuilts-%{bootstrap_sdk_version}-s390x.tar.gz
%else
# For non-releases, the source is generated on a Fedora box via:
# ./build-dotnet-tarball %%{upstream_tag} or commit
@ -88,9 +89,9 @@ Source21: dotnet.sh.in
# Disable apphost; there's no net6.0 apphost for ppc64le
Patch1: roslyn-analyzers-ppc64le-apphost.patch
# https://github.com/dotnet/source-build/discussions/3481
Patch2: nuget-client-use-net8.0.patch
Patch3: fsharp-use-net8.0.patch
Patch4: vstest-intent-net8.0.patch
Patch2: vstest-intent-net8.0.patch
# https://github.com/dotnet/runtime/pull/88145
Patch3: runtime-88145-ppc64le-build-failure.patch
%if 0%{?fedora} || 0%{?rhel} >= 8
ExclusiveArch: aarch64 ppc64le s390x x86_64
@ -361,6 +362,12 @@ These are not meant for general use.
%prep
release_json_tag=$(grep tag %{SOURCE5} | cut -d: -f2 | sed -E 's/[," ]*//g')
if [[ ${release_json_tag} != %{upstream_tag} ]]; then
echo "error: tag in release.json doesn't match tag in spec file"
exit 1
fi
%if %{without bootstrap}
%setup -q -n dotnet-%{upstream_tag}
@ -645,6 +652,8 @@ export COMPlus_LTTng=0
%{_libdir}/dotnet/sdk-manifests/%{sdk_feature_band_version}*
%{_libdir}/dotnet/metadata
%dir %{_libdir}/dotnet/packs
%{_libdir}/dotnet/packs/Microsoft.AspNetCore.App.Runtime.%{runtime_id}/%{aspnetcore_runtime_version}
%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Runtime.%{runtime_id}/%{runtime_version}
%files -n dotnet-sdk-%{dotnetver}-source-built-artifacts
%dir %{_libdir}/dotnet
@ -652,6 +661,12 @@ export COMPlus_LTTng=0
%changelog
* Mon Jul 17 2023 Omair Majid <omajid@redhat.com> - 8.0.100~preview.6-0.1
- Update to .NET SDK 8.0.100 Preview 6 and Runtime 8.0.0 Preview 6
* Fri Jun 23 2023 Omair Majid <omajid@redhat.com> - 8.0.100~preview.5-0.2
- Fix release.json and sourcelink references
* Mon Jun 19 2023 Omair Majid <omajid@redhat.com> - 8.0.100~preview.5-0.1
- Update to .NET SDK 8.0.100 Preview 5 and Runtime 8.0.0 Preview 5

View File

@ -1,11 +0,0 @@
--- a/src/fsharp/src/Microsoft.FSharp.Compiler/Microsoft.FSharp.Compiler.fsproj
+++ b/src/fsharp/src/Microsoft.FSharp.Compiler/Microsoft.FSharp.Compiler.fsproj
@@ -3,7 +3,7 @@
<PropertyGroup>
<PreRelease>true</PreRelease>
<OutputType>Exe</OutputType>
- <TargetFramework>net7.0</TargetFramework>
+ <TargetFramework>net8.0</TargetFramework>
<NuspecFile>Microsoft.FSharp.Compiler.nuspec</NuspecFile>
<IsPackable>true</IsPackable>
<PackageDescription>.NET Core compatible version of the F# compiler fsc.exe.</PackageDescription>

View File

@ -1,251 +0,0 @@
From https://github.com/dotnet/source-build/discussions/3481
--- a/src/nuget-client/build/common.project.props
+++ a/src/nuget-client/build/common.project.props
@@ -14,7 +14,7 @@
<NETFXTargetFrameworkVersion>v4.7.2</NETFXTargetFrameworkVersion>
<NETFXTargetFramework>net472</NETFXTargetFramework>
<NETCoreTargetFramework>netcoreapp3.1</NETCoreTargetFramework>
- <NETCoreTargetFramework Condition="'$(DotNetBuildFromSource)' == 'true'">net7.0</NETCoreTargetFramework>
+ <NETCoreTargetFramework Condition="'$(DotNetBuildFromSource)' == 'true'">net8.0</NETCoreTargetFramework>
<NETCoreTestTargetFrameworks>net7.0</NETCoreTestTargetFrameworks>
<NETCoreTestTargetFrameworks Condition=" ('$(CI)' == 'true' AND '$(BUILD_NET8)' != 'false') OR '$(BUILD_NET8)' == 'true' ">net7.0;net8.0</NETCoreTestTargetFrameworks>
<NetStandardVersion>netstandard2.0</NetStandardVersion>
@@ -24,7 +24,7 @@
<TargetFrameworksExeForSigning Condition="'$(DotNetBuildFromSource)' == 'true'">$(TargetFrameworksExe);net7.0</TargetFrameworksExeForSigning>
<MinimalTargetFrameworksExeSigning>$(NETFXTargetFramework);netcoreapp5.0</MinimalTargetFrameworksExeSigning>
<MinimalTargetFrameworksExeSigning Condition=" '$(IsXPlat)' == 'true' ">netcoreapp5.0</MinimalTargetFrameworksExeSigning>
- <MinimalTargetFrameworksExeSigning Condition="'$(DotNetBuildFromSource)' == 'true'">net7.0</MinimalTargetFrameworksExeSigning>
+ <MinimalTargetFrameworksExeSigning Condition="'$(DotNetBuildFromSource)' == 'true'">net8.0</MinimalTargetFrameworksExeSigning>
<TargetFrameworksLibrary>$(NETFXTargetFramework);$(NetStandardVersion)</TargetFrameworksLibrary>
<TargetFrameworksLibrary Condition="'$(DotNetBuildFromSource)' == 'true'">$(NETCoreTargetFramework);$(NetStandardVersion)</TargetFrameworksLibrary>
<TargetFrameworksLibraryForSigning>$(TargetFrameworksLibrary);netcoreapp5.0</TargetFrameworksLibraryForSigning>
--- a/src/nuget-client/build/common.targets
+++ b/src/nuget-client/build/common.targets
@@ -6,7 +6,7 @@
<IsDesktop>true</IsDesktop>
</PropertyGroup>
- <PropertyGroup Condition=" $(TargetFramework.StartsWith('netcoreapp')) OR $(TargetFramework.StartsWith('netstandard')) OR $(TargetFramework.StartsWith('net6')) OR $(TargetFramework.StartsWith('net7')) ">
+ <PropertyGroup Condition=" $(TargetFramework.StartsWith('netcoreapp')) OR $(TargetFramework.StartsWith('netstandard')) OR $(TargetFramework.StartsWith('net6')) OR $(TargetFramework.StartsWith('net7')) OR $(TargetFramework.StartsWith('net8')) ">
<DefineConstants>$(DefineConstants);IS_CORECLR</DefineConstants>
<IsCore>true</IsCore>
</PropertyGroup>
--- a/src/nuget-client/src/NuGet.Core/NuGet.Configuration/NuGet.Configuration.csproj
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Configuration/NuGet.Configuration.csproj
@@ -26,7 +26,7 @@
<Reference Include="System.Xml.Linq" />
</ItemGroup>
- <ItemGroup Condition=" '$(TargetFramework)' == '$(NetStandardVersion)' or '$(TargetFramework)' == 'net7.0' ">
+ <ItemGroup Condition=" '$(TargetFramework)' == '$(NetStandardVersion)' or '$(TargetFramework)' == 'net7.0' or '$(TargetFramework)' == 'net8.0' ">
<PackageReference Include="System.Security.Cryptography.ProtectedData" />
</ItemGroup>
--- a/src/nuget-client/src/NuGet.Core/NuGet.PackageManagement/NuGet.PackageManagement.csproj
+++ b/src/nuget-client/src/NuGet.Core/NuGet.PackageManagement/NuGet.PackageManagement.csproj
@@ -32,7 +32,7 @@
<Reference Include="System.Net.Http" />
</ItemGroup>
- <ItemGroup Condition=" '$(TargetFramework)' == '$(NetStandardVersion)' or '$(TargetFramework)' == 'net7.0' ">
+ <ItemGroup Condition=" '$(TargetFramework)' == '$(NetStandardVersion)' or '$(TargetFramework)' == 'net7.0' or '$(TargetFramework)' == 'net8.0' ">
<PackageReference Include="System.ComponentModel.Composition" />
</ItemGroup>
diff --git a/src/NuGet.Clients/NuGet.PackageManagement.PowerShellCmdlets/Exceptions/PackageSourceException.cs b/src/NuGet.Clients/NuGet.PackageManagement.PowerShellCmdlets/Exceptions/PackageSourceException.cs
index ef589f85a..a0615d68c 100644
--- a/src/nuget-client/src/NuGet.Clients/NuGet.PackageManagement.PowerShellCmdlets/Exceptions/PackageSourceException.cs
+++ b/src/nuget-client/src/NuGet.Clients/NuGet.PackageManagement.PowerShellCmdlets/Exceptions/PackageSourceException.cs
@@ -14,6 +14,9 @@ public PackageSourceException(string message)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected PackageSourceException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Commands/Common/CommandException.cs b/src/NuGet.Core/NuGet.Commands/Common/CommandException.cs
index 0b2ded3fc..6cf41ea16 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Commands/Common/CommandException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Commands/Common/CommandException.cs
@@ -29,6 +29,9 @@ public CommandException(string message, Exception exception)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected CommandException(SerializationInfo info, StreamingContext context)
: base(info, context)
{
diff --git a/src/NuGet.Core/NuGet.Configuration/Exceptions/NuGetConfigurationException.cs b/src/NuGet.Core/NuGet.Configuration/Exceptions/NuGetConfigurationException.cs
index 7e62c4562..88ab349ba 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Configuration/Exceptions/NuGetConfigurationException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Configuration/Exceptions/NuGetConfigurationException.cs
@@ -22,6 +22,9 @@ public NuGetConfigurationException(string message, Exception innerException)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected NuGetConfigurationException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Frameworks/FrameworkException.cs b/src/NuGet.Core/NuGet.Frameworks/FrameworkException.cs
index 9e538d481..5a7fd3feb 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Frameworks/FrameworkException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Frameworks/FrameworkException.cs
@@ -14,6 +14,9 @@ public FrameworkException(string message)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected FrameworkException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Packaging/Licenses/NuGetLicenseExpressionParsingException.cs b/src/NuGet.Core/NuGet.Packaging/Licenses/NuGetLicenseExpressionParsingException.cs
index b48fe5bdd..bee4f569b 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Packaging/Licenses/NuGetLicenseExpressionParsingException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Packaging/Licenses/NuGetLicenseExpressionParsingException.cs
@@ -18,6 +18,9 @@ public NuGetLicenseExpressionParsingException(string message, Exception innerExc
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected NuGetLicenseExpressionParsingException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Protocol/Exceptions/FatalProtocolException.cs b/src/NuGet.Core/NuGet.Protocol/Exceptions/FatalProtocolException.cs
index 68913b98d..999da9db7 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Exceptions/FatalProtocolException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Exceptions/FatalProtocolException.cs
@@ -18,6 +18,9 @@ public FatalProtocolException(string message, Exception innerException) : base(m
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected FatalProtocolException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Protocol/Exceptions/InvalidCacheProtocolException.cs b/src/NuGet.Core/NuGet.Protocol/Exceptions/InvalidCacheProtocolException.cs
index de810344a..07ae05cae 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Exceptions/InvalidCacheProtocolException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Exceptions/InvalidCacheProtocolException.cs
@@ -23,6 +23,9 @@ public InvalidCacheProtocolException(string message, Exception innerException)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected InvalidCacheProtocolException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Protocol/Exceptions/NuGetProtocolException.cs b/src/NuGet.Core/NuGet.Protocol/Exceptions/NuGetProtocolException.cs
index 8a1a81c9d..0655b8429 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Exceptions/NuGetProtocolException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Exceptions/NuGetProtocolException.cs
@@ -22,6 +22,9 @@ public NuGetProtocolException(string message, Exception innerException)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected NuGetProtocolException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Protocol/Exceptions/RetriableProtocolException.cs b/src/NuGet.Core/NuGet.Protocol/Exceptions/RetriableProtocolException.cs
index 4a63a8f4c..a53490f62 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Exceptions/RetriableProtocolException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Exceptions/RetriableProtocolException.cs
@@ -17,6 +17,9 @@ public RetriableProtocolException(string message, Exception innerException) : ba
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected RetriableProtocolException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Protocol/Plugins/PluginException.cs b/src/NuGet.Core/NuGet.Protocol/Plugins/PluginException.cs
index da7df46fd..ea8c8083e 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Plugins/PluginException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Plugins/PluginException.cs
@@ -31,6 +31,9 @@ public PluginException(string message, Exception innerException)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
private PluginException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Protocol/Plugins/ProtocolException.cs b/src/NuGet.Core/NuGet.Protocol/Plugins/ProtocolException.cs
index df18f9f81..e701ece77 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Plugins/ProtocolException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Protocol/Plugins/ProtocolException.cs
@@ -31,6 +31,9 @@ public ProtocolException(string message, Exception innerException)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
private ProtocolException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverConstraintException.cs b/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverConstraintException.cs
index 6998e28c1..e9252092a 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverConstraintException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverConstraintException.cs
@@ -17,6 +17,9 @@ public NuGetResolverConstraintException(string message)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected NuGetResolverConstraintException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverException.cs b/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverException.cs
index e2b426eb4..c3ea9fb08 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverException.cs
@@ -14,6 +14,9 @@ public NuGetResolverException(string message)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected NuGetResolverException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}
diff --git a/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverInputException.cs b/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverInputException.cs
index e1542ec4f..0471a3597 100644
--- a/src/nuget-client/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverInputException.cs
+++ b/src/nuget-client/src/NuGet.Core/NuGet.Resolver/Exceptions/NuGetResolverInputException.cs
@@ -17,6 +17,9 @@ public NuGetResolverInputException(string message)
{
}
+#if NET8_0_OR_GREATER
+ [Obsolete(DiagnosticId = "SYSLIB0051")]
+#endif
protected NuGetResolverInputException(SerializationInfo info, StreamingContext context) : base(info, context)
{
}

View File

@ -1,9 +1,9 @@
{
"release": "8.0.0-preview.4",
"release": "8.0.0-preview.6",
"channel": "8.0",
"tag": "v8.0.0-preview.4.23259.5",
"sdkVersion": "8.0.100-preview.4.23260.5",
"runtimeVersion": "8.0.0-preview.4.23259.5",
"tag": "v8.0.0-preview.6.23329.7",
"sdkVersion": "8.0.100-preview.6.23330.14",
"runtimeVersion": "8.0.0-preview.6.23329.7",
"sourceRepository": "https://github.com/dotnet/dotnet",
"sourceVersion": "5c2ab7ee737adf4b43071fedfd702b861ec8d8ef"
"sourceVersion": "3869a558bdd561a40ad963a0d52f87b8c770be40"
}

View File

@ -0,0 +1,22 @@
From 225ac9c2dfeba7e0c5eb1c04fac642515cb36cdd Mon Sep 17 00:00:00 2001
From: Sapana Khemkar <Sapana.Khemkar@ibm.cm>
Date: Wed, 28 Jun 2023 14:52:46 +0000
Subject: [PATCH] remove ppc64/setcontext.S from libunwind sources as file does
not exist any more
---
src/native/external/libunwind.cmake | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/runtime/src/native/external/libunwind.cmake b/src/runtime/src/native/external/libunwind.cmake
index dc40fc28c1f5b..3854f9b85a2b3 100644
--- a/src/runtime/src/native/external/libunwind.cmake
+++ b/src/runtime/src/native/external/libunwind.cmake
@@ -373,7 +373,6 @@ set(libunwind_la_SOURCES_ppc64le_common
set(libunwind_la_SOURCES_ppc64le
${libunwind_la_SOURCES_ppc64le_common}
${libunwind_la_SOURCES_local}
- ppc64/setcontext.S
ppc64/Lapply_reg_state.c ppc64/Lreg_states_iterate.c
ppc64/Lcreate_addr_space.c ppc/Lget_save_loc.c ppc64/Lglobal.c
ppc64/Linit.c ppc/Linit_local.c

View File

@ -110,3 +110,7 @@ sed -i -E 's|^Release: [[:digit:]]+%|Release: '"$rpm_release"'%|'
# Reset Release in changelog comment
# See https://stackoverflow.com/questions/18620153/find-matching-text-and-replace-next-line
sed -i -E '/^%changelog$/!b;n;s/-[[:digit:]]+$/-'"$rpm_release"'/' "$spec_file"
release_json_url=$(spectool -l --sources ./dotnet8.0.spec | grep release.json | cut -d' ' -f2)
rm "$(basename "$release_json_url")"
wget "$release_json_url"