diff --git a/dotnet-missing-pdbs-okay.patch b/dotnet-missing-pdbs-okay.patch
new file mode 100644
index 0000000..f239d17
--- /dev/null
+++ b/dotnet-missing-pdbs-okay.patch
@@ -0,0 +1,20 @@
+Allow builders to override failing on pdb mismatch
+--- a/build.proj
++++ b/build.proj
+@@ -114,6 +114,7 @@
+ $(OutputPath)dotnet-symbols-sdk-$(MicrosoftSourceBuildIntermediateInstallerVersion)-$(TargetRid).tar.gz
+ $(ArtifactsTmpDir)Sdk
+ %(SdkTarballItem.Identity)
++ true
+
+
+
+@@ -123,7 +124,7 @@
+
++ FailOnMissingPDBs="$(FailOnMissingPDBs)" />
+
+
diff --git a/dotnet8.0.spec b/dotnet8.0.spec
index c3e906f..4a6edcf 100644
--- a/dotnet8.0.spec
+++ b/dotnet8.0.spec
@@ -54,7 +54,7 @@
Name: dotnet%{dotnetver}
Version: %{sdk_rpm_version}
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: .NET Runtime and SDK
License: 0BSD AND Apache-2.0 AND (Apache-2.0 WITH LLVM-exception) AND APSL-2.0 AND BSD-2-Clause AND BSD-3-Clause AND BSD-4-Clause AND BSL-1.0 AND bzip2-1.0.6 AND CC0-1.0 AND CC-BY-3.0 AND CC-BY-4.0 AND CC-PDDC AND CNRI-Python AND EPL-1.0 AND GPL-2.0-only AND (GPL-2.0-only WITH GCC-exception-2.0) AND GPL-2.0-or-later AND GPL-3.0-only AND ICU AND ISC AND LGPL-2.1-only AND LGPL-2.1-or-later AND LicenseRef-Fedora-Public-Domain AND LicenseRef-ISO-8879 AND MIT AND MIT-Wu AND MS-PL AND MS-RL AND NCSA AND OFL-1.1 AND OpenSSL AND Unicode-DFS-2015 AND Unicode-DFS-2016 AND W3C-19980720 AND X11 AND Zlib
@@ -90,6 +90,8 @@ Source21: dotnet.sh.in
Patch1: roslyn-analyzers-ppc64le-apphost.patch
# https://github.com/dotnet/source-build/discussions/3481
Patch2: vstest-intent-net8.0.patch
+# We are failing to build 8.0.101 on s390x due to pdb errors that are under investigation
+Patch3: dotnet-missing-pdbs-okay.patch
ExclusiveArch: aarch64 ppc64le s390x x86_64
@@ -499,6 +501,9 @@ VERBOSE=1 ./build.sh \
%endif
--release-manifest %{SOURCE5} \
-- \
+%ifarch s390x
+ /p:FailOnMissingPDBs=false \
+%endif
/p:MinimalConsoleLogOutput=false \
/p:ContinueOnPrebuiltBaselineError=true \
/v:n \
@@ -655,6 +660,10 @@ export COMPlus_LTTng=0
%changelog
+* Thu Jan 18 2024 Omair Majid - 8.0.101-3
+- Stop enforcing pdb checking on s390x
+- Related: RHEL-19800
+
* Mon Jan 15 2024 Omair Majid - 8.0.101-2
- Update to .NET SDK 8.0.101 and Runtime 8.0.1
- Resolves: RHEL-19800