diff --git a/.gitignore b/.gitignore
index e29d3c0..d0833b2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -21,3 +21,4 @@
 /dotnet-v7.0.112.tar.gz
 /dotnet-v7.0.113.tar.gz
 /dotnet-v7.0.114.tar.gz
+/dotnet-v7.0.115.tar.gz
diff --git a/dotnet7.0.spec b/dotnet7.0.spec
index 3d20112..a9a684d 100644
--- a/dotnet7.0.spec
+++ b/dotnet7.0.spec
@@ -6,10 +6,10 @@
 # until that's done, disable LTO.  This has to happen before setting the flags below.
 %define _lto_cflags %{nil}
 
-%global host_version 7.0.14
-%global runtime_version 7.0.14
+%global host_version 7.0.15
+%global runtime_version 7.0.15
 %global aspnetcore_runtime_version %{runtime_version}
-%global sdk_version 7.0.114
+%global sdk_version 7.0.115
 %global sdk_feature_band_version %(echo %{sdk_version} | cut -d '-' -f 1 | sed -e 's|[[:digit:]][[:digit:]]$|00|')
 %global templates_version %{runtime_version}
 #%%global templates_version %%(echo %%{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
@@ -609,6 +609,10 @@ rm -rf %{buildroot}%{_libdir}/dotnet/packs/NETStandard.Library.Ref/2.1.0
 
 
 %changelog
+* Mon Jan 15 2024 Omair Majid <omajid@redhat.com> - 7.0.115-2
+- Update to .NET SDK 7.0.115 and Runtime 7.0.15
+- Resolves: RHEL-19802
+
 * Mon Dec 11 2023 Omair Majid <omajid@redhat.com> - 7.0.114-2
 - Update to .NET SDK 7.0.114 and Runtime 7.0.14
 - Resolves: RHEL-15351
diff --git a/sources b/sources
index 0d6fcd6..e8d6820 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (dotnet-v7.0.114.tar.gz) = 4f4dc7759faeb65f70012ebf939f64f149771bf3d3f689ea2dc923c89fa0fe4e2cdb2d8af4da33b1e9769a791b4668c726fc5b535401fed187a2b91882365b5c
+SHA512 (dotnet-v7.0.115.tar.gz) = 2d1ef1930bf7e6659f61669d7f68c42c8950bcc7fd0a84d161d3702434899ae31cc0218fd298486e8e508391987d5194e7f13f0a7c2a6f5ef3c492150ae8a35d