diff --git a/dotnet6.0.spec b/dotnet6.0.spec
index 09ca42c..9105a42 100644
--- a/dotnet6.0.spec
+++ b/dotnet6.0.spec
@@ -391,13 +391,6 @@ ln -s %{_libdir}/dotnet/source-built-artifacts/Private.SourceBuilt.Artifacts.*.t
# Fix bad hardcoded path in build
sed -i 's|/usr/share/dotnet|%{_libdir}/dotnet|' src/runtime/src/native/corehost/hostmisc/pal.unix.cpp
-%if 0%{?fedora} == 40
-# Fix incorrectly using fedora.39 RIDs on fedora.40
-sed -i -E 's|(true)|\1%{runtime_id}false|' \
- src/aspnetcore/src/Tools/dotnet-dev-certs/src/dotnet-dev-certs.csproj \
- src/aspnetcore/src/Tools/dotnet-user-secrets/src/dotnet-user-secrets.csproj \
-%endif
-
pushd src/runtime
%patch100 -p1
%patch101 -p1
@@ -450,7 +443,6 @@ cat /etc/os-release
%if %{without bootstrap}
# We need to create a copy because we will mutate this
cp -a %{_libdir}/dotnet previously-built-dotnet
-sed -i -E 's|fedora.33|fedora.40|' previously-built-dotnet/sdk/6.0.120/RuntimeIdentifierGraph.json
find previously-built-dotnet
%endif