Update to .NET SDK 5.0.104 and Runtime 5.0.4
Drop unneeded/upstreamed patches
This commit is contained in:
parent
a36231563c
commit
68176abe60
File diff suppressed because it is too large
Load Diff
@ -158,18 +158,6 @@ rm -r src/NuGet.Client.*/test/EndToEnd
|
|||||||
rm -r src/runtime.*/src/mono/
|
rm -r src/runtime.*/src/mono/
|
||||||
rm -r src/Humanizer.*/samples/
|
rm -r src/Humanizer.*/samples/
|
||||||
|
|
||||||
# FIXME delete when upstream has a new release with this file fixed
|
|
||||||
if ! grep "RSA Data Security" src/runtime.*/src/libraries/System.Security.Cryptography.Algorithms/src/Internal/Cryptography/SHAHashProvider.Browser.cs; then
|
|
||||||
echo "SHAHashProvider.Browser.cs has been fixed upstream. Please fix build-dotnet-tarball"
|
|
||||||
exit 1
|
|
||||||
fi
|
|
||||||
# Delete the bad source
|
|
||||||
rm src/runtime.*/src/libraries/System.Security.Cryptography.Algorithms/src/Internal/Cryptography/SHAHashProvider.Browser.cs
|
|
||||||
# Delete the patch that modifies the bad source
|
|
||||||
rm patches/runtime/0001-Use-substitute-SHA-1-implementation-in-wasm-44982.patch
|
|
||||||
# Add pre-patched copy
|
|
||||||
cp ../SHAHashProvider.Browser.cs src/runtime.*/src/libraries/System.Security.Cryptography.Algorithms/src/Internal/Cryptography/
|
|
||||||
|
|
||||||
popd
|
popd
|
||||||
|
|
||||||
tar czf "${tarball_name}.tar.gz" "${tarball_name}"
|
tar czf "${tarball_name}.tar.gz" "${tarball_name}"
|
||||||
|
@ -20,10 +20,10 @@
|
|||||||
# until that's done, disable LTO. This has to happen before setting the flags below.
|
# until that's done, disable LTO. This has to happen before setting the flags below.
|
||||||
%define _lto_cflags %{nil}
|
%define _lto_cflags %{nil}
|
||||||
|
|
||||||
%global host_version 5.0.3
|
%global host_version 5.0.4
|
||||||
%global runtime_version 5.0.3
|
%global runtime_version 5.0.4
|
||||||
%global aspnetcore_runtime_version %{runtime_version}
|
%global aspnetcore_runtime_version %{runtime_version}
|
||||||
%global sdk_version 5.0.103
|
%global sdk_version 5.0.104
|
||||||
%global templates_version %{runtime_version}
|
%global templates_version %{runtime_version}
|
||||||
#%%global templates_version %%(echo %%{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
|
#%%global templates_version %%(echo %%{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
|
||||||
|
|
||||||
@ -56,7 +56,7 @@
|
|||||||
|
|
||||||
Name: dotnet5.0
|
Name: dotnet5.0
|
||||||
Version: %{sdk_rpm_version}
|
Version: %{sdk_rpm_version}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: .NET Runtime and SDK
|
Summary: .NET Runtime and SDK
|
||||||
License: MIT and ASL 2.0 and BSD and LGPLv2+ and CC-BY and CC0 and MS-PL and EPL-1.0 and GPL+ and GPLv2 and ISC and OFL and zlib
|
License: MIT and ASL 2.0 and BSD and LGPLv2+ and CC-BY and CC0 and MS-PL and EPL-1.0 and GPL+ and GPLv2 and ISC and OFL and zlib
|
||||||
URL: https://github.com/dotnet/
|
URL: https://github.com/dotnet/
|
||||||
@ -68,21 +68,9 @@ Source0: dotnet-v%{src_version}-SDK.tar.gz
|
|||||||
Source10: check-debug-symbols.py
|
Source10: check-debug-symbols.py
|
||||||
Source11: dotnet.sh.in
|
Source11: dotnet.sh.in
|
||||||
|
|
||||||
# Fix up a patch included in source-build to apply after we apply the linker-order patch first
|
|
||||||
Patch1: source-build-runtime-fixup-linker-order.patch
|
|
||||||
|
|
||||||
# FIXME: upstream Fedora 35 RIDs; needed to unblock Fedora 35 for now
|
|
||||||
Patch2: source-build-rids.patch
|
|
||||||
|
|
||||||
# https://github.com/dotnet/runtime/pull/42094
|
|
||||||
# Fix linker order when linking with --as-needed
|
|
||||||
Patch100: runtime-linker-order.patch
|
|
||||||
# https://github.com/dotnet/runtime/pull/47020
|
|
||||||
# Fix build with gcc 11
|
|
||||||
Patch101: runtime-47020-gcc11.patch
|
|
||||||
# https://github.com/dotnet/runtime/pull/48203
|
# https://github.com/dotnet/runtime/pull/48203
|
||||||
# Add Fedora 35 RID
|
# Add Fedora 35 RID
|
||||||
Patch102: runtime-48203-fedora-35-rid.patch
|
Patch100: runtime-48203-fedora-35-rid.patch
|
||||||
|
|
||||||
# Disable telemetry by default; make it opt-in
|
# Disable telemetry by default; make it opt-in
|
||||||
Patch500: sdk-telemetry-optout.patch
|
Patch500: sdk-telemetry-optout.patch
|
||||||
@ -355,13 +343,8 @@ sed -i 's|/usr/share/dotnet|%{_libdir}/dotnet|' src/runtime.*/src/installer/core
|
|||||||
# Disable warnings
|
# Disable warnings
|
||||||
sed -i 's|skiptests|skiptests ignorewarnings|' repos/runtime.common.props
|
sed -i 's|skiptests|skiptests ignorewarnings|' repos/runtime.common.props
|
||||||
|
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
pushd src/runtime.*
|
pushd src/runtime.*
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
%patch101 -p1
|
|
||||||
%patch102 -p1
|
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd src/sdk.*
|
pushd src/sdk.*
|
||||||
@ -552,6 +535,10 @@ echo "Testing build results for debug symbols..."
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 16 2021 Omair Majid <omajid@redhat.com> - 5.0.104-1
|
||||||
|
- Update to .NET SDK 5.0.104 and Runtime 5.0.4
|
||||||
|
- Drop unneeded/upstreamed patches
|
||||||
|
|
||||||
* Wed Feb 17 2021 Omair Majid <omajid@redhat.com> - 5.0.103-2
|
* Wed Feb 17 2021 Omair Majid <omajid@redhat.com> - 5.0.103-2
|
||||||
- Add Fedora 35 RIDs
|
- Add Fedora 35 RIDs
|
||||||
|
|
||||||
|
@ -1,55 +0,0 @@
|
|||||||
From 7123b8344ddc1c883483f13d34abbd22d4170452 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Omair Majid <omajid@redhat.com>
|
|
||||||
Date: Tue, 5 Jan 2021 18:50:18 -0500
|
|
||||||
Subject: [PATCH] Fix build errors using GCC 11 (#46334)
|
|
||||||
|
|
||||||
Building runtime with GCC 11 leads to some new errors. The errors are
|
|
||||||
consistent with the "Header dependency changes" section documented at
|
|
||||||
https://gcc.gnu.org/gcc-11/porting_to.html
|
|
||||||
|
|
||||||
The first set of errors looks like this:
|
|
||||||
|
|
||||||
runtime/src/coreclr/pal/src/misc/cgroup.cpp:403:29:
|
|
||||||
error: no member named 'numeric_limits' in namespace 'std'
|
|
||||||
if (temp > std::numeric_limits<size_t>::max())
|
|
||||||
~~~~~^
|
|
||||||
|
|
||||||
Fix that by including <limits>.
|
|
||||||
|
|
||||||
The second set of errors looks like this:
|
|
||||||
|
|
||||||
runtime/src/installer/corehost/cli/test/nativehost/host_context_test.cpp:634:31:
|
|
||||||
error: no member named 'sleep_for' in namespace 'std::this_thread'
|
|
||||||
std::this_thread::sleep_for(std::chrono::milliseconds(100));
|
|
||||||
~~~~~~~~~~~~~~~~~~^
|
|
||||||
|
|
||||||
Fix that by including <thread>.
|
|
||||||
---
|
|
||||||
src/coreclr/src/pal/src/misc/cgroup.cpp | 1 +
|
|
||||||
src/installer/corehost/cli/test/nativehost/host_context_test.cpp | 1 +
|
|
||||||
2 files changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/coreclr/src/pal/src/misc/cgroup.cpp b/src/coreclr/src/pal/src/misc/cgroup.cpp
|
|
||||||
index f3e20012c539..24617359a21b 100644
|
|
||||||
--- a/src/coreclr/src/pal/src/misc/cgroup.cpp
|
|
||||||
+++ b/src/coreclr/src/pal/src/misc/cgroup.cpp
|
|
||||||
@@ -14,6 +14,7 @@ Module Name:
|
|
||||||
#include "pal/dbgmsg.h"
|
|
||||||
SET_DEFAULT_DEBUG_CHANNEL(MISC);
|
|
||||||
#include "pal/palinternal.h"
|
|
||||||
+#include <limits>
|
|
||||||
#include <limits.h>
|
|
||||||
#include <sys/resource.h>
|
|
||||||
#include "pal/virtual.h"
|
|
||||||
diff --git a/src/installer/corehost/cli/test/nativehost/host_context_test.cpp b/src/installer/corehost/cli/test/nativehost/host_context_test.cpp
|
|
||||||
index cea98db6673a..371ec2d7e2aa 100644
|
|
||||||
--- a/src/installer/corehost/cli/test/nativehost/host_context_test.cpp
|
|
||||||
+++ b/src/installer/corehost/cli/test/nativehost/host_context_test.cpp
|
|
||||||
@@ -11,6 +11,7 @@
|
|
||||||
#include <corehost_context_contract.h>
|
|
||||||
#include "hostfxr_exports.h"
|
|
||||||
#include "host_context_test.h"
|
|
||||||
+#include <thread>
|
|
||||||
#include <utils.h>
|
|
||||||
|
|
||||||
namespace
|
|
@ -1,20 +0,0 @@
|
|||||||
diff --git a/src/installer/corehost/cli/apphost/static/CMakeLists.txt b/src/installer/corehost/cli/apphost/static/CMakeLists.txt
|
|
||||||
index 85ea6ffe642..e6369f6b9ad 100644
|
|
||||||
--- a/src/installer/corehost/cli/apphost/static/CMakeLists.txt
|
|
||||||
+++ b/src/installer/corehost/cli/apphost/static/CMakeLists.txt
|
|
||||||
@@ -204,11 +204,12 @@ target_link_libraries(singlefilehost
|
|
||||||
libhostcommon
|
|
||||||
${CORECLR_LIBRARIES}
|
|
||||||
|
|
||||||
+ ${START_WHOLE_ARCHIVE}
|
|
||||||
+ ${NATIVE_LIBS}
|
|
||||||
+ ${END_WHOLE_ARCHIVE}
|
|
||||||
+
|
|
||||||
${ZLIB_LIBRARIES}
|
|
||||||
${LIBGSS}
|
|
||||||
${NATIVE_LIBS_EXTRA}
|
|
||||||
|
|
||||||
- ${START_WHOLE_ARCHIVE}
|
|
||||||
- ${NATIVE_LIBS}
|
|
||||||
- ${END_WHOLE_ARCHIVE}
|
|
||||||
)
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/tools-local/tasks/Microsoft.DotNet.SourceBuild.Tasks.XPlat/PublishCoreSetupBinaries.cs b/tools-local/tasks/Microsoft.DotNet.SourceBuild.Tasks.XPlat/PublishCoreSetupBinaries.cs
|
|
||||||
index 363fdeee..0a39a0d0 100644
|
|
||||||
--- a/tools-local/tasks/Microsoft.DotNet.SourceBuild.Tasks.XPlat/PublishCoreSetupBinaries.cs
|
|
||||||
+++ b/tools-local/tasks/Microsoft.DotNet.SourceBuild.Tasks.XPlat/PublishCoreSetupBinaries.cs
|
|
||||||
@@ -46,6 +46,8 @@ namespace Microsoft.DotNet.Build.Tasks
|
|
||||||
".fedora.32", "-fedora.32",
|
|
||||||
".fedora.33", "-fedora.33",
|
|
||||||
".fedora.34", "-fedora.34",
|
|
||||||
+ ".fedora.35", "-fedora.35",
|
|
||||||
+ ".fedora.36", "-fedora.36",
|
|
||||||
"-linux", ".linux",
|
|
||||||
"-osx", ".osx",
|
|
||||||
"-OSX", ".OSX",
|
|
@ -1,13 +0,0 @@
|
|||||||
--- a/patches/runtime/0014-Fix-singlefilehost-build-in-non-portable-mode-42415.patch
|
|
||||||
+++ b/patches/runtime/0014-Fix-singlefilehost-build-in-non-portable-mode-42415.patch
|
|
||||||
@@ -45,8 +45,8 @@
|
|
||||||
# These options are used to force every object to be included even if it's unused.
|
|
||||||
set(START_WHOLE_ARCHIVE -Wl,--whole-archive)
|
|
||||||
@@ -212,3 +217,10 @@ target_link_libraries(singlefilehost
|
|
||||||
- ${NATIVE_LIBS}
|
|
||||||
- ${END_WHOLE_ARCHIVE}
|
|
||||||
+ ${NATIVE_LIBS_EXTRA}
|
|
||||||
+
|
|
||||||
)
|
|
||||||
+
|
|
||||||
+if(NOT FEATURE_DISTRO_AGNOSTIC_SSL)
|
|
@ -1,14 +1,14 @@
|
|||||||
#!/bin/bash
|
#!/bin/bash
|
||||||
|
|
||||||
# Usage:
|
# Usage:
|
||||||
# ./update-release sdk-version runtime-version
|
# ./update-release sdk-version runtime-version [tarball-name]
|
||||||
|
|
||||||
set -euo pipefail
|
set -euo pipefail
|
||||||
IFS=$'\n\t'
|
IFS=$'\n\t'
|
||||||
|
|
||||||
print_usage() {
|
print_usage() {
|
||||||
echo " Usage:"
|
echo " Usage:"
|
||||||
echo " ./update-release sdk-version runtime-version"
|
echo " ./update-release sdk-version runtime-version [tarball-name]"
|
||||||
}
|
}
|
||||||
|
|
||||||
positional_args=()
|
positional_args=()
|
||||||
@ -40,10 +40,20 @@ if [[ -z ${runtime_version} ]]; then
|
|||||||
exit 1
|
exit 1
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
tag=v${sdk_version}-SDK
|
||||||
|
|
||||||
|
user_provided_tarball_name=${positional_args[2]:-}
|
||||||
|
if [[ -n "${user_provided_tarball_name}" ]]; then
|
||||||
|
# we know the format build-dotnet-tarball expects for the original tarball:
|
||||||
|
# dotnet-${tag}-original.tar.gz
|
||||||
|
./rename-tarball "$user_provided_tarball_name" dotnet-${tag}-original.tar.gz
|
||||||
|
fi
|
||||||
|
|
||||||
|
|
||||||
host_version="$runtime_version"
|
host_version="$runtime_version"
|
||||||
|
|
||||||
if [[ ! -f "dotnet-v${sdk_version}-SDK.tar.gz" ]]; then
|
if [[ ! -f "dotnet-${tag}.tar.gz" ]]; then
|
||||||
./build-dotnet-tarball "v${sdk_version}-SDK"
|
./build-dotnet-tarball "${tag}"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
set -x
|
set -x
|
||||||
|
Loading…
Reference in New Issue
Block a user