import dotnet5.0-5.0.207-3.el8
This commit is contained in:
parent
6f5f19809d
commit
f63c675133
@ -1 +1 @@
|
||||
88fd61e290a8c6c76759ba819d42a2d861e7b521 SOURCES/dotnet-v5.0.208-SDK.tar.gz
|
||||
ed16c6e24e11b7108bdff716ae73cfd8d82823d7 SOURCES/dotnet-v5.0.207-SDK.tar.gz
|
||||
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/dotnet-v5.0.208-SDK.tar.gz
|
||||
SOURCES/dotnet-v5.0.207-SDK.tar.gz
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff --git a/src/installer/corehost/cli/apphost/static/CMakeLists.txt b/src/installer/corehost/cli/apphost/static/CMakeLists.txt
|
||||
index 85ea6ffe642..e6369f6b9ad 100644
|
||||
--- a/src/installer/corehost/cli/apphost/static/CMakeLists.txt
|
||||
+++ b/src/installer/corehost/cli/apphost/static/CMakeLists.txt
|
||||
@@ -207,12 +207,12 @@
|
||||
libhostcommon
|
||||
${CORECLR_LIBRARIES}
|
||||
|
||||
- ${ZLIB_LIBRARIES}
|
||||
- ${LIBGSS}
|
||||
- ${NATIVE_LIBS_EXTRA}
|
||||
-
|
||||
${START_WHOLE_ARCHIVE}
|
||||
${RUNTIMEINFO_LIB}
|
||||
${NATIVE_LIBS}
|
||||
${END_WHOLE_ARCHIVE}
|
||||
+
|
||||
+ ${ZLIB_LIBRARIES}
|
||||
+ ${LIBGSS}
|
||||
+ ${NATIVE_LIBS_EXTRA}
|
||||
)
|
@ -1,13 +0,0 @@
|
||||
--- a/patches/runtime/0010-Fix-singlefilehost-build-in-non-portable-mode-42415.patch
|
||||
+++ b/patches/runtime/0010-Fix-singlefilehost-build-in-non-portable-mode-42415.patch
|
||||
@@ -45,8 +45,8 @@
|
||||
# These options are used to force every object to be included even if it's unused.
|
||||
set(START_WHOLE_ARCHIVE -Wl,--whole-archive)
|
||||
@@ -216,3 +221,10 @@ target_link_libraries(
|
||||
- ${NATIVE_LIBS}
|
||||
- ${END_WHOLE_ARCHIVE}
|
||||
+ ${LIBGSS}
|
||||
+ ${NATIVE_LIBS_EXTRA}
|
||||
)
|
||||
+
|
||||
+if(NOT FEATURE_DISTRO_AGNOSTIC_SSL)
|
@ -1,4 +1,4 @@
|
||||
%bcond_without bootstrap
|
||||
%bcond_with bootstrap
|
||||
|
||||
# Avoid provides/requires from private libraries
|
||||
%global privlibs libhostfxr
|
||||
@ -20,10 +20,10 @@
|
||||
# until that's done, disable LTO. This has to happen before setting the flags below.
|
||||
%define _lto_cflags %{nil}
|
||||
|
||||
%global host_version 5.0.11
|
||||
%global runtime_version 5.0.11
|
||||
%global host_version 5.0.10
|
||||
%global runtime_version 5.0.10
|
||||
%global aspnetcore_runtime_version %{runtime_version}
|
||||
%global sdk_version 5.0.208
|
||||
%global sdk_version 5.0.207
|
||||
%global templates_version %{runtime_version}
|
||||
#%%global templates_version %%(echo %%{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
|
||||
|
||||
@ -56,7 +56,7 @@
|
||||
|
||||
Name: dotnet5.0
|
||||
Version: %{sdk_rpm_version}
|
||||
Release: 1%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: .NET Runtime and SDK
|
||||
License: MIT and ASL 2.0 and BSD and LGPLv2+ and CC-BY and CC0 and MS-PL and EPL-1.0 and GPL+ and GPLv2 and ISC and OFL and zlib
|
||||
URL: https://github.com/dotnet/
|
||||
@ -67,12 +67,7 @@ Source0: dotnet-v%{src_version}-SDK.tar.gz
|
||||
Source1: check-debug-symbols.py
|
||||
Source2: dotnet.sh.in
|
||||
|
||||
Patch1: source-build-runtime-fixup-linker-order.patch
|
||||
Patch2: source-build-remove-test-references-from-patches.patch
|
||||
|
||||
# https://github.com/dotnet/runtime/pull/42094
|
||||
# Fix linker order when linking with --as-needed
|
||||
Patch100: runtime-linker-order.patch
|
||||
Patch1: source-build-remove-test-references-from-patches.patch
|
||||
|
||||
# Disable telemetry by default; make it opt-in
|
||||
Patch500: sdk-telemetry-optout.patch
|
||||
@ -295,7 +290,7 @@ applications using the .NET SDK.
|
||||
%dotnet_targeting_pack dotnet-apphost-pack-5.0 %{runtime_rpm_version} Microsoft.NETCore.App 5.0 Microsoft.NETCore.App.Host.%{runtime_id}
|
||||
%dotnet_targeting_pack dotnet-targeting-pack-5.0 %{runtime_rpm_version} Microsoft.NETCore.App 5.0 Microsoft.NETCore.App.Ref
|
||||
%dotnet_targeting_pack aspnetcore-targeting-pack-5.0 %{aspnetcore_runtime_rpm_version} Microsoft.AspNetCore.App 5.0 Microsoft.AspNetCore.App.Ref
|
||||
%dotnet_targeting_pack netstandard-targeting-pack-2.1 %{sdk_rpm_version} NETStandard.Library 2.1 NETStandard.Library.Ref
|
||||
#%%dotnet_targeting_pack netstandard-targeting-pack-2.1 %%{sdk_rpm_version} NETStandard.Library 2.1 NETStandard.Library.Ref
|
||||
|
||||
|
||||
%package -n dotnet-sdk-5.0-source-built-artifacts
|
||||
@ -320,32 +315,28 @@ find -iname '*.so' -type f -delete
|
||||
find -iname '*.tar.gz' -type f -delete
|
||||
find -iname '*.nupkg' -type f -delete
|
||||
find -iname '*.zip' -type f -delete
|
||||
rm -rf .dotnet/
|
||||
rm -rf packages/source-built
|
||||
%endif
|
||||
|
||||
rm -rf .dotnet/
|
||||
|
||||
%if %{without bootstrap}
|
||||
sed -i -e 's|5.0.100-preview1-014459|5.0.103|' global.json
|
||||
mkdir -p packages/archive
|
||||
ln -s %{_libdir}/dotnet/source-built-artifacts/*.tar.gz packages/archive/
|
||||
ln -s %{_libdir}/dotnet/reference-packages/Private.SourceBuild.ReferencePackages*.tar.gz packages/archive
|
||||
%endif
|
||||
|
||||
# Fix bad hardcoded path in build
|
||||
sed -i 's|/usr/share/dotnet|%{_libdir}/dotnet|' src/dotnet-runtime.*/src/installer/corehost/cli/hostmisc/pal.unix.cpp
|
||||
sed -i 's|/usr/share/dotnet|%{_libdir}/dotnet|' src/runtime.*/src/installer/corehost/cli/hostmisc/pal.unix.cpp
|
||||
|
||||
# Disable warnings
|
||||
sed -i 's|skiptests|skiptests ignorewarnings|' repos/runtime.common.props
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
pushd src/dotnet-runtime.*
|
||||
%patch100 -p1
|
||||
pushd src/runtime.*
|
||||
popd
|
||||
|
||||
pushd src/dotnet-sdk.*
|
||||
pushd src/sdk.*
|
||||
%patch500 -p1
|
||||
popd
|
||||
|
||||
@ -362,10 +353,10 @@ find -iname 'nuget.config' -exec echo {}: \; -exec cat {} \; -exec echo \;
|
||||
%build
|
||||
cat /etc/os-release
|
||||
|
||||
#%%if %%{without bootstrap}
|
||||
# We need to create a copy because we will mutate this
|
||||
cp -a %{_libdir}/dotnet previously-built-dotnet
|
||||
#%%endif
|
||||
%if %{without bootstrap}
|
||||
# We need to create a copy because we will mutate this
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora} > 32 || 0%{?rhel} > 8
|
||||
# Setting this macro ensures that only clang supported options will be
|
||||
@ -407,6 +398,8 @@ unset LDFLAGS
|
||||
|
||||
VERBOSE=1 ./build.sh \
|
||||
--with-sdk previously-built-dotnet \
|
||||
%if %{without bootstrap}
|
||||
%endif
|
||||
-- \
|
||||
/v:n \
|
||||
/p:SkipPortableRuntimeBuild=true \
|
||||
@ -447,29 +440,34 @@ chmod 0755 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Host.%{run
|
||||
chmod 0644 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Host.%{runtime_id}/%{runtime_version}/runtimes/%{runtime_id}/native/nethost.h
|
||||
chmod 0755 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Host.%{runtime_id}/%{runtime_version}/runtimes/%{runtime_id}/native/singlefilehost
|
||||
|
||||
install -dm 0755 %{buildroot}%{_sysconfdir}/profile.d/
|
||||
install dotnet.sh %{buildroot}%{_sysconfdir}/profile.d/
|
||||
# Provided by dotnet-host from another SRPM
|
||||
#install -dm 0755 %%{buildroot}%%{_sysconfdir}/profile.d/
|
||||
#install dotnet.sh %%{buildroot}%%{_sysconfdir}/profile.d/
|
||||
|
||||
install -dm 0755 %{buildroot}/%{_datadir}/bash-completion/completions
|
||||
# Provided by dotnet-host from another SRPM
|
||||
#install -dm 0755 %%{buildroot}/%%{_datadir}/bash-completion/completions
|
||||
# dynamic completion needs the file to be named the same as the base command
|
||||
install src/dotnet-sdk.*/scripts/register-completions.bash %{buildroot}/%{_datadir}/bash-completion/completions/dotnet
|
||||
#install src/sdk.*/scripts/register-completions.bash %%{buildroot}/%%{_datadir}/bash-completion/completions/dotnet
|
||||
|
||||
# TODO: the zsh completion script needs to be ported to use #compdef
|
||||
#install -dm 755 %%{buildroot}/%%{_datadir}/zsh/site-functions
|
||||
#install src/cli/scripts/register-completions.zsh %%{buildroot}/%%{_datadir}/zsh/site-functions/_dotnet
|
||||
|
||||
install -dm 0755 %{buildroot}%{_bindir}
|
||||
ln -s ../../%{_libdir}/dotnet/dotnet %{buildroot}%{_bindir}/
|
||||
# Provided by dotnet-host from another SRPM
|
||||
#install -dm 0755 %%{buildroot}%%{_bindir}
|
||||
#ln -s ../../%%{_libdir}/dotnet/dotnet %%{buildroot}%%{_bindir}/
|
||||
|
||||
install -dm 0755 %{buildroot}%{_mandir}/man1/
|
||||
find -iname 'dotnet*.1' -type f -exec cp {} %{buildroot}%{_mandir}/man1/ \;
|
||||
# Provided by dotnet-host from another SRPM
|
||||
#install -dm 0755 %%{buildroot}%%{_mandir}/man1/
|
||||
#find -iname 'dotnet*.1' -type f -exec cp {} %%{buildroot}%%{_mandir}/man1/ \;
|
||||
|
||||
echo "%{_libdir}/dotnet" >> install_location
|
||||
install -dm 0755 %{buildroot}%{_sysconfdir}/dotnet
|
||||
install install_location %{buildroot}%{_sysconfdir}/dotnet/
|
||||
# Provided by dotnet-host from another SRPM
|
||||
#echo "%%{_libdir}/dotnet" >> install_location
|
||||
#install -dm 0755 %%{buildroot}%%{_sysconfdir}/dotnet
|
||||
#install install_location %%{buildroot}%%{_sysconfdir}/dotnet/
|
||||
|
||||
#install -dm 0755 %%{buildroot}%%{_libdir}/dotnet/source-built-artifacts
|
||||
#install artifacts/%%{runtime_arch}/Release/Private.SourceBuilt.Artifacts.*.tar.gz %%{buildroot}/%%{_libdir}/dotnet/source-built-artifacts/
|
||||
install -dm 0755 %{buildroot}%{_libdir}/dotnet/source-built-artifacts
|
||||
install artifacts/%{runtime_arch}/Release/Private.SourceBuilt.Artifacts.*.tar.gz %{buildroot}/%{_libdir}/dotnet/source-built-artifacts/
|
||||
|
||||
# Check debug symbols in all elf objects. This is not in %%check
|
||||
# because native binaries are stripped by rpm-build after %%install.
|
||||
@ -477,28 +475,17 @@ install install_location %{buildroot}%{_sysconfdir}/dotnet/
|
||||
echo "Testing build results for debug symbols..."
|
||||
%{SOURCE1} -v %{buildroot}%{_libdir}/dotnet/
|
||||
|
||||
|
||||
%check
|
||||
# Self-check
|
||||
%{buildroot}%{_libdir}/dotnet/dotnet --info
|
||||
|
||||
# Provided by dotnet-host from another SRPM
|
||||
rm %{buildroot}%{_libdir}/dotnet/LICENSE.txt
|
||||
rm %{buildroot}%{_libdir}/dotnet/ThirdPartyNotices.txt
|
||||
rm %{buildroot}%{_libdir}/dotnet/dotnet
|
||||
|
||||
%files -n dotnet
|
||||
# empty package useful for dependencies
|
||||
# Provided by netstandard-targeting-pack-2.1 from another SRPM
|
||||
rm -rf %{buildroot}%{_libdir}/dotnet/packs/NETStandard.Library.Ref/2.1.0
|
||||
|
||||
%files -n dotnet-host
|
||||
%dir %{_libdir}/dotnet
|
||||
%{_libdir}/dotnet/dotnet
|
||||
%dir %{_libdir}/dotnet/host
|
||||
%dir %{_libdir}/dotnet/host/fxr
|
||||
%{_bindir}/dotnet
|
||||
%license %{_libdir}/dotnet/LICENSE.txt
|
||||
%license %{_libdir}/dotnet/ThirdPartyNotices.txt
|
||||
%doc %{_mandir}/man1/dotnet*.1.gz
|
||||
%{_sysconfdir}/profile.d/dotnet.sh
|
||||
%{_sysconfdir}/dotnet
|
||||
%dir %{_datadir}/bash-completion
|
||||
%dir %{_datadir}/bash-completion/completions
|
||||
%{_datadir}/bash-completion/completions/dotnet
|
||||
|
||||
%files -n dotnet-hostfxr-5.0
|
||||
%dir %{_libdir}/dotnet/host/fxr
|
||||
@ -523,48 +510,41 @@ echo "Testing build results for debug symbols..."
|
||||
%{_libdir}/dotnet/sdk/%{sdk_version}
|
||||
%dir %{_libdir}/dotnet/packs
|
||||
|
||||
#%%files -n dotnet-sdk-5.0-source-built-artifacts
|
||||
#%%dir %%{_libdir}/dotnet
|
||||
#%%{_libdir}/dotnet/source-built-artifacts
|
||||
%files -n dotnet-sdk-5.0-source-built-artifacts
|
||||
%dir %{_libdir}/dotnet
|
||||
%{_libdir}/dotnet/source-built-artifacts
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 06 2021 Omair Majid <omajid@redhat.com> - 5.0.208-1
|
||||
- Update to .NET SDK 5.0.208 and Runtime 5.0.11
|
||||
- Resolves: RHBZ#2011060
|
||||
* Sun Oct 10 2021 Omair Majid <omajid@redhat.com> - 5.0.207-3
|
||||
- Disable subpackages that will be provided by .NET 6 SRPM
|
||||
- Resolves: RHBZ#1986017
|
||||
|
||||
* Tue Sep 07 2021 Omair Majid <omajid@redhat.com> - 5.0.207-1
|
||||
* Fri Sep 24 2021 Omair Majid <omajid@redhat.com> - 5.0.207-2
|
||||
- Update to .NET SDK 5.0.207 and Runtime 5.0.10
|
||||
- Resolves: RHBZ#2000460
|
||||
- Resolves: RHBZ#2000319
|
||||
|
||||
* Fri Aug 06 2021 Omair Majid <omajid@redhat.com> - 5.0.206-1
|
||||
* Thu Aug 12 2021 Omair Majid <omajid@redhat.com> - 5.0.206-1
|
||||
- Update to .NET SDK 5.0.206 and Runtime 5.0.9
|
||||
- Resolves: RHBZ#1990965
|
||||
- Resolves: RHBZ#1990940
|
||||
|
||||
* Fri Jul 23 2021 Omair Majid <omajid@redhat.com> - 5.0.205-2
|
||||
- Update to new upstream release for .NET SDK 5.0.205 and Runtime 5.0.8
|
||||
- Resolves: RHBZ#1985446
|
||||
|
||||
* Thu Jul 08 2021 Andrew Slice <andrew.slice@redhat.com> - 5.0.205-1
|
||||
* Tue Aug 10 2021 Omair Majid <omajid@redhat.com> - 5.0.205-1
|
||||
- Update to .NET SDK 5.0.205 and Runtime 5.0.8
|
||||
- Added a patch to remove references to the tests directory from other patches.
|
||||
- Resolves: RHBZ#1980412
|
||||
- Resolves: RHBZ#1985445
|
||||
|
||||
* Mon May 31 2021 Omair Majid <omajid@redhat.com> - 5.0.204-1
|
||||
* Fri Jun 11 2021 Omair Majid <omajid@redhat.com> - 5.0.204-1
|
||||
- Update to .NET SDK 5.0.204 and Runtime 5.0.7
|
||||
- Resolves: RHBZ#1966166
|
||||
- Resolves: RHBZ#1966164
|
||||
- Resolves: RHBZ#1966996
|
||||
|
||||
* Thu Apr 29 2021 Omair Majid <omajid@redhat.com> - 5.0.203-1
|
||||
* Fri Jun 11 2021 Omair Majid <omajid@redhat.com> - 5.0.203-1
|
||||
- Update to .NET SDK 5.0.203 and Runtime 5.0.6
|
||||
- Resolves: RHBZ#1954328
|
||||
- Resolves: RHBZ#1954327
|
||||
|
||||
* Tue Apr 13 2021 Omair Majid <omajid@redhat.com> - 5.0.202-1
|
||||
* Thu Apr 22 2021 Omair Majid <omajid@redhat.com> - 5.0.202-2
|
||||
- Update to .NET SDK 5.0.202 and Runtime 5.0.5
|
||||
- Resolves: RHBZ#1947662
|
||||
|
||||
* Tue Mar 09 2021 Omair Majid <omajid@redhat.com> - 5.0.104-2
|
||||
- Update to .NET SDK 5.0.104 and Runtime 5.0.4
|
||||
- Resolves: RHBZ#1934241
|
||||
- Create -source-built-artifacts subpackage
|
||||
- Resolves: RHBZ#1947600
|
||||
|
||||
* Wed Feb 10 2021 Omair Majid <omajid@redhat.com> - 5.0.103-2
|
||||
- Update to .NET SDK 5.0.103 and Runtime 5.0.3
|
||||
|
Loading…
Reference in New Issue
Block a user