import dotnet5.0-5.0.206-1.el8

This commit is contained in:
CentOS Sources 2021-10-06 05:57:45 -04:00 committed by Stepan Oksanichenko
parent 9e8b50e837
commit 91a1a58ea8
7 changed files with 72 additions and 61 deletions

View File

@ -1 +1 @@
7d0d8dc54afe995e0fb450e305856f3fd3ffee17 SOURCES/dotnet-v5.0.103-SDK.tar.gz
4e69f55efa3555d765674449e65b6b1f7be13a1c SOURCES/dotnet-v5.0.206-SDK.tar.gz

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/dotnet-v5.0.103-SDK.tar.gz
SOURCES/dotnet-v5.0.206-SDK.tar.gz

View File

@ -1,20 +0,0 @@
diff --git a/src/installer/corehost/cli/apphost/static/CMakeLists.txt b/src/installer/corehost/cli/apphost/static/CMakeLists.txt
index 85ea6ffe642..e6369f6b9ad 100644
--- a/src/installer/corehost/cli/apphost/static/CMakeLists.txt
+++ b/src/installer/corehost/cli/apphost/static/CMakeLists.txt
@@ -204,11 +204,12 @@ target_link_libraries(singlefilehost
libhostcommon
${CORECLR_LIBRARIES}
+ ${START_WHOLE_ARCHIVE}
+ ${NATIVE_LIBS}
+ ${END_WHOLE_ARCHIVE}
+
${ZLIB_LIBRARIES}
${LIBGSS}
${NATIVE_LIBS_EXTRA}
- ${START_WHOLE_ARCHIVE}
- ${NATIVE_LIBS}
- ${END_WHOLE_ARCHIVE}
)

View File

@ -15,4 +15,4 @@ index de1ebb9e6..6bbf479de 100644
+
DebugHelper.HandleDebugSwitch(ref args);
new MulticoreJitActivator().TryActivateMulticoreJit();
// Capture the current timestamp to calculate the host overhead.

View File

@ -0,0 +1,28 @@
--- a/patches/runtime/0036-Add-net46-for-some-packages-to-support-Omnisharp.patch
+++ b/patches/runtime/0036-Add-net46-for-some-packages-to-support-Omnisharp.patch
@@ -58,25 +58,3 @@
<DefineConstants>$(DefineConstants);RESOURCES_EXTENSIONS</DefineConstants>
<Nullable>enable</Nullable>
</PropertyGroup>
-diff --git a/src/libraries/System.Resources.Extensions/tests/System.Resources.Extensions.Tests.csproj b/src/libraries/System.Resources.Extensions/tests/System.Resources.Extensions.Tests.csproj
-index b48848c7a45..b310496f4bc 100644
---- a/src/libraries/System.Resources.Extensions/tests/System.Resources.Extensions.Tests.csproj
-+++ b/src/libraries/System.Resources.Extensions/tests/System.Resources.Extensions.Tests.csproj
-@@ -1,6 +1,6 @@
- <Project Sdk="Microsoft.NET.Sdk">
- <PropertyGroup>
-- <TargetFrameworks>$(NetCoreAppCurrent)-Windows_NT;$(NetCoreAppCurrent)-Unix;net461</TargetFrameworks>
-+ <TargetFrameworks>$(NetCoreAppCurrent)-Windows_NT;$(NetCoreAppCurrent)-Unix;net461;net46</TargetFrameworks>
- <IncludeRemoteExecutor>true</IncludeRemoteExecutor>
- </PropertyGroup>
- <ItemGroup>
-@@ -44,4 +44,4 @@
- </ItemGroup>
- <Exec Command="%(ExecuteMethod.Command)" WorkingDirectory="$(TargetDir)" />
- </Target>
--</Project>
-\ No newline at end of file
-+</Project>
---
-2.18.0
-

View File

@ -1,13 +0,0 @@
--- a/patches/runtime/0014-Fix-singlefilehost-build-in-non-portable-mode-42415.patch
+++ b/patches/runtime/0014-Fix-singlefilehost-build-in-non-portable-mode-42415.patch
@@ -45,8 +45,8 @@
# These options are used to force every object to be included even if it's unused.
set(START_WHOLE_ARCHIVE -Wl,--whole-archive)
@@ -212,3 +217,10 @@ target_link_libraries(singlefilehost
- ${NATIVE_LIBS}
- ${END_WHOLE_ARCHIVE}
+ ${NATIVE_LIBS_EXTRA}
+
)
+
+if(NOT FEATURE_DISTRO_AGNOSTIC_SSL)

View File

@ -1,4 +1,4 @@
%bcond_without bootstrap
%bcond_with bootstrap
# Avoid provides/requires from private libraries
%global privlibs libhostfxr
@ -20,10 +20,10 @@
# until that's done, disable LTO. This has to happen before setting the flags below.
%define _lto_cflags %{nil}
%global host_version 5.0.3
%global runtime_version 5.0.3
%global host_version 5.0.9
%global runtime_version 5.0.9
%global aspnetcore_runtime_version %{runtime_version}
%global sdk_version 5.0.103
%global sdk_version 5.0.206
%global templates_version %{runtime_version}
#%%global templates_version %%(echo %%{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
@ -56,7 +56,7 @@
Name: dotnet5.0
Version: %{sdk_rpm_version}
Release: 2%{?dist}
Release: 1%{?dist}
Summary: .NET Runtime and SDK
License: MIT and ASL 2.0 and BSD and LGPLv2+ and CC-BY and CC0 and MS-PL and EPL-1.0 and GPL+ and GPLv2 and ISC and OFL and zlib
URL: https://github.com/dotnet/
@ -67,11 +67,7 @@ Source0: dotnet-v%{src_version}-SDK.tar.gz
Source1: check-debug-symbols.py
Source2: dotnet.sh.in
Patch1: source-build-runtime-fixup-linker-order.patch
# https://github.com/dotnet/runtime/pull/42094
# Fix linker order when linking with --as-needed
Patch100: runtime-linker-order.patch
Patch1: source-build-remove-test-references-from-patches.patch
# Disable telemetry by default; make it opt-in
Patch500: sdk-telemetry-optout.patch
@ -86,9 +82,9 @@ ExclusiveArch: x86_64
BuildRequires: clang
BuildRequires: cmake
BuildRequires: coreutils
%if %{without bootstrap}
BuildRequires: dotnet-build-reference-packages
BuildRequires: dotnet-sdk-5.0
%if %{without bootstrap}
BuildRequires: dotnet5.0-build-reference-packages
BuildRequires: dotnet-sdk-5.0-source-built-artifacts
%endif
BuildRequires: findutils
@ -324,25 +320,23 @@ rm -rf packages/source-built
%endif
%if %{without bootstrap}
sed -i -e 's|5.0.100-preview1-014459|5.0.103|' global.json
mkdir -p packages/archive
ln -s %{_libdir}/dotnet/source-built-artifacts/*.tar.gz packages/archive/
ln -s %{_libdir}/dotnet/reference-packages/Private.SourceBuild.ReferencePackages*.tar.gz packages/archive
%endif
# Fix bad hardcoded path in build
sed -i 's|/usr/share/dotnet|%{_libdir}/dotnet|' src/dotnet-runtime.*/src/installer/corehost/cli/hostmisc/pal.unix.cpp
sed -i 's|/usr/share/dotnet|%{_libdir}/dotnet|' src/runtime.*/src/installer/corehost/cli/hostmisc/pal.unix.cpp
# Disable warnings
sed -i 's|skiptests|skiptests ignorewarnings|' repos/runtime.common.props
%patch1 -p1
pushd src/dotnet-runtime.*
%patch100 -p1
pushd src/runtime.*
popd
pushd src/dotnet-sdk.*
pushd src/sdk.*
%patch500 -p1
popd
@ -359,9 +353,9 @@ find -iname 'nuget.config' -exec echo {}: \; -exec cat {} \; -exec echo \;
%build
cat /etc/os-release
cp -a %{_libdir}/dotnet previously-built-dotnet
%if %{without bootstrap}
# We need to create a copy because we will mutate this
cp -a %{_libdir}/dotnet previously-built-dotnet
%endif
%if 0%{?fedora} > 32 || 0%{?rhel} > 8
@ -403,8 +397,8 @@ unset LDFLAGS
#%%endif
VERBOSE=1 ./build.sh \
%if %{without bootstrap}
--with-sdk previously-built-dotnet \
%if %{without bootstrap}
%endif
-- \
/v:n \
@ -451,7 +445,7 @@ install dotnet.sh %{buildroot}%{_sysconfdir}/profile.d/
install -dm 0755 %{buildroot}/%{_datadir}/bash-completion/completions
# dynamic completion needs the file to be named the same as the base command
install src/dotnet-sdk.*/scripts/register-completions.bash %{buildroot}/%{_datadir}/bash-completion/completions/dotnet
install src/sdk.*/scripts/register-completions.bash %{buildroot}/%{_datadir}/bash-completion/completions/dotnet
# TODO: the zsh completion script needs to be ported to use #compdef
#install -dm 755 %%{buildroot}/%%{_datadir}/zsh/site-functions
@ -467,8 +461,8 @@ echo "%{_libdir}/dotnet" >> install_location
install -dm 0755 %{buildroot}%{_sysconfdir}/dotnet
install install_location %{buildroot}%{_sysconfdir}/dotnet/
#install -dm 0755 %%{buildroot}%%{_libdir}/dotnet/source-built-artifacts
#install artifacts/%%{runtime_arch}/Release/Private.SourceBuilt.Artifacts.*.tar.gz %%{buildroot}/%%{_libdir}/dotnet/source-built-artifacts/
install -dm 0755 %{buildroot}%{_libdir}/dotnet/source-built-artifacts
install artifacts/%{runtime_arch}/Release/Private.SourceBuilt.Artifacts.*.tar.gz %{buildroot}/%{_libdir}/dotnet/source-built-artifacts/
# Check debug symbols in all elf objects. This is not in %%check
# because native binaries are stripped by rpm-build after %%install.
@ -522,12 +516,34 @@ echo "Testing build results for debug symbols..."
%{_libdir}/dotnet/sdk/%{sdk_version}
%dir %{_libdir}/dotnet/packs
#%%files -n dotnet-sdk-5.0-source-built-artifacts
#%%dir %%{_libdir}/dotnet
#%%{_libdir}/dotnet/source-built-artifacts
%files -n dotnet-sdk-5.0-source-built-artifacts
%dir %{_libdir}/dotnet
%{_libdir}/dotnet/source-built-artifacts
%changelog
* Thu Aug 12 2021 Omair Majid <omajid@redhat.com> - 5.0.206-1
- Update to .NET SDK 5.0.206 and Runtime 5.0.9
- Resolves: RHBZ#1990940
* Tue Aug 10 2021 Omair Majid <omajid@redhat.com> - 5.0.205-1
- Update to .NET SDK 5.0.205 and Runtime 5.0.8
- Resolves: RHBZ#1985445
* Fri Jun 11 2021 Omair Majid <omajid@redhat.com> - 5.0.204-1
- Update to .NET SDK 5.0.204 and Runtime 5.0.7
- Resolves: RHBZ#1966164
- Resolves: RHBZ#1966996
* Fri Jun 11 2021 Omair Majid <omajid@redhat.com> - 5.0.203-1
- Update to .NET SDK 5.0.203 and Runtime 5.0.6
- Resolves: RHBZ#1954327
* Thu Apr 22 2021 Omair Majid <omajid@redhat.com> - 5.0.202-2
- Update to .NET SDK 5.0.202 and Runtime 5.0.5
- Create -source-built-artifacts subpackage
- Resolves: RHBZ#1947600
* Wed Feb 10 2021 Omair Majid <omajid@redhat.com> - 5.0.103-2
- Update to .NET SDK 5.0.103 and Runtime 5.0.3
- Resolves: RHBZ#1924762