dotnet3.1/coreclr-hardening-flags.patch

12 lines
367 B
Diff

diff --git a/src/debug/createdump/CMakeLists.txt b/src/debug/createdump/CMakeLists.txt
--- a/src/debug/createdump/CMakeLists.txt
+++ b/src/debug/createdump/CMakeLists.txt
@@ -21,6 +21,7 @@ include_directories(BEFORE ${VM_DIR})
add_definitions(-DPAL_STDCPP_COMPAT)
add_compile_options(-fPIE)
+add_link_options(-pie)
set(CREATEDUMP_SOURCES
createdump.cpp