import dotnet3.1-3.1.117-1.el8

This commit is contained in:
CentOS Sources 2021-08-18 18:38:05 +00:00 committed by Andrew Lukoshko
parent 8ad6472eb7
commit f5f88b3290
6 changed files with 11 additions and 69 deletions

View File

@ -1 +1 @@
5c5e6634828f357fcfefe8c1b17ffe80f1491d2a SOURCES/dotnet-v3.1.116-SDK.tar.gz
9bd8f83bef529745ea6feaaecbc1bee953aea492 SOURCES/dotnet-v3.1.117-SDK.tar.gz

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/dotnet-v3.1.116-SDK.tar.gz
SOURCES/dotnet-v3.1.117-SDK.tar.gz

View File

@ -1,23 +0,0 @@
diff --git a/src/settings.cmake b/src/settings.cmake
--- a/src/settings.cmake
+++ b/src/settings.cmake
@@ -218,6 +218,8 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Xlinker -Bsymbolic -Bsymbolic-functions")
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--build-id=sha1")
+ set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -pie")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--build-id=sha1")
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -pie")
add_compile_options(-fstack-protector-strong)
elseif(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
add_compile_options(-fstack-protector)
--- a/src/corehost/cli/apphost/CMakeLists.txt
+++ b/src/corehost/cli/apphost/CMakeLists.txt
@@ -50,6 +50,8 @@
add_definitions(-DFEATURE_APPHOST=1)
+set_target_properties("apphost" PROPERTIES LINK_FLAGS -pie)
+
# Disable manifest generation into the file .exe on Windows
if(WIN32)
set_property(TARGET ${PROJECT_NAME} PROPERTY

View File

@ -1,22 +0,0 @@
--- a/src/debug/createdump/CMakeLists.txt
+++ b/src/debug/createdump/CMakeLists.txt
@@ -38,6 +38,8 @@
add_dependencies(createdump pal_redefines_file)
+SET_TARGET_PROPERTIES(createdump PROPERTIES LINK_FLAGS -pie)
+
target_link_libraries(createdump
createdump_lib
# share the PAL/corguids in the dac module
--- a/src/corefx/System.Globalization.Native/CMakeLists.txt
+++ b/src/corefx/System.Globalization.Native/CMakeLists.txt
@@ -71,6 +71,8 @@
set_target_properties(System.Globalization.Native_Static PROPERTIES PREFIX "")
set_target_properties(System.Globalization.Native_Static PROPERTIES OUTPUT_NAME System.Globalization.Native)
+set_target_properties(System.Globalization.Native PROPERTIES LINK_FLAGS -pie)
+
if(NOT CLR_CMAKE_PLATFORM_DARWIN)
if (NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD AND NOT CMAKE_SYSTEM_NAME STREQUAL NetBSD)
target_link_libraries(System.Globalization.Native

View File

@ -1,11 +0,0 @@
--- a/src/Native/Unix/System.Native/CMakeLists.txt
+++ b/src/Native/Unix/System.Native/CMakeLists.txt
@@ -48,6 +48,8 @@
set_target_properties(System.Native-Static PROPERTIES PREFIX "")
set_target_properties(System.Native-Static PROPERTIES OUTPUT_NAME System.Native CLEAN_DIRECT_OUTPUT 1)
+set_target_properties(System.Native PROPERTIES LINK_FLAGS -pie)
+
if (CMAKE_SYSTEM_NAME STREQUAL Linux AND NOT CLR_CMAKE_PLATFORM_ANDROID)
target_link_libraries(System.Native rt)
endif ()

View File

@ -25,10 +25,10 @@
%endif
%global dotnet_ldflags %(echo %{__global_ldflags} | sed -re 's/-specs=[^ ]*//g')
%global host_version 3.1.16
%global runtime_version 3.1.16
%global host_version 3.1.17
%global runtime_version 3.1.17
%global aspnetcore_runtime_version %{runtime_version}
%global sdk_version 3.1.116
%global sdk_version 3.1.117
%global templates_version %(echo %{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
%global host_rpm_version %{host_version}
@ -77,15 +77,12 @@ Patch1: source-build-ilasm-ildasm-path-fix.patch
Patch100: corefx-optflags-support.patch
Patch103: corefx-39633-cgroupv2-mountpoints.patch
Patch104: corefx-hardening-flags.patch
Patch200: coreclr-27048-sysctl-deprecation.patch
Patch201: coreclr-hardening-flags.patch
# Already applied at tarball build time
#Patch202: coreclr-libunwind-fno-common.patch
#Patch201: coreclr-libunwind-fno-common.patch
Patch300: core-setup-do-not-strip.patch
Patch301: core-setup-hardening-flags.patch
Patch500: cli-telemetry-optout.patch
@ -346,18 +343,15 @@ sed -i 's|skiptests|skiptests ignorewarnings|' repos/coreclr.common.props
pushd src/corefx.*
%patch100 -p1
%patch103 -p1
%patch104 -p1
popd
pushd src/coreclr.*
%patch200 -p1
%patch201 -p1
#%%patch202 -p1
#%%patch201 -p1
popd
pushd src/core-setup.*
%patch300 -p1
%patch301 -p1
popd
pushd src/cli.*
@ -507,6 +501,10 @@ rm -rf %{buildroot}%{_libdir}/dotnet/packs/NETStandard.Library.Ref/2.1.0
%{_libdir}/dotnet/source-built-artifacts
%changelog
* Wed Aug 11 2021 Omair Majid <omajid@redhat.com> - 3.1.117-1
- Update to .NET SDK 3.1.117 and Runtime 3.1.17
- Resolves: RHBZ#1978389
* Fri Jun 11 2021 Omair Majid <omajid@redhat.com> - 3.1.116-1
- Update to .NET SDK 3.1.116 and Runtime 3.1.16
- Resolves: RHBZ#1965499