Update to .NET SDK 3.1.117 and Runtime 3.1.17
Resolves: RHBZ#1961848
This commit is contained in:
parent
cba30c5ced
commit
9a758096ea
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
||||
/dotnet-v3.1.113-SDK.tar.gz
|
||||
/dotnet-v3.1.115-SDK.tar.gz
|
||||
/dotnet-v3.1.116-SDK.tar.gz
|
||||
/dotnet-v3.1.117-SDK.tar.gz
|
||||
|
@ -91,7 +91,7 @@ if [ ! -f "${unmodified_tarball_name}.tar.gz" ]; then
|
||||
git checkout "${tag}"
|
||||
git submodule update --init --recursive
|
||||
clean_dotnet_cache
|
||||
sed -i -e 's|cmakeargs -DCLR_CMAKE_USE_SYSTEM_LIBUNWIND=TRUE||' repos/coreclr.proj
|
||||
sed -i -e 's|cmakeargs -DCLR_CMAKE_USE_SYSTEM_LIBUNWIND=TRUE||' repos/coreclr.common.props
|
||||
mkdir -p patches/coreclr/
|
||||
cp ../../build-coreclr-clang10.patch patches/coreclr/
|
||||
cp ../../coreclr-libunwind-fno-common.patch patches/coreclr/
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff --git a/src/settings.cmake b/src/settings.cmake
|
||||
--- a/src/settings.cmake
|
||||
+++ b/src/settings.cmake
|
||||
@@ -218,6 +218,7 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Xlinker -Bsymbolic -Bsymbolic-functions")
|
||||
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--build-id=sha1")
|
||||
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--build-id=sha1")
|
||||
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -pie")
|
||||
add_compile_options(-fstack-protector-strong)
|
||||
elseif(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
|
||||
add_compile_options(-fstack-protector)
|
@ -1,11 +0,0 @@
|
||||
diff --git a/src/debug/createdump/CMakeLists.txt b/src/debug/createdump/CMakeLists.txt
|
||||
--- a/src/debug/createdump/CMakeLists.txt
|
||||
+++ b/src/debug/createdump/CMakeLists.txt
|
||||
@@ -21,6 +21,7 @@ include_directories(BEFORE ${VM_DIR})
|
||||
add_definitions(-DPAL_STDCPP_COMPAT)
|
||||
|
||||
add_compile_options(-fPIE)
|
||||
+add_link_options(-pie)
|
||||
|
||||
set(CREATEDUMP_SOURCES
|
||||
createdump.cpp
|
@ -21,10 +21,10 @@
|
||||
%define _lto_cflags %{nil}
|
||||
|
||||
|
||||
%global host_version 3.1.16
|
||||
%global runtime_version 3.1.16
|
||||
%global host_version 3.1.17
|
||||
%global runtime_version 3.1.17
|
||||
%global aspnetcore_runtime_version %{runtime_version}
|
||||
%global sdk_version 3.1.116
|
||||
%global sdk_version 3.1.117
|
||||
# upstream can update releases without revving the SDK version so these don't always match
|
||||
%global src_version %{sdk_version}
|
||||
%global templates_version %(echo %{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
|
||||
@ -55,7 +55,7 @@
|
||||
|
||||
Name: dotnet3.1
|
||||
Version: %{sdk_rpm_version}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: .NET Core Runtime and SDK
|
||||
License: MIT and ASL 2.0 and BSD and LGPLv2+ and CC-BY and CC0 and MS-PL and EPL-1.0 and GPL+ and GPLv2 and ISC and OFL and zlib
|
||||
URL: https://github.com/dotnet/
|
||||
@ -89,17 +89,12 @@ Patch112: corefx-openssl-0007-OpenSSL3-Register-legacy-algorithms-when-nee
|
||||
Patch113: corefx-openssl-0008-Work-around-OpenSSL-3.0-ciphers-not-restoring-origin.patch
|
||||
Patch114: corefx-openssl-0009-Use-1-instead-of-true-for-more-portable-code.patch
|
||||
|
||||
# Build with with hardening flags, including -pie
|
||||
Patch200: coreclr-hardening-flags.patch
|
||||
# Fix build with clang 10; Already applied at tarball-build time
|
||||
# Patch201: coreclr-clang10.patch
|
||||
# Patch200: coreclr-clang10.patch
|
||||
# Fix build on recent versions of gcc/clang
|
||||
# https://github.com/libunwind/libunwind/pull/166
|
||||
# Already applied
|
||||
#Patch202: coreclr-libunwind-fno-common.patch
|
||||
|
||||
# Build with with hardening flags, including -pie
|
||||
Patch300: core-setup-hardening-flags.patch
|
||||
#Patch201: coreclr-libunwind-fno-common.patch
|
||||
|
||||
# Disable telemetry by default; make it opt-in
|
||||
Patch500: cli-telemetry-optout.patch
|
||||
@ -383,13 +378,11 @@ pushd src/corefx.*
|
||||
popd
|
||||
|
||||
pushd src/coreclr.*
|
||||
%patch200 -p1
|
||||
#%%patch200 -p1
|
||||
#%%patch201 -p1
|
||||
#%%patch202 -p1
|
||||
popd
|
||||
|
||||
pushd src/core-setup.*
|
||||
%patch300 -p1
|
||||
popd
|
||||
|
||||
pushd src/cli.*
|
||||
@ -575,6 +568,10 @@ echo "Testing build results for debug symbols..."
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Aug 12 2021 Omair Majid <omajid@redhat.com> - 3.1.117-1
|
||||
- Update to .NET SDK 3.1.117 and Runtime 3.1.17
|
||||
- Resolves: RHBZ#1961848
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 3.1.116-3
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dotnet-v3.1.116-SDK.tar.gz) = 5c3eea2936065480fe829448ef8d3f9c858503d1c15c8d46fcdb01fd345dea649cd1a7207e888ae52210bf98c9e7a9076095d3b9095170e4900e2ce9cebc1812
|
||||
SHA512 (dotnet-v3.1.117-SDK.tar.gz) = 1d2c3dfd4826c0f6b83abed8a7d0028ef049132ab6fc9d22f7913ba16543e35ca41ad115041e215b243b606af69ffbc44c4b0bc7644c3f23751d6a9e35b949c8
|
||||
|
@ -23,6 +23,7 @@
|
||||
required_packages:
|
||||
- bash-completion
|
||||
- binutils
|
||||
- compat-openssl11
|
||||
- expect
|
||||
- jq
|
||||
- lldb
|
||||
|
Loading…
Reference in New Issue
Block a user