New upstream 1.3 release, update URL/Source

This commit is contained in:
Peter Robinson 2010-12-08 13:12:31 +00:00
parent 72e2d32ec9
commit bb38922a18
6 changed files with 19 additions and 169 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
dotconf-1.0.13.tar.gz
/dotconf-1.3.tar.gz

View File

@ -1,82 +0,0 @@
diff -up dotconf-1.0.13/dotconf.m4.m4-underquote dotconf-1.0.13/dotconf.m4
--- dotconf-1.0.13/dotconf.m4.m4-underquote 2002-09-17 23:38:08.000000000 +0530
+++ dotconf-1.0.13/dotconf.m4 2008-03-01 19:49:12.000000000 +0530
@@ -2,7 +2,7 @@
dnl ## AM_PATH_DOTCONF([MINIMUM_VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT_FOUND]]])
dnl ##
dnl ##
-AC_DEFUN(AM_PATH_DOTCONF,
+AC_DEFUN([AM_PATH_DOTCONF],
[dnl
dnl Get the cflags and libs from the dotconf-config script
dnl
diff -up dotconf-1.0.13/acinclude.m4.m4-underquote dotconf-1.0.13/acinclude.m4
--- dotconf-1.0.13/acinclude.m4.m4-underquote 2002-01-30 20:29:17.000000000 +0530
+++ dotconf-1.0.13/acinclude.m4 2008-03-01 19:45:18.000000000 +0530
@@ -2,10 +2,10 @@ dnl SQ_EXPAND_DIR(VARNAME, DIR)
dnl expands occurrences of ${prefix} and ${exec_prefix} in the given DIR,
dnl and assigns the resulting string to VARNAME
dnl example: SQ_EXPAND_DIR(LOCALEDIR, "$datadir/locale")
-dnl eg, then: AC_DEFINE_UNQUOTED(LOCALEDIR, "$LOCALEDIR")
+dnl eg, then: AC_DEFINE_UNQUOTED([LOCALEDIR], "$LOCALEDIR")
dnl by Alexandre Oliva
dnl from http://www.cygnus.com/ml/automake/1998-Aug/0040.html
-AC_DEFUN(SQ_EXPAND_DIR, [
+AC_DEFUN([SQ_EXPAND_DIR], [
$1=$2
$1=`(
test "x$prefix" = xNONE && prefix="$ac_default_prefix"
@@ -24,7 +24,7 @@ dnl AC_PHP_ONCE(namespace, variable, cod
dnl
dnl execute code, if variable is not set in namespace
dnl
-AC_DEFUN(AC_PHP_ONCE,[
+AC_DEFUN([AC_PHP_ONCE],[
unique=`echo $ac_n "$2$ac_c" | tr -c -d a-zA-Z0-9`
cmd="echo $ac_n \"\$$1$unique$ac_c\""
if test -n "$unique" && test "`eval $cmd`" = "" ; then
@@ -38,7 +38,7 @@ dnl AC_EXPAND_PATH(path, variable)
dnl
dnl expands path to an absolute path and assigns it to variable
dnl
-AC_DEFUN(AC_EXPAND_PATH,[
+AC_DEFUN([AC_EXPAND_PATH],[
if test -z "$1" || echo "$1" | grep '^/' >/dev/null ; then
$2="$1"
else
@@ -51,7 +51,7 @@ dnl AC_ADD_LIBPATH(path)
dnl
dnl add a library to linkpath/runpath
dnl
-AC_DEFUN(AC_ADD_LIBPATH,[
+AC_DEFUN([AC_ADD_LIBPATH],[
AC_EXPAND_PATH($1, ai_p)
AC_PHP_ONCE(LIBPATH, $ai_p, [
EXTRA_LIBS="$EXTRA_LIBS -L$ai_p"
@@ -71,7 +71,7 @@ dnl AC_ADD_INCLUDE(path)
dnl
dnl add a include path
dnl
-AC_DEFUN(AC_ADD_INCLUDE,[
+AC_DEFUN([AC_ADD_INCLUDE],[
AC_EXPAND_PATH($1, ai_p)
AC_PHP_ONCE(INCLUDEPATH, $ai_p, [
INCLUDES="$INCLUDES -I$ai_p"
@@ -83,7 +83,7 @@ dnl AC_ADD_LIBRARY(library)
dnl
dnl add a library to the link line
dnl
-AC_DEFUN(AC_ADD_LIBRARY,[
+AC_DEFUN([AC_ADD_LIBRARY],[
AC_PHP_ONCE(LIBRARY, $1, [
EXTRA_LIBS="$EXTRA_LIBS -l$1"
])
@@ -94,7 +94,7 @@ dnl AC_ADD_LIBRARY_WITH_PATH(library, pa
dnl
dnl add a library to the link line and path to linkpath/runpath
dnl
-AC_DEFUN(AC_ADD_LIBRARY_WITH_PATH,[
+AC_DEFUN([AC_ADD_LIBRARY_WITH_PATH],[
AC_ADD_LIBPATH($2)
AC_ADD_LIBRARY($1)
])

View File

@ -1,32 +0,0 @@
--- dotconf-1.0.13/dotconf-config.in.multilib 2002-01-30 23:59:17.000000000 +0900
+++ dotconf-1.0.13/dotconf-config.in 2008-02-23 02:28:23.000000000 +0900
@@ -12,7 +12,6 @@
[--version]
[--cflags]
[--libs]
- [--pool]
EOF
exit $1
}
@@ -43,9 +42,6 @@
--libs)
echo_libs=yes
;;
- --pool)
- echo_pool=yes
- ;;
*)
usage 1 1>&2
;;
@@ -65,11 +61,6 @@
fi
if test "$echo_libs" = "yes"; then
- libdirs=-L@libdir@
echo $libdirs -ldotconf
fi
-if test "$echo_pool" = "yes"; then
- echo @libdir@/libpool.a
-fi
-

View File

@ -1,23 +0,0 @@
--- dotconf-1.0.13/src/Makefile.in.legal 2008-02-20 16:19:34.000000000 +0900
+++ dotconf-1.0.13/src/Makefile.in 2008-02-20 16:29:52.000000000 +0900
@@ -88,9 +88,9 @@
INCLUDES = -I. -I$(includedir)
include_HEADERS = dotconf.h
-noinst_HEADERS = readdir.h
+noinst_HEADERS =
lib_LTLIBRARIES = libdotconf.la
-libdotconf_la_SOURCES = dotconf.c readdir.c
+libdotconf_la_SOURCES = dotconf.c
libdotconf_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE) -export-dynamic
@@ -106,7 +106,7 @@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
libdotconf_la_LIBADD =
-libdotconf_la_OBJECTS = dotconf.lo readdir.lo
+libdotconf_la_OBJECTS = dotconf.lo
CFLAGS = @CFLAGS@
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View File

@ -1,27 +1,22 @@
Name: dotconf
Version: 1.0.13
Release: 9%{?dist}
Version: 1.3
Release: 1%{?dist}
Summary: Libraries to parse configuration files
Group: System Environment/Libraries
License: LGPLv2
URL: http://www.azzit.de/dotconf/
Source: http://www.azzit.de/dotconf/download/v1.0/%{name}-%{version}.tar.gz
Patch0: dotconf-1.0.13-remove-ASL11-part.patch
Patch1: dotconf-1.0.13-multilib.patch
Patch2: dotconf-1.0.13-m4-underquote.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
URL: http://www.opentts.org/projects/dotconf
Source: http://files.opentts.org/%{name}/%{name}-%{version}.tar.gz
%description
Dotconf is a library used to handle configuration files.
%package devel
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: pkgconfig
Requires: automake
Requires: pkgconfig
%description devel
@ -32,30 +27,22 @@ developing applications that use %{name}.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
# Override config.{guess,sub}
cp -p /usr/lib/rpm/config.{guess,sub} .
%build
%configure --disable-static
%configure --disable-static --docdir=%{_datadir}/doc/%{name}-%{version}
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
make install DESTDIR=%{buildroot} INSTALL="install -p"
iconv -f iso-8859-2 -t utf-8 -o iconv.tmp AUTHORS
mv iconv.tmp AUTHORS
iconv -f iso-8859-2 -t utf-8 -o iconv.tmp doc/dotconf-features.txt
mv iconv.tmp doc/dotconf-features.txt
find $RPM_BUILD_ROOT -type f -name "*.a" -o -name "*.la" | xargs rm -f
rm examples/maketest.sh
find %{buildroot} -type f -name "*.a" -o -name "*.la" | xargs rm -f
%clean
rm -rf $RPM_BUILD_ROOT
rm -rf $%{buildroot}
%post -p /sbin/ldconfig
@ -65,22 +52,21 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc README AUTHORS COPYING NEWS ChangeLog
%doc README AUTHORS COPYING
%{_libdir}/libdotconf*.so.*
%files devel
%defattr(-,root,root,-)
%doc doc/*
%doc examples/
%{_libdir}/libdotconf*.so
%{_includedir}/libpool.h
%{_includedir}/dotconf.h
%{_bindir}/dotconf-config
%{_datadir}/aclocal/dotconf.m4
%{_libdir}/pkgconfig/dotconf.pc
%changelog
* Wed Dec 8 2010 Peter Robinson <pbrobinson@gmail.com> - 1.3-1
- New upstream 1.3 release, update URL/Source
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.13-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

View File

@ -1 +1 @@
bbf981a5f4a64e94cc6f2a693f96c21a dotconf-1.0.13.tar.gz
35c19ec9b96648f53e987e47e52dbc4c dotconf-1.3.tar.gz