auto-import changelog data from dos2unix-3.1-6.src.rpm
Wed Jan 10 2001 Bernhard Rosenkraenzer <bero@redhat.com> - shut up rpmlint Fri Nov 17 2000 Tim Powers <timp@redhat.com> - use mkstemp instead of mktemp. Not much needed to change. Thu Nov 16 2000 Tim Powers <timp@redhat.com> - cleaned up specfile a bit - built for 7.1 Wed Jul 07 1999 Peter Soos <sp@osb.hu> - Added Hungarian "Summary:" and "%description" - Corrected the file and directory attributes to rebuild the package under RedHat Linux 6.0
This commit is contained in:
parent
4290cff215
commit
0f2616b78e
@ -0,0 +1 @@
|
||||
dos2unix-3.1.tar.bz2
|
49
dos2unix-3.1.patch
Normal file
49
dos2unix-3.1.patch
Normal file
@ -0,0 +1,49 @@
|
||||
--- dos2unix-3.1/Makefile.orig Thu Nov 19 07:09:38 1998
|
||||
+++ dos2unix-3.1/Makefile Fri Nov 17 13:25:35 2000
|
||||
@@ -1,10 +1,12 @@
|
||||
+CFLAGS=
|
||||
+
|
||||
default: dos2unix
|
||||
|
||||
all: dos2unix link install
|
||||
|
||||
|
||||
dos2unix:
|
||||
- gcc -O dos2unix.c -o dos2unix
|
||||
+ gcc $(CFLAGS) dos2unix.c -o dos2unix
|
||||
|
||||
|
||||
link:
|
||||
@@ -12,11 +14,10 @@
|
||||
ln -s dos2unix.1 mac2unix.1
|
||||
|
||||
clean:
|
||||
- rm dos2unix
|
||||
+ rm -f dos2unix mac2unix mac2unix.1 *~ *.orig core
|
||||
|
||||
install:
|
||||
install -m 755 dos2unix /usr/local/bin
|
||||
install -m 644 dos2unix.1 /usr/local/man/man1
|
||||
install -m 755 mac2unix /usr/local/bin
|
||||
install -m 644 mac2unix.1 /usr/local/man/man1
|
||||
-
|
||||
--- dos2unix-3.1/dos2unix.c.orig Thu Nov 19 07:19:25 1998
|
||||
+++ dos2unix-3.1/dos2unix.c Fri Nov 17 13:25:25 2000
|
||||
@@ -267,7 +267,7 @@
|
||||
|
||||
strcpy (TempPath, "./d2utmp");
|
||||
strcat (TempPath, "XXXXXX");
|
||||
- mktemp (TempPath);
|
||||
+ mkstemp (TempPath);
|
||||
|
||||
#ifdef DEBUG
|
||||
fprintf(stderr, "dos2unix: using %s as temp file\n", TempPath);
|
||||
@@ -347,7 +347,7 @@
|
||||
|
||||
strcpy (TempPath, "./u2dtmp");
|
||||
strcat (TempPath, "XXXXXX");
|
||||
- mktemp (TempPath);
|
||||
+ mkstemp (TempPath);
|
||||
|
||||
#ifdef DEBUG
|
||||
fprintf(stderr, "dos2unix: using %s as temp file\n", TempPath);
|
52
dos2unix.spec
Normal file
52
dos2unix.spec
Normal file
@ -0,0 +1,52 @@
|
||||
Summary: Text file format converter
|
||||
Name: dos2unix
|
||||
Version: 3.1
|
||||
Release: 6
|
||||
Group: Applications/Text
|
||||
Copyright: Freely distributable
|
||||
Source: %{name}-%{version}.tar.bz2
|
||||
Patch0: %{name}-%{version}.patch
|
||||
Buildroot: %{_tmppath}/%{name}-root
|
||||
|
||||
%description
|
||||
Dos2unix converts DOS or MAC text files to UNIX format.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .orig
|
||||
|
||||
%build
|
||||
make clean
|
||||
make CFLAGS="$RPM_OPT_FLAGS"
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
|
||||
install -m755 dos2unix $RPM_BUILD_ROOT%{_bindir}
|
||||
install -m444 dos2unix.1 $RPM_BUILD_ROOT%{_mandir}/man1
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,0755)
|
||||
%doc COPYRIGHT
|
||||
%{_bindir}/dos2unix
|
||||
%{_mandir}/*/*
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Wed Jan 10 2001 Bernhard Rosenkraenzer <bero@redhat.com>
|
||||
- shut up rpmlint
|
||||
|
||||
* Fri Nov 17 2000 Tim Powers <timp@redhat.com>
|
||||
- use mkstemp instead of mktemp. Not much needed to change.
|
||||
|
||||
* Thu Nov 16 2000 Tim Powers <timp@redhat.com>
|
||||
- cleaned up specfile a bit
|
||||
- built for 7.1
|
||||
|
||||
* Tue Jul 07 1999 Peter Soos <sp@osb.hu>
|
||||
- Added Hungarian "Summary:" and "%description"
|
||||
- Corrected the file and directory attributes to rebuild the package
|
||||
under RedHat Linux 6.0
|
Loading…
Reference in New Issue
Block a user