dom4j package is retired on c9s for CS-554
This commit is contained in:
parent
08e24322c3
commit
30db08abf5
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,4 +0,0 @@
|
||||
dom4j-1.6.1.tar.gz
|
||||
/dom4j-1.6.1-clean.tar.xz
|
||||
/v2.0.0.tar.gz
|
||||
/dom4j-2.0.0.pom
|
@ -1,22 +0,0 @@
|
||||
diff --git a/src/main/java/org/dom4j/swing/LeafTreeNode.java b/src/main/java/org/dom4j/swing/LeafTreeNode.java
|
||||
index 94706c6..69b5465 100644
|
||||
--- a/src/main/java/org/dom4j/swing/LeafTreeNode.java
|
||||
+++ b/src/main/java/org/dom4j/swing/LeafTreeNode.java
|
||||
@@ -24,7 +24,7 @@ import org.dom4j.Node;
|
||||
* @version $Revision: 1.7 $
|
||||
*/
|
||||
public class LeafTreeNode implements TreeNode {
|
||||
- protected static final Enumeration<?> EMPTY_ENUMERATION = new Enumeration() {
|
||||
+ protected static final Enumeration<? extends TreeNode> EMPTY_ENUMERATION = new Enumeration() {
|
||||
public boolean hasMoreElements() {
|
||||
return false;
|
||||
}
|
||||
@@ -54,7 +54,7 @@ public class LeafTreeNode implements TreeNode {
|
||||
|
||||
// TreeNode methods
|
||||
// -------------------------------------------------------------------------
|
||||
- public Enumeration<?> children() {
|
||||
+ public Enumeration<? extends TreeNode> children() {
|
||||
return EMPTY_ENUMERATION;
|
||||
}
|
||||
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
||||
dom4j package is retired on c9s for CS-554
|
265
dom4j.spec
265
dom4j.spec
@ -1,265 +0,0 @@
|
||||
# Copyright (c) 2000-2007, JPackage Project
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use in source and binary forms, with or without
|
||||
# modification, are permitted provided that the following conditions
|
||||
# are met:
|
||||
#
|
||||
# 1. Redistributions of source code must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
# 2. Redistributions in binary form must reproduce the above copyright
|
||||
# notice, this list of conditions and the following disclaimer in the
|
||||
# documentation and/or other materials provided with the
|
||||
# distribution.
|
||||
# 3. Neither the name of the JPackage Project nor the names of its
|
||||
# contributors may be used to endorse or promote products derived
|
||||
# from this software without specific prior written permission.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
||||
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
||||
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
#
|
||||
|
||||
Name: dom4j
|
||||
Version: 2.0.0
|
||||
Release: 13%{?dist}
|
||||
Epoch: 0
|
||||
Summary: Open Source XML framework for Java
|
||||
License: BSD
|
||||
URL: https://dom4j.github.io/
|
||||
BuildArch: noarch
|
||||
|
||||
Source0: https://github.com/%{name}/%{name}/archive/v%{version}.tar.gz
|
||||
Source1: https://repo1.maven.org/maven2/org/%{name}/%{name}/%{version}/%{name}-%{version}.pom
|
||||
|
||||
Patch0: 00-fix-java11-compilation.patch
|
||||
|
||||
Obsoletes: %{name}-demo < 2.0.0
|
||||
Obsoletes: %{name}-manual < 2.0.0
|
||||
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(jaxen:jaxen)
|
||||
BuildRequires: mvn(net.java.dev.msv:xsdlib)
|
||||
BuildRequires: mvn(xpp3:xpp3)
|
||||
BuildRequires: mvn(javax.xml.bind:jaxb-api)
|
||||
|
||||
# Test deps
|
||||
BuildRequires: mvn(org.testng:testng)
|
||||
BuildRequires: mvn(xerces:xercesImpl)
|
||||
BuildRequires: mvn(xalan:xalan)
|
||||
|
||||
%description
|
||||
dom4j is an Open Source XML framework for Java. dom4j allows you to read,
|
||||
write, navigate, create and modify XML documents. dom4j integrates with
|
||||
DOM and SAX and is seamlessly integrated with full XPath support.
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
|
||||
%description javadoc
|
||||
Javadoc for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%mvn_alias org.%{name}:%{name} %{name}:%{name}
|
||||
%mvn_file : %{name}/%{name} %{name}
|
||||
|
||||
cp %{SOURCE1} pom.xml
|
||||
|
||||
# optional deps missing from pom
|
||||
%pom_add_dep net.java.dev.msv:xsdlib::provided
|
||||
%pom_add_dep xpp3:xpp3::provided
|
||||
%pom_add_dep javax.xml.bind:jaxb-api::provided
|
||||
|
||||
# Remove support for ancient xpp2 (deprecated and not developed since 2003)
|
||||
rm -r src/main/java/org/dom4j/xpp
|
||||
rm src/main/java/org/dom4j/io/XPPReader.java
|
||||
|
||||
# non-deterministic test
|
||||
rm src/test/java/org/dom4j/util/PerThreadSingletonTest.java
|
||||
|
||||
%build
|
||||
%mvn_build -- -Dproject.build.sourceEncoding=UTF-8 -Dmaven.compiler.source=1.8 -Dmaven.compiler.target=1.8
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles
|
||||
%license LICENSE
|
||||
%doc README.md
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license LICENSE
|
||||
|
||||
%changelog
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 0:2.0.0-13
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.0.0-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Fri Jul 24 2020 Fabio Valentini <decathorpe@gmail.com> - 0:2.0.0-11
|
||||
- Add a small patch to fix build with Java 11.
|
||||
|
||||
* Fri Jul 10 2020 Jiri Vanek <jvanek@redhat.com> - 0:2.0.0-10
|
||||
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.0.0-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.0.0-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.0.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Jul 17 2018 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:2.0.0-6
|
||||
- Remove dependency on bea-stax-api
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.0.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.0.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Oct 04 2017 Michael Simacek <msimacek@redhat.com> - 0:2.0.0-3
|
||||
- Explicitly specify source encoding
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Mar 29 2017 Michael Simacek <msimacek@redhat.com> - 0:2.0.0-1
|
||||
- Upgrade to upstream version 2.0.0
|
||||
|
||||
* Wed Mar 22 2017 Michael Simacek <msimacek@redhat.com> - 0:1.6.1-30
|
||||
- Drop support for ancient xpp2
|
||||
|
||||
* Tue Mar 7 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.6.1-29
|
||||
- Don't hardcode package name
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6.1-28
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Jun 15 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.6.1-27
|
||||
- Fix build-dependency on jaxen
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6.1-26
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6.1-25
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Tue Jun 09 2015 Michal Srb <msrb@redhat.com> - 0:1.6.1-24
|
||||
- Add symlink for backward compatibility
|
||||
|
||||
* Mon Jun 08 2015 Michal Srb <msrb@redhat.com> - 0:1.6.1-23
|
||||
- Adapt to current guidelines
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6.1-22
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu May 29 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.6.1-21
|
||||
- Use .mfiles generated during build
|
||||
|
||||
* Fri Dec 06 2013 Michal Srb <msrb@redhat.com> - 0:1.6.1-20
|
||||
- Add ability to disable HTML handling
|
||||
|
||||
* Wed Oct 16 2013 Michal Srb <msrb@redhat.com> - 0:1.6.1-19
|
||||
- Port to JAXP 1.4
|
||||
|
||||
* Wed Aug 07 2013 Michal Srb <msrb@redhat.com> - 0:1.6.1-18
|
||||
- Unversioned doc dir (Resolves: #993729)
|
||||
- See: http://fedoraproject.org/wiki/Changes/UnversionedDocdirs
|
||||
|
||||
* Fri Aug 02 2013 Michal Srb <msrb@redhat.com> - 0:1.6.1-17
|
||||
- Add create-tarball.sh script to SRPM
|
||||
|
||||
* Thu Jul 25 2013 Michal Srb <msrb@redhat.com> - 0:1.6.1-16
|
||||
- Properly remove references to ConcurrentReaderHashMap
|
||||
|
||||
* Tue Jul 02 2013 Michal Srb <msrb@redhat.com> - 0:1.6.1-15
|
||||
- Remove file with unclear licensing (Resolves: rhbz#976180)
|
||||
|
||||
* Wed Jun 19 2013 Michal Srb <msrb@redhat.com> - 0:1.6.1-14
|
||||
- Install license file with javadoc subpackage
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6.1-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Nov 1 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.6.1-12
|
||||
- Add maven POM
|
||||
|
||||
* Mon Oct 29 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.6.1-11
|
||||
- Cleanup source tarball from non-free content
|
||||
- Resolves: rhbz#848875
|
||||
|
||||
* Fri Oct 12 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.6.1-10
|
||||
- Disable test dependencies because tests are skipped
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6.1-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Apr 6 2012 Alexander Kurtakov <akurtako@redhat.com> 0:1.6.1-8
|
||||
- Simplify packaging and remove old things.
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.6.1-3
|
||||
- drop repotag
|
||||
|
||||
* Wed Oct 17 2007 Deepak Bhole <dbhole@redhat.com> 1.6.1-2jpp.3
|
||||
- Resaolve bz#302321: Add copyright header that was accidentally removed.
|
||||
|
||||
* Mon Mar 26 2007 Nuno Santos <nsantos@redhat.com> - 0:1.6.1-2jpp.2
|
||||
- fix unowned directory
|
||||
|
||||
* Wed Feb 14 2007 Jeff Johnston <jjohnstn@redhat.com> - 0:1.6.1-2jpp.1
|
||||
- Resolves: #227049
|
||||
- Updated per Fedora package review process
|
||||
- Modified dom4j-1.6.1-build_xml.patch to include jaxp 1.2 apis on
|
||||
boot classpath
|
||||
- Added new patch for javadocs
|
||||
- Add buildrequires for jaxp = 1.2
|
||||
|
||||
* Mon Jan 30 2006 Ralph Apel <r.apel@r-apel.de> - 0:1.6.1-2jpp
|
||||
- Change STAX dependency to free bea-stax and bea-stax-api
|
||||
|
||||
* Wed Aug 17 2005 Ralph Apel <r.apel@r-apel.de> - 0:1.6.1-1jpp
|
||||
- Upgrade to 1.6.1
|
||||
- Now requires xpp3 additionally to xpp2
|
||||
|
||||
* Thu Sep 09 2004 Ralph Apel <r.apel@r-apel.de> - 0:1.5-1jpp
|
||||
- Upgrade to 1.5
|
||||
- Drop saxpath requirement as this is now included in jaxen
|
||||
|
||||
* Fri Aug 20 2004 Ralph Apel <r.apel@r-apel.de> - 0:1.4-3jpp
|
||||
- Upgrade to Ant 1.6.X
|
||||
- Build with ant-1.6.2
|
||||
|
||||
* Tue Jul 06 2004 Ralph Apel <r.apel@r-apel.de> - 0:1.4-2jpp
|
||||
- Replace non-free msv with free relaxngDatatype xsdlib isorelax msv-strict
|
||||
- Relax some versioned dependencies
|
||||
|
||||
* Mon Jan 19 2004 Ralph Apel <r.apel@r-apel.de> - 0:1.4-1jpp
|
||||
- First JPackage release
|
2
sources
2
sources
@ -1,2 +0,0 @@
|
||||
SHA512 (v2.0.0.tar.gz) = 740ddf617cde6dac448e11120906c0e59cd01484b41fd0c7e1379944289857b3481b37262abdb289cb01b949662605aa5d516ab031219dd2fb45d465da2cd2a9
|
||||
SHA512 (dom4j-2.0.0.pom) = ebb1a6d54d4425347ccf57fb90491cfdd00b887476d7c16e647aec5a8ef351d0301a291048fdd2bdfc59b9ccd71e3eea81d45a1a85358605df437cdb8c2b4c2c
|
Loading…
Reference in New Issue
Block a user