Update to 2.68rc3
Signed-off-by: Tomas Hozza <thozza@redhat.com>
This commit is contained in:
parent
ad9a1ef487
commit
fad2ab1eb0
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@ dnsmasq-2.52.tar.lzma
|
|||||||
/dnsmasq-2.67rc2.tar.xz
|
/dnsmasq-2.67rc2.tar.xz
|
||||||
/dnsmasq-2.67rc4.tar.xz
|
/dnsmasq-2.67rc4.tar.xz
|
||||||
/dnsmasq-2.67.tar.xz
|
/dnsmasq-2.67.tar.xz
|
||||||
|
/dnsmasq-2.68rc3.tar.xz
|
||||||
|
41
dnsmasq-2.68-Add-missing-malloc-return-code-check.patch
Normal file
41
dnsmasq-2.68-Add-missing-malloc-return-code-check.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
From 532066ee2d7a4addd0af1a5f4ac0b8c3b5ad73cf Mon Sep 17 00:00:00 2001
|
||||||
|
From: Simon Kelley <simon@thekelleys.org.uk>
|
||||||
|
Date: Tue, 26 Nov 2013 10:14:47 +0000
|
||||||
|
Subject: [PATCH] Add missing malloc() return-code check.
|
||||||
|
|
||||||
|
Signed-off-by: Tomas Hozza <thozza@redhat.com>
|
||||||
|
---
|
||||||
|
src/cache.c | 16 ++++++++--------
|
||||||
|
1 file changed, 8 insertions(+), 8 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/cache.c b/src/cache.c
|
||||||
|
index 582b882..43a7ce9 100644
|
||||||
|
--- a/src/cache.c
|
||||||
|
+++ b/src/cache.c
|
||||||
|
@@ -945,15 +945,15 @@ void cache_reload(void)
|
||||||
|
/* Add CNAMEs to interface_names to the cache */
|
||||||
|
for (a = daemon->cnames; a; a = a->next)
|
||||||
|
for (intr = daemon->int_names; intr; intr = intr->next)
|
||||||
|
- if (hostname_isequal(a->target, intr->name))
|
||||||
|
+ if (hostname_isequal(a->target, intr->name) &&
|
||||||
|
+ ((cache = whine_malloc(sizeof(struct crec)))))
|
||||||
|
{
|
||||||
|
- struct crec *aliasc = whine_malloc(sizeof(struct crec));
|
||||||
|
- aliasc->flags = F_FORWARD | F_NAMEP | F_CNAME | F_IMMORTAL | F_CONFIG;
|
||||||
|
- aliasc->name.namep = a->alias;
|
||||||
|
- aliasc->addr.cname.target.int_name = intr;
|
||||||
|
- aliasc->addr.cname.uid = -1;
|
||||||
|
- cache_hash(aliasc);
|
||||||
|
- add_hosts_cname(aliasc); /* handle chains */
|
||||||
|
+ cache->flags = F_FORWARD | F_NAMEP | F_CNAME | F_IMMORTAL | F_CONFIG;
|
||||||
|
+ cache->name.namep = a->alias;
|
||||||
|
+ cache->addr.cname.target.int_name = intr;
|
||||||
|
+ cache->addr.cname.uid = -1;
|
||||||
|
+ cache_hash(cache);
|
||||||
|
+ add_hosts_cname(cache); /* handle chains */
|
||||||
|
}
|
||||||
|
|
||||||
|
/* borrow the packet buffer for a temporary by-address hash */
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
15
dnsmasq.spec
15
dnsmasq.spec
@ -1,19 +1,19 @@
|
|||||||
%define testrelease 0
|
%define testrelease 0
|
||||||
%define releasecandidate 0
|
%define releasecandidate 1
|
||||||
%if 0%{testrelease}
|
%if 0%{testrelease}
|
||||||
%define extrapath test-releases/
|
%define extrapath test-releases/
|
||||||
%define extraversion test16
|
%define extraversion test16
|
||||||
%endif
|
%endif
|
||||||
%if 0%{releasecandidate}
|
%if 0%{releasecandidate}
|
||||||
%define extrapath release-candidates/
|
%define extrapath release-candidates/
|
||||||
%define extraversion rc4
|
%define extraversion rc3
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define _hardened_build 1
|
%define _hardened_build 1
|
||||||
|
|
||||||
Name: dnsmasq
|
Name: dnsmasq
|
||||||
Version: 2.67
|
Version: 2.68
|
||||||
Release: 1%{?extraversion}%{?dist}
|
Release: 0.1.%{?extraversion}%{?dist}
|
||||||
Summary: A lightweight DHCP/caching DNS server
|
Summary: A lightweight DHCP/caching DNS server
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -23,7 +23,7 @@ Source0: http://www.thekelleys.org.uk/dnsmasq/%{?extrapath}%{name}-%{vers
|
|||||||
Source1: %{name}.service
|
Source1: %{name}.service
|
||||||
|
|
||||||
# Patches
|
# Patches
|
||||||
Patch0: %{name}-2.67-Fix-check-for-local-domains-in-CNAME-case.patch
|
Patch0: %{name}-2.68-Add-missing-malloc-return-code-check.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -58,7 +58,7 @@ query/remove a DHCP server's leases.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?extraversion}
|
%setup -q -n %{name}-%{version}%{?extraversion}
|
||||||
%patch0 -p1 -b .cname
|
%patch0 -p1
|
||||||
|
|
||||||
# use /var/lib/dnsmasq instead of /var/lib/misc
|
# use /var/lib/dnsmasq instead of /var/lib/misc
|
||||||
for file in dnsmasq.conf.example man/dnsmasq.8 man/es/dnsmasq.8 src/config.h; do
|
for file in dnsmasq.conf.example man/dnsmasq.8 man/es/dnsmasq.8 src/config.h; do
|
||||||
@ -139,6 +139,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/dhcp_*
|
%{_mandir}/man1/dhcp_*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 26 2013 Tomas Hozza <thozza@redhat.com> - 2.68-0.1.rc3
|
||||||
|
- Update to 2.68rc3
|
||||||
|
|
||||||
* Fri Nov 01 2013 Tomas Hozza <thozza@redhat.com> - 2.67-1
|
* Fri Nov 01 2013 Tomas Hozza <thozza@redhat.com> - 2.67-1
|
||||||
- Update to 2.67 stable
|
- Update to 2.67 stable
|
||||||
- Include one post release upstream fix for CNAME
|
- Include one post release upstream fix for CNAME
|
||||||
|
Loading…
Reference in New Issue
Block a user