auto-import dnsmasq-2.30-2 on branch devel from dnsmasq-2.30-2.src.rpm
This commit is contained in:
parent
a2c38759e4
commit
b0365fbe30
@ -0,0 +1 @@
|
|||||||
|
dnsmasq-2.30.tar.gz
|
26
dnsmasq-2.30-fedora-extras.patch
Normal file
26
dnsmasq-2.30-fedora-extras.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
diff -urN dnsmasq-2.30/rpm/dnsmasq.rh dnsmasq-2.30-patched/rpm/dnsmasq.rh
|
||||||
|
--- dnsmasq-2.30/rpm/dnsmasq.rh 2006-04-23 08:26:21.000000000 -0500
|
||||||
|
+++ dnsmasq-2.30-patched/rpm/dnsmasq.rh 2006-04-24 15:06:01.000000000 -0500
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
#
|
||||||
|
# Startup script for the DNS caching server
|
||||||
|
#
|
||||||
|
-# chkconfig: 2345 99 01
|
||||||
|
+# chkconfig: - 99 01
|
||||||
|
# description: This script starts your DNS caching server
|
||||||
|
# processname: dnsmasq
|
||||||
|
# pidfile: /var/run/dnsmasq.pid
|
||||||
|
diff -urN dnsmasq-2.30/src/config.h dnsmasq-2.30-patched/src/config.h
|
||||||
|
--- dnsmasq-2.30/src/config.h 2006-04-23 13:27:20.000000000 -0500
|
||||||
|
+++ dnsmasq-2.30-patched/src/config.h 2006-04-24 15:04:28.000000000 -0500
|
||||||
|
@@ -167,8 +167,8 @@
|
||||||
|
|
||||||
|
/* platform independent options- uncomment to enable */
|
||||||
|
/* #define HAVE_BROKEN_RTC */
|
||||||
|
-/* #define HAVE_ISC_READER */
|
||||||
|
-/* #define HAVE_DBUS */
|
||||||
|
+#define HAVE_ISC_READER
|
||||||
|
+#define HAVE_DBUS
|
||||||
|
|
||||||
|
#if defined(HAVE_BROKEN_RTC) && defined(HAVE_ISC_READER)
|
||||||
|
# error HAVE_ISC_READER is not compatible with HAVE_BROKEN_RTC
|
83
dnsmasq.spec
Normal file
83
dnsmasq.spec
Normal file
@ -0,0 +1,83 @@
|
|||||||
|
Name: dnsmasq
|
||||||
|
Version: 2.30
|
||||||
|
Release: 2%{?dist}
|
||||||
|
Summary: A lightweight DHCP/caching DNS server
|
||||||
|
|
||||||
|
Group: System Environment/Daemons
|
||||||
|
License: GPL
|
||||||
|
URL: http://www.thekelleys.org.uk/dnsmasq/
|
||||||
|
Source0: http://www.thekelleys.org.uk/dnsmasq/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: http://beer.tclug.org/fedora-extras/dnsmasq/%{name}-%{version}-fedora-extras.patch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
BuildRequires: dbus-devel
|
||||||
|
|
||||||
|
Requires(post): /sbin/chkconfig
|
||||||
|
Requires(post): /sbin/service
|
||||||
|
Requires(preun): /sbin/chkconfig
|
||||||
|
Requires(preun): /sbin/service
|
||||||
|
|
||||||
|
%description
|
||||||
|
Dnsmasq is lightweight, easy to configure DNS forwarder and DHCP server.
|
||||||
|
It is designed to provide DNS and, optionally, DHCP, to a small network.
|
||||||
|
It can serve the names of local machines which are not in the global
|
||||||
|
DNS. The DHCP server integrates with the DNS server and allows machines
|
||||||
|
with DHCP-allocated addresses to appear in the DNS with names configured
|
||||||
|
either in each host or in a central configuration file. Dnsmasq supports
|
||||||
|
static and dynamic DHCP leases and BOOTP for network booting of diskless
|
||||||
|
machines.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
# normally i'd do 'make install'...it's a bit messy, though
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_sbindir} $RPM_BUILD_ROOT%{_initrddir} \
|
||||||
|
$RPM_BUILD_ROOT%{_mandir}/man8
|
||||||
|
install src/dnsmasq $RPM_BUILD_ROOT%{_sbindir}/dnsmasq
|
||||||
|
install dnsmasq.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/dnsmasq.conf
|
||||||
|
install rpm/dnsmasq.rh $RPM_BUILD_ROOT%{_initrddir}/dnsmasq
|
||||||
|
install man/dnsmasq.8 $RPM_BUILD_ROOT%{_mandir}/man8/
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
%post
|
||||||
|
/sbin/chkconfig --add dnsmasq
|
||||||
|
|
||||||
|
%preun
|
||||||
|
if [ $1 = 0 ]; then # execute this only if we are NOT doing an upgrade
|
||||||
|
service dnsmasq stop >/dev/null 2>&1
|
||||||
|
/sbin/chkconfig --del dnsmasq
|
||||||
|
fi
|
||||||
|
|
||||||
|
%postun
|
||||||
|
if [ "$1" -ge "1" ]; then
|
||||||
|
service dnsmasq restart >/dev/null 2>&1
|
||||||
|
fi
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%doc CHANGELOG COPYING FAQ doc.html setup.html UPGRADING_to_2.0
|
||||||
|
%config(noreplace) %attr(664,root,root) %{_sysconfdir}/dnsmasq.conf
|
||||||
|
%{_initrddir}/dnsmasq
|
||||||
|
%{_sbindir}/dnsmasq
|
||||||
|
%{_mandir}/man8/dnsmasq*
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Apr 24 2006 Patrick Laughton <jima@auroralinux.org> 2.30-2
|
||||||
|
- Disabled stripping of binary while installing (oops)
|
||||||
|
- Enabled HAVE_ISC_READER/HAVE_DBUS via patch
|
||||||
|
- Added BuildReq for dbus-devel
|
||||||
|
|
||||||
|
* Mon Apr 24 2006 Patrick Laughton <jima@auroralinux.org> 2.30-1
|
||||||
|
- Initial Fedora Extras RPM
|
Loading…
Reference in New Issue
Block a user