Update to 2.67 stable
- Include one post release upstream fix for CNAME Signed-off-by: Tomas Hozza <thozza@redhat.com>
This commit is contained in:
parent
c43d685d66
commit
ad9a1ef487
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@ dnsmasq-2.52.tar.lzma
|
||||
/dnsmasq-2.67test16.tar.xz
|
||||
/dnsmasq-2.67rc2.tar.xz
|
||||
/dnsmasq-2.67rc4.tar.xz
|
||||
/dnsmasq-2.67.tar.xz
|
||||
|
49
dnsmasq-2.67-Fix-check-for-local-domains-in-CNAME-case.patch
Normal file
49
dnsmasq-2.67-Fix-check-for-local-domains-in-CNAME-case.patch
Normal file
@ -0,0 +1,49 @@
|
||||
From 7b174c250df2bc97b503fd03b9e473998676b1a6 Mon Sep 17 00:00:00 2001
|
||||
From: Simon Kelley <simon@thekelleys.org.uk>
|
||||
Date: Mon, 28 Oct 2013 13:14:03 +0000
|
||||
Subject: [PATCH] Fix check for local domains in CNAME case. Fixes
|
||||
d56a604a9600c08d4a863527d549713c07f0186d
|
||||
|
||||
---
|
||||
src/cache.c | 2 +-
|
||||
src/rfc1035.c | 4 ++--
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/cache.c b/src/cache.c
|
||||
index d99aba6..6c5f601 100644
|
||||
--- a/src/cache.c
|
||||
+++ b/src/cache.c
|
||||
@@ -330,7 +330,7 @@ static int cache_scan_free(char *name, struct all_addr *addr, time_t now, unsign
|
||||
((flags & crecp->flags & F_TYPE) || ((crecp->flags | flags) & F_CNAME)) &&
|
||||
hostname_isequal(cache_get_name(crecp), name))
|
||||
{
|
||||
- if (crecp->flags & (F_HOSTS | F_DHCP))
|
||||
+ if (crecp->flags & (F_HOSTS | F_DHCP | F_CONFIG))
|
||||
return 0;
|
||||
*up = crecp->hash_next;
|
||||
cache_unlink(crecp);
|
||||
diff --git a/src/rfc1035.c b/src/rfc1035.c
|
||||
index fc6d09c..ff97576 100644
|
||||
--- a/src/rfc1035.c
|
||||
+++ b/src/rfc1035.c
|
||||
@@ -1221,7 +1221,7 @@ int check_for_local_domain(char *name, time_t now)
|
||||
struct naptr *naptr;
|
||||
|
||||
if ((crecp = cache_find_by_name(NULL, name, now, F_IPV4 | F_IPV6 | F_CNAME)) &&
|
||||
- (crecp->flags & (F_HOSTS | F_DHCP)))
|
||||
+ (crecp->flags & (F_HOSTS | F_DHCP | F_CONFIG)))
|
||||
return 1;
|
||||
|
||||
for (naptr = daemon->naptr; naptr; naptr = naptr->next)
|
||||
@@ -1861,7 +1861,7 @@ size_t answer_request(struct dns_header *header, char *limit, size_t qlen,
|
||||
if (qtype == T_CNAME || qtype == T_ANY)
|
||||
{
|
||||
if ((crecp = cache_find_by_name(NULL, name, now, F_CNAME)) &&
|
||||
- (qtype == T_CNAME || (crecp->flags & (F_HOSTS | F_DHCP))))
|
||||
+ (qtype == T_CNAME || (crecp->flags & (F_HOSTS | F_DHCP | F_CONFIG))))
|
||||
{
|
||||
ans = 1;
|
||||
if (!dryrun)
|
||||
--
|
||||
1.8.3.1
|
||||
|
10
dnsmasq.spec
10
dnsmasq.spec
@ -1,5 +1,5 @@
|
||||
%define testrelease 0
|
||||
%define releasecandidate 1
|
||||
%define releasecandidate 0
|
||||
%if 0%{testrelease}
|
||||
%define extrapath test-releases/
|
||||
%define extraversion test16
|
||||
@ -13,7 +13,7 @@
|
||||
|
||||
Name: dnsmasq
|
||||
Version: 2.67
|
||||
Release: 0.9.%{?extraversion}%{?dist}
|
||||
Release: 1%{?extraversion}%{?dist}
|
||||
Summary: A lightweight DHCP/caching DNS server
|
||||
|
||||
Group: System Environment/Daemons
|
||||
@ -23,6 +23,7 @@ Source0: http://www.thekelleys.org.uk/dnsmasq/%{?extrapath}%{name}-%{vers
|
||||
Source1: %{name}.service
|
||||
|
||||
# Patches
|
||||
Patch0: %{name}-2.67-Fix-check-for-local-domains-in-CNAME-case.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -57,6 +58,7 @@ query/remove a DHCP server's leases.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?extraversion}
|
||||
%patch0 -p1 -b .cname
|
||||
|
||||
# use /var/lib/dnsmasq instead of /var/lib/misc
|
||||
for file in dnsmasq.conf.example man/dnsmasq.8 man/es/dnsmasq.8 src/config.h; do
|
||||
@ -137,6 +139,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man1/dhcp_*
|
||||
|
||||
%changelog
|
||||
* Fri Nov 01 2013 Tomas Hozza <thozza@redhat.com> - 2.67-1
|
||||
- Update to 2.67 stable
|
||||
- Include one post release upstream fix for CNAME
|
||||
|
||||
* Fri Oct 18 2013 Tomas Hozza <thozza@redhat.com> - 2.67-0.9.rc4
|
||||
- update to 2.67rc4
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user