Update to 2.88 (#2150667)
Still keeping underflow patch, even it seems not necessary. https://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2022q4/016767.html
This commit is contained in:
parent
a2d26dd525
commit
773d89e137
2
.gitignore
vendored
2
.gitignore
vendored
@ -46,3 +46,5 @@ dnsmasq-2.52.tar.lzma
|
||||
/dnsmasq-2.86.tar.xz.asc
|
||||
/dnsmasq-2.87.tar.xz
|
||||
/dnsmasq-2.87.tar.xz.asc
|
||||
/dnsmasq-2.88.tar.xz
|
||||
/dnsmasq-2.88.tar.xz.asc
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 46b9670a418419d9e04bbe9a0d6c5a85f3c63265 Mon Sep 17 00:00:00 2001
|
||||
From 0e581ae7b2d3b181f22f71d5a0b7ace0bf90089f Mon Sep 17 00:00:00 2001
|
||||
From: Doran Moppert <dmoppert@redhat.com>
|
||||
Date: Tue, 26 Sep 2017 14:48:20 +0930
|
||||
Subject: [PATCH] google patch hand-applied
|
||||
@ -30,19 +30,19 @@ index c498eb1..0eb3873 100644
|
||||
free(buff);
|
||||
p += rdlen;
|
||||
diff --git a/src/rfc1035.c b/src/rfc1035.c
|
||||
index 60ef272..93701f6 100644
|
||||
index 5c0df56..7e01459 100644
|
||||
--- a/src/rfc1035.c
|
||||
+++ b/src/rfc1035.c
|
||||
@@ -1411,6 +1411,9 @@ size_t answer_request(struct dns_header *header, char *limit, size_t qlen,
|
||||
@@ -1425,6 +1425,9 @@ size_t answer_request(struct dns_header *header, char *limit, size_t qlen,
|
||||
size_t len;
|
||||
int rd_bit = (header->hb3 & HB3_RD);
|
||||
|
||||
+ // Make sure we do not underflow here too.
|
||||
+ if (qlen > (limit - ((char *)header))) return 0;
|
||||
+
|
||||
/* never answer queries with RD unset, to avoid cache snooping. */
|
||||
if (ntohs(header->ancount) != 0 ||
|
||||
ntohs(header->nscount) != 0 ||
|
||||
--
|
||||
2.37.3
|
||||
if (stale)
|
||||
*stale = 0;
|
||||
|
||||
--
|
||||
2.38.1
|
||||
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 930428fb970f4991e5c2933fd5a5d2504c18a551 Mon Sep 17 00:00:00 2001
|
||||
From: Simon Kelley <simon@thekelleys.org.uk>
|
||||
Date: Mon, 17 Oct 2022 21:15:43 +0100
|
||||
Subject: [PATCH] Fix loss of DNS servers on config reload.
|
||||
|
||||
A bug, introduced in 2.87, which could result in DNS
|
||||
servers being removed from the configuration when reloading
|
||||
server configuration from DBus, or re-reading /etc/resolv.conf
|
||||
Only servers from the same source should be replaced, but some
|
||||
servers from other sources (ie hard coded or another dynamic source)
|
||||
could mysteriously disappear.
|
||||
---
|
||||
src/domain-match.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/domain-match.c b/src/domain-match.c
|
||||
index f7db0fe..76a1109 100644
|
||||
--- a/src/domain-match.c
|
||||
+++ b/src/domain-match.c
|
||||
@@ -683,7 +683,9 @@ int add_update_server(int flags,
|
||||
serv->next = NULL;
|
||||
}
|
||||
break;
|
||||
- }
|
||||
+ }
|
||||
+ else
|
||||
+ up = &serv->next;
|
||||
}
|
||||
|
||||
if (serv)
|
||||
--
|
||||
2.38.1
|
||||
|
15
dnsmasq.spec
15
dnsmasq.spec
@ -19,8 +19,8 @@
|
||||
%bcond_with sourcegit
|
||||
|
||||
Name: dnsmasq
|
||||
Version: 2.87
|
||||
Release: 3%{?extraversion:.%{extraversion}}%{?dist}
|
||||
Version: 2.88
|
||||
Release: 1%{?extraversion:.%{extraversion}}%{?dist}
|
||||
Summary: A lightweight DHCP/caching DNS server
|
||||
|
||||
License: GPL-2.0-only or GPL-3.0-only
|
||||
@ -41,14 +41,6 @@ Patch1: dnsmasq-2.77-underflow.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1852373
|
||||
Patch2: dnsmasq-2.81-configuration.patch
|
||||
Patch3: dnsmasq-2.78-fips.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2148301
|
||||
# https://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=930428fb970f4991e5c2933fd5a5d2504c18a551
|
||||
Patch4: dnsmasq-2.87-dbus-file-reload.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2009975
|
||||
# replaces/enhances http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=d290630d31f4517ab26392d00753d1397f9a4114
|
||||
#Patch26: dnsmasq-2.86-build_server_array.patch
|
||||
|
||||
|
||||
|
||||
Requires: nettle
|
||||
@ -190,6 +182,9 @@ install -Dpm 644 %{SOURCE2} %{buildroot}%{_sysusersdir}/%{name}.conf
|
||||
%{_mandir}/man1/dhcp_*
|
||||
|
||||
%changelog
|
||||
* Tue Dec 06 2022 Petr Menšík <pemensik@redhat.com> - 2.88-1
|
||||
- Update to 2.88 (#2150667)
|
||||
|
||||
* Fri Nov 25 2022 Petr Menšík <pemensik@redhat.com> - 2.87-3
|
||||
- Fix regression removing config statements on DBus change (#2148301)
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (dnsmasq-2.87.tar.xz) = 965071ff35aed558a661e7f57ff82de170f4ad7fcdd6a4070ce7915c9f5e41450d8d86b2a0c2c30bf52ddc3aaeb22af18bb6da71a1cccb3c409429ef0ef308f3
|
||||
SHA512 (dnsmasq-2.87.tar.xz.asc) = 539abb6c5ad50c2e3eaa534dde63be4003b4ed96d471ba9d96fed028d5ddf76111591626de6def823438731c363383282a75139346304f2819aef64a0943a300
|
||||
SHA512 (dnsmasq-2.88.tar.xz) = 109ee4513cb25fb0c9ff6f81d696c195a24ffa013847fdc3a507757137fff098248e2b907a87695075405039c4dc0eda40803395a52306ce673ca593cc4f4e00
|
||||
SHA512 (dnsmasq-2.88.tar.xz.asc) = 64b12010139b224db879eb007550ddc0ce8152c98aaa9f3a8063b757c49478473d6ff10a6053913400f7eedefceb4fa38e83b8b6f1e3ebe36c78b00e490bd951
|
||||
|
Loading…
Reference in New Issue
Block a user