Upgrade to 2.31
This commit is contained in:
parent
5275092fa0
commit
60068e4691
@ -1,20 +0,0 @@
|
|||||||
diff -urN dnsmasq-2.30/dbus/dnsmasq.conf dnsmasq-2.30-patched/dbus/dnsmasq.conf
|
|
||||||
--- dnsmasq-2.30/dbus/dnsmasq.conf 1969-12-31 18:00:00.000000000 -0600
|
|
||||||
+++ dnsmasq-2.30-patched/dbus/dnsmasq.conf 2006-05-02 09:52:56.000000000 -0500
|
|
||||||
@@ -0,0 +1,16 @@
|
|
||||||
+<!DOCTYPE busconfig PUBLIC
|
|
||||||
+ "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
|
|
||||||
+ "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
|
|
||||||
+<busconfig>
|
|
||||||
+ <policy user="root">
|
|
||||||
+ <allow own="uk.org.thekelleys.dnsmasq"/>
|
|
||||||
+ <allow send_destination="uk.org.thekelleys.dnsmasq"/>
|
|
||||||
+ <allow send_interface="uk.org.thekelleys.dnsmasq"/>
|
|
||||||
+ </policy>
|
|
||||||
+ <policy context="default">
|
|
||||||
+ <deny own="uk.org.thekelleys.dnsmasq"/>
|
|
||||||
+ <deny send_destination="uk.org.thekelleys.dnsmasq"/>
|
|
||||||
+ <deny send_interface="uk.org.thekelleys.dnsmasq"/>
|
|
||||||
+ </policy>
|
|
||||||
+</busconfig>
|
|
||||||
+
|
|
@ -1,62 +0,0 @@
|
|||||||
diff -urN dnsmasq-2.30/rpm/dnsmasq.rh dnsmasq-2.30-patched/rpm/dnsmasq.rh
|
|
||||||
--- dnsmasq-2.30/rpm/dnsmasq.rh 2006-04-23 08:26:21.000000000 -0500
|
|
||||||
+++ dnsmasq-2.30-patched/rpm/dnsmasq.rh 2006-05-02 11:07:16.000000000 -0500
|
|
||||||
@@ -2,7 +2,7 @@
|
|
||||||
#
|
|
||||||
# Startup script for the DNS caching server
|
|
||||||
#
|
|
||||||
-# chkconfig: 2345 99 01
|
|
||||||
+# chkconfig: - 99 01
|
|
||||||
# description: This script starts your DNS caching server
|
|
||||||
# processname: dnsmasq
|
|
||||||
# pidfile: /var/run/dnsmasq.pid
|
|
||||||
@@ -19,33 +19,9 @@
|
|
||||||
dnsmasq=/usr/sbin/dnsmasq
|
|
||||||
[ -f $dnsmasq ] || exit 0
|
|
||||||
|
|
||||||
-# change this line if you want dnsmasq to serve an MX record for
|
|
||||||
-# the host it is running on.
|
|
||||||
-MAILHOSTNAME=""
|
|
||||||
-# change this line if you want dns to get its upstream servers from
|
|
||||||
-# somewhere other that /etc/resolv.conf
|
|
||||||
-RESOLV_CONF=""
|
|
||||||
-# change this if you want dnsmasq to cache any "hostname" or "client-hostname" from
|
|
||||||
-# a dhcpd's lease file
|
|
||||||
-DHCP_LEASE="/var/lib/dhcp/dhcpd.leases"
|
|
||||||
DOMAIN_SUFFIX=`dnsdomainname`
|
|
||||||
-
|
|
||||||
-OPTIONS=""
|
|
||||||
-
|
|
||||||
-if [ ! -z "${MAILHOSTNAME}" ]; then
|
|
||||||
- OPTIONS="$OPTIONS -m $MAILHOSTNAME"
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
-if [ ! -z "${RESOLV_CONF}" ]; then
|
|
||||||
- OPTIONS="$OPTIONS -r $RESOLV_CONF"
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
-if [ ! -z "${DHCP_LEASE}" ]; then
|
|
||||||
- OPTIONS="$OPTIONS -l $DHCP_LEASE"
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
if [ ! -z "${DOMAIN_SUFFIX}" ]; then
|
|
||||||
- OPTIONS="$OPTIONS -s $DOMAIN_SUFFIX"
|
|
||||||
+ OPTIONS="-s $DOMAIN_SUFFIX"
|
|
||||||
fi
|
|
||||||
|
|
||||||
RETVAL=0
|
|
||||||
@@ -72,7 +48,13 @@
|
|
||||||
status dnsmasq
|
|
||||||
RETVAL=$?
|
|
||||||
;;
|
|
||||||
- restart|reload)
|
|
||||||
+ reload)
|
|
||||||
+ echo -n "Reloading dnsmasq: "
|
|
||||||
+ killproc dnsmasq -HUP
|
|
||||||
+ RETVAL=$?
|
|
||||||
+ echo
|
|
||||||
+ ;;
|
|
||||||
+ restart)
|
|
||||||
$0 stop
|
|
||||||
$0 start
|
|
||||||
RETVAL=$?
|
|
@ -1,7 +1,7 @@
|
|||||||
diff -urN dnsmasq-2.30/src/config.h dnsmasq-2.30-patched/src/config.h
|
diff -urN dnsmasq-2.31/src/config.h dnsmasq-2.31-patched/src/config.h
|
||||||
--- dnsmasq-2.30/src/config.h 2006-04-23 13:27:20.000000000 -0500
|
--- dnsmasq-2.31/src/config.h 2006-05-06 06:18:25.000000000 -0500
|
||||||
+++ dnsmasq-2.30-patched/src/config.h 2006-04-26 13:43:54.000000000 -0500
|
+++ dnsmasq-2.31-patched/src/config.h 2006-05-08 07:26:04.000000000 -0500
|
||||||
@@ -168,7 +168,7 @@
|
@@ -169,7 +169,7 @@
|
||||||
/* platform independent options- uncomment to enable */
|
/* platform independent options- uncomment to enable */
|
||||||
/* #define HAVE_BROKEN_RTC */
|
/* #define HAVE_BROKEN_RTC */
|
||||||
/* #define HAVE_ISC_READER */
|
/* #define HAVE_ISC_READER */
|
79
dnsmasq-2.31-initscript.patch
Normal file
79
dnsmasq-2.31-initscript.patch
Normal file
@ -0,0 +1,79 @@
|
|||||||
|
diff -urN dnsmasq-2.31/rpm/dnsmasq.init dnsmasq-2.31-patched/rpm/dnsmasq.init
|
||||||
|
--- dnsmasq-2.31/rpm/dnsmasq.init 1969-12-31 18:00:00.000000000 -0600
|
||||||
|
+++ dnsmasq-2.31-patched/rpm/dnsmasq.init 2006-05-08 07:30:11.000000000 -0500
|
||||||
|
@@ -0,0 +1,75 @@
|
||||||
|
+#!/bin/sh
|
||||||
|
+#
|
||||||
|
+# Startup script for the DNS caching server
|
||||||
|
+#
|
||||||
|
+# chkconfig: - 99 01
|
||||||
|
+# description: This script starts your DNS caching server
|
||||||
|
+# processname: dnsmasq
|
||||||
|
+# pidfile: /var/run/dnsmasq.pid
|
||||||
|
+
|
||||||
|
+# Source function library.
|
||||||
|
+. /etc/rc.d/init.d/functions
|
||||||
|
+
|
||||||
|
+# Source networking configuration.
|
||||||
|
+. /etc/sysconfig/network
|
||||||
|
+
|
||||||
|
+# Check that networking is up.
|
||||||
|
+[ ${NETWORKING} = "no" ] && exit 0
|
||||||
|
+
|
||||||
|
+dnsmasq=/usr/sbin/dnsmasq
|
||||||
|
+[ -f $dnsmasq ] || exit 0
|
||||||
|
+
|
||||||
|
+DOMAIN_SUFFIX=`dnsdomainname`
|
||||||
|
+if [ ! -z "${DOMAIN_SUFFIX}" ]; then
|
||||||
|
+ OPTIONS="-s $DOMAIN_SUFFIX"
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+RETVAL=0
|
||||||
|
+
|
||||||
|
+# See how we were called.
|
||||||
|
+case "$1" in
|
||||||
|
+ start)
|
||||||
|
+ echo -n "Starting dnsmasq: "
|
||||||
|
+ daemon $dnsmasq $OPTIONS
|
||||||
|
+ RETVAL=$?
|
||||||
|
+ echo
|
||||||
|
+ [ $RETVAL -eq 0 ] && touch /var/lock/subsys/dnsmasq
|
||||||
|
+ ;;
|
||||||
|
+ stop)
|
||||||
|
+ if test "x`pidof dnsmasq`" != x; then
|
||||||
|
+ echo -n "Shutting down dnsmasq: "
|
||||||
|
+ killproc dnsmasq
|
||||||
|
+ fi
|
||||||
|
+ RETVAL=$?
|
||||||
|
+ echo
|
||||||
|
+ [ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/dnsmasq /var/run/dnsmasq.pid
|
||||||
|
+ ;;
|
||||||
|
+ status)
|
||||||
|
+ status dnsmasq
|
||||||
|
+ RETVAL=$?
|
||||||
|
+ ;;
|
||||||
|
+ reload)
|
||||||
|
+ echo -n "Reloading dnsmasq: "
|
||||||
|
+ killproc dnsmasq -HUP
|
||||||
|
+ RETVAL=$?
|
||||||
|
+ echo
|
||||||
|
+ ;;
|
||||||
|
+ restart)
|
||||||
|
+ $0 stop
|
||||||
|
+ $0 start
|
||||||
|
+ RETVAL=$?
|
||||||
|
+ ;;
|
||||||
|
+ condrestart)
|
||||||
|
+ if test "x`/sbin/pidof dnsmasq`" != x; then
|
||||||
|
+ $0 stop
|
||||||
|
+ $0 start
|
||||||
|
+ RETVAL=$?
|
||||||
|
+ fi
|
||||||
|
+ ;;
|
||||||
|
+ *)
|
||||||
|
+ echo "Usage: $0 {start|stop|restart|reload|condrestart|status}"
|
||||||
|
+ exit 1
|
||||||
|
+esac
|
||||||
|
+
|
||||||
|
+exit $RETVAL
|
||||||
|
+
|
19
dnsmasq.spec
19
dnsmasq.spec
@ -1,6 +1,6 @@
|
|||||||
Name: dnsmasq
|
Name: dnsmasq
|
||||||
Version: 2.30
|
Version: 2.31
|
||||||
Release: 4.2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A lightweight DHCP/caching DNS server
|
Summary: A lightweight DHCP/caching DNS server
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -9,7 +9,6 @@ URL: http://www.thekelleys.org.uk/dnsmasq/
|
|||||||
Source0: http://www.thekelleys.org.uk/dnsmasq/%{name}-%{version}.tar.gz
|
Source0: http://www.thekelleys.org.uk/dnsmasq/%{name}-%{version}.tar.gz
|
||||||
Patch0: http://beer.tclug.org/fedora-extras/dnsmasq/%{name}-%{version}-initscript.patch
|
Patch0: http://beer.tclug.org/fedora-extras/dnsmasq/%{name}-%{version}-initscript.patch
|
||||||
Patch1: http://beer.tclug.org/fedora-extras/dnsmasq/%{name}-%{version}-enable-dbus.patch
|
Patch1: http://beer.tclug.org/fedora-extras/dnsmasq/%{name}-%{version}-enable-dbus.patch
|
||||||
Patch2: http://beer.tclug.org/fedora-extras/dnsmasq/%{name}-%{version}-dbus-config.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
%if "%{dist}" != ".fc3"
|
%if "%{dist}" != ".fc3"
|
||||||
@ -37,7 +36,6 @@ machines.
|
|||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%if "%{dist}" != ".fc3"
|
%if "%{dist}" != ".fc3"
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -53,8 +51,10 @@ mkdir -p $RPM_BUILD_ROOT%{_sbindir} $RPM_BUILD_ROOT%{_initrddir} \
|
|||||||
$RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
|
$RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
|
||||||
install src/dnsmasq $RPM_BUILD_ROOT%{_sbindir}/dnsmasq
|
install src/dnsmasq $RPM_BUILD_ROOT%{_sbindir}/dnsmasq
|
||||||
install dnsmasq.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/dnsmasq.conf
|
install dnsmasq.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/dnsmasq.conf
|
||||||
|
%if "%{dist}" != ".fc3"
|
||||||
install dbus/dnsmasq.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/
|
install dbus/dnsmasq.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/
|
||||||
install rpm/dnsmasq.rh $RPM_BUILD_ROOT%{_initrddir}/dnsmasq
|
%endif
|
||||||
|
install rpm/dnsmasq.init $RPM_BUILD_ROOT%{_initrddir}/dnsmasq
|
||||||
install man/dnsmasq.8 $RPM_BUILD_ROOT%{_mandir}/man8/
|
install man/dnsmasq.8 $RPM_BUILD_ROOT%{_mandir}/man8/
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -77,15 +77,22 @@ fi
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc CHANGELOG COPYING FAQ doc.html setup.html UPGRADING_to_2.0
|
%doc CHANGELOG COPYING FAQ doc.html setup.html UPGRADING_to_2.0 dbus/DBus-interface
|
||||||
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dnsmasq.conf
|
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dnsmasq.conf
|
||||||
|
%if "%{dist}" != ".fc3"
|
||||||
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dbus-1/system.d/dnsmasq.conf
|
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dbus-1/system.d/dnsmasq.conf
|
||||||
|
%endif
|
||||||
%{_initrddir}/dnsmasq
|
%{_initrddir}/dnsmasq
|
||||||
%{_sbindir}/dnsmasq
|
%{_sbindir}/dnsmasq
|
||||||
%{_mandir}/man8/dnsmasq*
|
%{_mandir}/man8/dnsmasq*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 8 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.31-1
|
||||||
|
- Removed dbus config patch (now provided upstream)
|
||||||
|
- Patched in init script (no longer provided upstream)
|
||||||
|
- Added DBus-interface to docs
|
||||||
|
|
||||||
* Tue May 2 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-4.2
|
* Tue May 2 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-4.2
|
||||||
- More upstream-recommended cleanups :)
|
- More upstream-recommended cleanups :)
|
||||||
- Killed sysconfig file (provides unneeded functionality)
|
- Killed sysconfig file (provides unneeded functionality)
|
||||||
|
Loading…
Reference in New Issue
Block a user