Fix failure to start with ENOTSOCK (#962874)
Signed-off-by: Tomas Hozza <thozza@redhat.com>
This commit is contained in:
parent
f9818256f6
commit
4b348e1002
44
dnsmasq-2.67-Fix-failure-to-start-with-ENOTSOCK.patch
Normal file
44
dnsmasq-2.67-Fix-failure-to-start-with-ENOTSOCK.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
From cfcad42ff1ddee8e64d120f18016a654152d0215 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Simon Kelley <simon@thekelleys.org.uk>
|
||||||
|
Date: Fri, 17 May 2013 11:32:03 +0100
|
||||||
|
Subject: [PATCH] Fix failure to start with ENOTSOCK
|
||||||
|
|
||||||
|
---
|
||||||
|
CHANGELOG | 6 ++++++
|
||||||
|
src/dnsmasq.c | 2 +-
|
||||||
|
2 files changed, 7 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/CHANGELOG b/CHANGELOG
|
||||||
|
index 7aa0024..48b6070 100644
|
||||||
|
--- a/CHANGELOG
|
||||||
|
+++ b/CHANGELOG
|
||||||
|
@@ -31,7 +31,13 @@ version 2.67
|
||||||
|
want to continue to bind the aliases too, you need to add
|
||||||
|
eg. --interface=eth0:0 to the config.
|
||||||
|
|
||||||
|
+ Fix "failed to set SO_BINDTODEVICE on DHCP socket: Socket
|
||||||
|
+ operation on non-socket" error on startup with
|
||||||
|
+ configurations which have exactly one --interface option
|
||||||
|
+ and do RA but _not_ DHCPv6. Thanks to Trever Adams for the
|
||||||
|
+ bug report.
|
||||||
|
|
||||||
|
+
|
||||||
|
version 2.66
|
||||||
|
Add the ability to act as an authoritative DNS
|
||||||
|
server. Dnsmasq can now answer queries from the wider 'net
|
||||||
|
diff --git a/src/dnsmasq.c b/src/dnsmasq.c
|
||||||
|
index 43b8cb1..b0f984d 100644
|
||||||
|
--- a/src/dnsmasq.c
|
||||||
|
+++ b/src/dnsmasq.c
|
||||||
|
@@ -248,7 +248,7 @@ int main (int argc, char **argv)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#if defined(HAVE_LINUX_NETWORK) && defined(HAVE_DHCP6)
|
||||||
|
- if (daemon->dhcp6)
|
||||||
|
+ if (daemon->doing_dhcp6)
|
||||||
|
bindtodevice(daemon->dhcp6fd);
|
||||||
|
#endif
|
||||||
|
}
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
11
dnsmasq.spec
11
dnsmasq.spec
@ -11,7 +11,7 @@
|
|||||||
|
|
||||||
Name: dnsmasq
|
Name: dnsmasq
|
||||||
Version: 2.67
|
Version: 2.67
|
||||||
Release: 0.1.%{?extraversion}%{?dist}
|
Release: 0.2.%{?extraversion}%{?dist}
|
||||||
Summary: A lightweight DHCP/caching DNS server
|
Summary: A lightweight DHCP/caching DNS server
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -20,6 +20,10 @@ URL: http://www.thekelleys.org.uk/dnsmasq/
|
|||||||
Source0: http://www.thekelleys.org.uk/dnsmasq/%{?extrapath}%{name}-%{version}%{?extraversion}.tar.gz
|
Source0: http://www.thekelleys.org.uk/dnsmasq/%{?extrapath}%{name}-%{version}%{?extraversion}.tar.gz
|
||||||
Source1: %{name}.service
|
Source1: %{name}.service
|
||||||
|
|
||||||
|
# Patches from upstream repo git://thekelleys.org.uk/dnsmasq.git
|
||||||
|
# commit cfcad42ff1ddee8e64d120f18016a654152d0215 - Bug #962874
|
||||||
|
Patch0: %{name}-2.67-Fix-failure-to-start-with-ENOTSOCK.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
@ -54,6 +58,8 @@ query/remove a DHCP server's leases.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?extraversion}
|
%setup -q -n %{name}-%{version}%{?extraversion}
|
||||||
|
|
||||||
|
%patch0 -p1 -b .enotsock_failure
|
||||||
|
|
||||||
# use /var/lib/dnsmasq instead of /var/lib/misc
|
# use /var/lib/dnsmasq instead of /var/lib/misc
|
||||||
for file in dnsmasq.conf.example man/dnsmasq.8 man/es/dnsmasq.8 src/config.h; do
|
for file in dnsmasq.conf.example man/dnsmasq.8 man/es/dnsmasq.8 src/config.h; do
|
||||||
sed -i 's|/var/lib/misc/dnsmasq.leases|/var/lib/dnsmasq/dnsmasq.leases|g' "$file"
|
sed -i 's|/var/lib/misc/dnsmasq.leases|/var/lib/dnsmasq/dnsmasq.leases|g' "$file"
|
||||||
@ -137,6 +143,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/dhcp_*
|
%{_mandir}/man1/dhcp_*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 17 2013 Tomas Hozza <thozza@redhat.com> - 2.67-0.2.test4
|
||||||
|
- Fix failure to start with ENOTSOCK (#962874)
|
||||||
|
|
||||||
* Wed May 15 2013 Tomas Hozza <thozza@redhat.com> - 2.67-0.1.test4
|
* Wed May 15 2013 Tomas Hozza <thozza@redhat.com> - 2.67-0.1.test4
|
||||||
- update to the latest testing release 2.67test4 (#962246)
|
- update to the latest testing release 2.67test4 (#962246)
|
||||||
- drop mergerd patches
|
- drop mergerd patches
|
||||||
|
Loading…
Reference in New Issue
Block a user