More upstream-recommended cleanups :)
This commit is contained in:
parent
a6eee8a1dc
commit
00482ddfae
@ -1,6 +1,6 @@
|
|||||||
diff -urN dnsmasq-2.30/rpm/dnsmasq.rh dnsmasq-2.30-patched/rpm/dnsmasq.rh
|
diff -urN dnsmasq-2.30/rpm/dnsmasq.rh dnsmasq-2.30-patched/rpm/dnsmasq.rh
|
||||||
--- dnsmasq-2.30/rpm/dnsmasq.rh 2006-05-02 09:35:27.000000000 -0500
|
--- dnsmasq-2.30/rpm/dnsmasq.rh 2006-04-23 08:26:21.000000000 -0500
|
||||||
+++ dnsmasq-2.30-patched/rpm/dnsmasq.rh 2006-05-02 09:48:47.000000000 -0500
|
+++ dnsmasq-2.30-patched/rpm/dnsmasq.rh 2006-05-02 11:07:16.000000000 -0500
|
||||||
@@ -2,7 +2,7 @@
|
@@ -2,7 +2,7 @@
|
||||||
#
|
#
|
||||||
# Startup script for the DNS caching server
|
# Startup script for the DNS caching server
|
||||||
@ -10,7 +10,7 @@ diff -urN dnsmasq-2.30/rpm/dnsmasq.rh dnsmasq-2.30-patched/rpm/dnsmasq.rh
|
|||||||
# description: This script starts your DNS caching server
|
# description: This script starts your DNS caching server
|
||||||
# processname: dnsmasq
|
# processname: dnsmasq
|
||||||
# pidfile: /var/run/dnsmasq.pid
|
# pidfile: /var/run/dnsmasq.pid
|
||||||
@@ -19,19 +19,10 @@
|
@@ -19,33 +19,9 @@
|
||||||
dnsmasq=/usr/sbin/dnsmasq
|
dnsmasq=/usr/sbin/dnsmasq
|
||||||
[ -f $dnsmasq ] || exit 0
|
[ -f $dnsmasq ] || exit 0
|
||||||
|
|
||||||
@ -23,17 +23,29 @@ diff -urN dnsmasq-2.30/rpm/dnsmasq.rh dnsmasq-2.30-patched/rpm/dnsmasq.rh
|
|||||||
-# change this if you want dnsmasq to cache any "hostname" or "client-hostname" from
|
-# change this if you want dnsmasq to cache any "hostname" or "client-hostname" from
|
||||||
-# a dhcpd's lease file
|
-# a dhcpd's lease file
|
||||||
-DHCP_LEASE="/var/lib/dhcp/dhcpd.leases"
|
-DHCP_LEASE="/var/lib/dhcp/dhcpd.leases"
|
||||||
-DOMAIN_SUFFIX=`dnsdomainname`
|
DOMAIN_SUFFIX=`dnsdomainname`
|
||||||
-
|
-
|
||||||
-OPTIONS=""
|
-OPTIONS=""
|
||||||
+# source /etc/sysconfig/dnsmasq if it exists
|
-
|
||||||
+[ -f /etc/sysconfig/dnsmasq ] && . /etc/sysconfig/dnsmasq
|
-if [ ! -z "${MAILHOSTNAME}" ]; then
|
||||||
|
- OPTIONS="$OPTIONS -m $MAILHOSTNAME"
|
||||||
+# apply options from /etc/sysconfig/dnsmasq if they're set
|
-fi
|
||||||
if [ ! -z "${MAILHOSTNAME}" ]; then
|
-
|
||||||
OPTIONS="$OPTIONS -m $MAILHOSTNAME"
|
-if [ ! -z "${RESOLV_CONF}" ]; then
|
||||||
|
- OPTIONS="$OPTIONS -r $RESOLV_CONF"
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
-if [ ! -z "${DHCP_LEASE}" ]; then
|
||||||
|
- OPTIONS="$OPTIONS -l $DHCP_LEASE"
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
if [ ! -z "${DOMAIN_SUFFIX}" ]; then
|
||||||
|
- OPTIONS="$OPTIONS -s $DOMAIN_SUFFIX"
|
||||||
|
+ OPTIONS="-s $DOMAIN_SUFFIX"
|
||||||
fi
|
fi
|
||||||
@@ -72,7 +63,13 @@
|
|
||||||
|
RETVAL=0
|
||||||
|
@@ -72,7 +48,13 @@
|
||||||
status dnsmasq
|
status dnsmasq
|
||||||
RETVAL=$?
|
RETVAL=$?
|
||||||
;;
|
;;
|
||||||
@ -48,20 +60,3 @@ diff -urN dnsmasq-2.30/rpm/dnsmasq.rh dnsmasq-2.30-patched/rpm/dnsmasq.rh
|
|||||||
$0 stop
|
$0 stop
|
||||||
$0 start
|
$0 start
|
||||||
RETVAL=$?
|
RETVAL=$?
|
||||||
diff -urN dnsmasq-2.30/rpm/dnsmasq.sysconfig dnsmasq-2.30-patched/rpm/dnsmasq.sysconfig
|
|
||||||
--- dnsmasq-2.30/rpm/dnsmasq.sysconfig 1969-12-31 18:00:00.000000000 -0600
|
|
||||||
+++ dnsmasq-2.30-patched/rpm/dnsmasq.sysconfig 2006-05-02 09:49:42.000000000 -0500
|
|
||||||
@@ -0,0 +1,13 @@
|
|
||||||
+# change this line if you want dnsmasq to serve an MX record for
|
|
||||||
+# the host it is running on.
|
|
||||||
+MAILHOSTNAME=""
|
|
||||||
+# change this line if you want dns to get its upstream servers from
|
|
||||||
+# somewhere other that /etc/resolv.conf
|
|
||||||
+RESOLV_CONF=""
|
|
||||||
+# change this if you want dnsmasq to cache any "hostname" or "client-hostname"
|
|
||||||
+# from a dhcpd's lease file
|
|
||||||
+# (deprecated!)
|
|
||||||
+#DHCP_LEASE="/var/lib/dhcp/dhcpd.leases"
|
|
||||||
+DOMAIN_SUFFIX=`dnsdomainname`
|
|
||||||
+# other options?
|
|
||||||
+OPTIONS=""
|
|
||||||
|
15
dnsmasq.spec
15
dnsmasq.spec
@ -1,6 +1,6 @@
|
|||||||
Name: dnsmasq
|
Name: dnsmasq
|
||||||
Version: 2.30
|
Version: 2.30
|
||||||
Release: 4%{?dist}
|
Release: 4.1%{?dist}
|
||||||
Summary: A lightweight DHCP/caching DNS server
|
Summary: A lightweight DHCP/caching DNS server
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -34,10 +34,10 @@ machines.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
#%patch0 -p1
|
||||||
%if "%{dist}" != ".fc3"
|
%if "%{dist}" != ".fc3"
|
||||||
%patch1 -p1
|
#%patch1 -p1
|
||||||
%patch2 -p1
|
#%patch2 -p1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -53,7 +53,6 @@ mkdir -p $RPM_BUILD_ROOT%{_sbindir} $RPM_BUILD_ROOT%{_initrddir} \
|
|||||||
$RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
|
$RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
|
||||||
install src/dnsmasq $RPM_BUILD_ROOT%{_sbindir}/dnsmasq
|
install src/dnsmasq $RPM_BUILD_ROOT%{_sbindir}/dnsmasq
|
||||||
install dnsmasq.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/dnsmasq.conf
|
install dnsmasq.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/dnsmasq.conf
|
||||||
install rpm/dnsmasq.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/dnsmasq
|
|
||||||
install dbus/dnsmasq.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/
|
install dbus/dnsmasq.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/
|
||||||
install rpm/dnsmasq.rh $RPM_BUILD_ROOT%{_initrddir}/dnsmasq
|
install rpm/dnsmasq.rh $RPM_BUILD_ROOT%{_initrddir}/dnsmasq
|
||||||
install man/dnsmasq.8 $RPM_BUILD_ROOT%{_mandir}/man8/
|
install man/dnsmasq.8 $RPM_BUILD_ROOT%{_mandir}/man8/
|
||||||
@ -80,7 +79,6 @@ fi
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc CHANGELOG COPYING FAQ doc.html setup.html UPGRADING_to_2.0
|
%doc CHANGELOG COPYING FAQ doc.html setup.html UPGRADING_to_2.0
|
||||||
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dnsmasq.conf
|
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dnsmasq.conf
|
||||||
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/sysconfig/dnsmasq
|
|
||||||
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dbus-1/system.d/dnsmasq.conf
|
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dbus-1/system.d/dnsmasq.conf
|
||||||
%{_initrddir}/dnsmasq
|
%{_initrddir}/dnsmasq
|
||||||
%{_sbindir}/dnsmasq
|
%{_sbindir}/dnsmasq
|
||||||
@ -88,6 +86,11 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 2 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-4.1
|
||||||
|
- More upstream-recommended cleanups :)
|
||||||
|
- Killed sysconfig file (provides unneeded functionality)
|
||||||
|
- Tweaked init script a little more
|
||||||
|
|
||||||
* Tue May 2 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-4
|
* Tue May 2 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-4
|
||||||
- Moved options out of init script and into /etc/sysconfig/dnsmasq
|
- Moved options out of init script and into /etc/sysconfig/dnsmasq
|
||||||
- Disabled DHCP_LEASE in sysconfig file, fixing bug #190379
|
- Disabled DHCP_LEASE in sysconfig file, fixing bug #190379
|
||||||
|
Loading…
Reference in New Issue
Block a user