27 lines
876 B
Diff
27 lines
876 B
Diff
From 423c987b6b14ec0a6277181ac7c038b50033296d Mon Sep 17 00:00:00 2001
|
|
From: Pavla Kratochvilova <pkratoch@redhat.com>
|
|
Date: Wed, 19 May 2021 12:58:30 +0200
|
|
Subject: [PATCH] Set top-level directory for unittest
|
|
|
|
In some build environments, the top-level directory is not added to
|
|
the sys.path and the tests fail. This fixes the issue.
|
|
---
|
|
tests/CMakeLists.txt | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
|
index b15cc62b..dedc46fd 100644
|
|
--- a/tests/CMakeLists.txt
|
|
+++ b/tests/CMakeLists.txt
|
|
@@ -1,6 +1,6 @@
|
|
ADD_TEST(
|
|
NAME test
|
|
- COMMAND ${PYTHON_EXECUTABLE} -m unittest discover -s tests
|
|
+ COMMAND ${PYTHON_EXECUTABLE} -m unittest discover -s tests -t ${PROJECT_SOURCE_DIR}
|
|
WORKING_DIRECTORY ${PROJECT_SOURCE_DIR})
|
|
|
|
# For libdnf built with sanitizers, has no effect otherwise.
|
|
--
|
|
2.35.1
|
|
|