Update dnf to 1.1.0-1
This commit is contained in:
parent
35045e3ed2
commit
ffb7937d93
1
.gitignore
vendored
1
.gitignore
vendored
@ -77,3 +77,4 @@
|
||||
/dnf-1.0.0.tar.gz
|
||||
/dnf-1.0.1.tar.gz
|
||||
/dnf-1.0.2.tar.gz
|
||||
/dnf-1.1.0.tar.gz
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff -Naur a/py3/dnf/package.py b/py3/dnf/package.py
|
||||
--- a/dnf/package.py 2015-06-09 06:46:26.000000000 -0400
|
||||
+++ b/dnf/package.py 2015-07-21 12:26:00.000000000 -0400
|
||||
@@ -164,6 +164,11 @@
|
||||
loc = self.location
|
||||
if not self.repo.local:
|
||||
loc = os.path.basename(loc)
|
||||
+ if self.baseurl:
|
||||
+ path = os.path.join(self.baseurl, self.location)
|
||||
+ if path.startswith("file://"):
|
||||
+ path = path[7:]
|
||||
+ return path
|
||||
return os.path.join(self.repo.pkgdir, loc)
|
||||
|
||||
# yum compatibility method
|
||||
|
@ -1,44 +0,0 @@
|
||||
diff --git a/dnf.spec b/dnf.spec
|
||||
index 93adc0d..aff444f 100644
|
||||
--- a/dnf.spec
|
||||
+++ b/dnf.spec
|
||||
@@ -11,7 +11,7 @@
|
||||
|
||||
Name: dnf
|
||||
Version: 1.0.2
|
||||
-Release: 1%{?snapshot}%{?dist}
|
||||
+Release: 2%{?snapshot}%{?dist}
|
||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
@@ -250,6 +250,9 @@ exit 0
|
||||
%systemd_postun_with_restart dnf-automatic.timer
|
||||
|
||||
%changelog
|
||||
+* Tue Jul 21 2015 Jan Silhan <jsilhan@redhat.com> 1.0.2-2
|
||||
+- fixed python3 syntax error from f427aa2 (Jan Silhan)
|
||||
+
|
||||
* Fri Jul 17 2015 Michal Luscon <mluscon@redhat.com> 1.0.2-1
|
||||
- give --allowerasing hint when error occurs during resolution (RhBug:1148630)
|
||||
(Jan Silhan)
|
||||
diff --git a/dnf/cli/output.py b/dnf/cli/output.py
|
||||
index c24de7c..2b1ba45 100644
|
||||
--- a/dnf/cli/output.py
|
||||
+++ b/dnf/cli/output.py
|
||||
@@ -929,7 +929,8 @@ class Output(object):
|
||||
return '\n'.join(out)
|
||||
|
||||
def _skipped_conflicts(self):
|
||||
- def is_better_version((pkg1, pkg2)):
|
||||
+ def is_better_version(same_name_pkgs):
|
||||
+ pkg1, pkg2 = same_name_pkgs
|
||||
if not pkg2 or (pkg1 and pkg1 > pkg2):
|
||||
return False
|
||||
return True
|
||||
diff --git a/rel-eng/packages/dnf b/rel-eng/packages/dnf
|
||||
index 062f380..35bf379 100644
|
||||
--- a/rel-eng/packages/dnf
|
||||
+++ b/rel-eng/packages/dnf
|
||||
@@ -1 +1 @@
|
||||
-1.0.2-1 ./
|
||||
+1.0.2-2 ./
|
@ -1,102 +0,0 @@
|
||||
diff --git a/AUTHORS b/AUTHORS
|
||||
index 3e6495b..a0ab5d2 100644
|
||||
--- a/AUTHORS
|
||||
+++ b/AUTHORS
|
||||
@@ -63,6 +63,7 @@ DNF CONTRIBUTORS
|
||||
Haïkel Guémar <haikel.guemar@gmail.com>
|
||||
Kevin Kofler <kevin.kofler@chello.at>
|
||||
Kushal Das <kushaldas@gmail.com>
|
||||
+ Matthew Miller
|
||||
Padraig Brady <P@draigBrady.com>
|
||||
Peter Hjalmarsson <kanelxake@gmail.com>
|
||||
Peter Simonyi
|
||||
diff --git a/dnf.spec b/dnf.spec
|
||||
index aff444f..070c8ee 100644
|
||||
--- a/dnf.spec
|
||||
+++ b/dnf.spec
|
||||
@@ -11,7 +11,7 @@
|
||||
|
||||
Name: dnf
|
||||
Version: 1.0.2
|
||||
-Release: 2%{?snapshot}%{?dist}
|
||||
+Release: 3%{?snapshot}%{?dist}
|
||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
@@ -250,6 +250,11 @@ exit 0
|
||||
%systemd_postun_with_restart dnf-automatic.timer
|
||||
|
||||
%changelog
|
||||
+* Fri Jul 31 2015 Michal Luscon <mluscon@redhat.com> 1.0.2-3
|
||||
+- Fix regression in group list command introduced by 02c3cc3 (Adam Salih)
|
||||
+- AUTHORS: updated (Jan Silhan)
|
||||
+- stop saying "experimental" (Matthew Miller)
|
||||
+
|
||||
* Tue Jul 21 2015 Jan Silhan <jsilhan@redhat.com> 1.0.2-2
|
||||
- fixed python3 syntax error from f427aa2 (Jan Silhan)
|
||||
|
||||
diff --git a/dnf/cli/commands/group.py b/dnf/cli/commands/group.py
|
||||
index fed75fe..de55610 100644
|
||||
--- a/dnf/cli/commands/group.py
|
||||
+++ b/dnf/cli/commands/group.py
|
||||
@@ -164,14 +164,15 @@ class GroupCommand(commands.Command):
|
||||
userlist = None # Match everything...
|
||||
|
||||
errs = False
|
||||
- for group in userlist:
|
||||
- in_group = len(self.base.comps.groups_by_pattern(group)) > 0
|
||||
- in_environment = len(self.base.comps.environments_by_pattern(group)) > 0
|
||||
- if not in_group and not in_environment:
|
||||
- logger.error(_('Warning: No groups match:\n %s'), group)
|
||||
- errs = True
|
||||
- if errs:
|
||||
- return 0, []
|
||||
+ if userlist is not None:
|
||||
+ for group in userlist:
|
||||
+ in_group = len(self.base.comps.groups_by_pattern(group)) > 0
|
||||
+ in_environment = len(self.base.comps.environments_by_pattern(group)) > 0
|
||||
+ if not in_group and not in_environment:
|
||||
+ logger.error(_('Warning: No groups match:\n %s'), group)
|
||||
+ errs = True
|
||||
+ if errs:
|
||||
+ return 0, []
|
||||
|
||||
env_inst, env_avail = self._environment_lists(userlist)
|
||||
installed, available = self._group_lists(uservisible, userlist)
|
||||
diff --git a/doc/index.rst b/doc/index.rst
|
||||
index e3f246d..d023efc 100644
|
||||
--- a/doc/index.rst
|
||||
+++ b/doc/index.rst
|
||||
@@ -15,9 +15,9 @@
|
||||
License and may only be used or replicated with the express permission of
|
||||
Red Hat, Inc.
|
||||
|
||||
-###################################
|
||||
- DNF, Experimental Yum Replacement
|
||||
-###################################
|
||||
+#############################################
|
||||
+ DNF, the next-generation replacement for Yum
|
||||
+#############################################
|
||||
|
||||
Contents:
|
||||
|
||||
diff --git a/rel-eng/packages/dnf b/rel-eng/packages/dnf
|
||||
index 35bf379..d616dda 100644
|
||||
--- a/rel-eng/packages/dnf
|
||||
+++ b/rel-eng/packages/dnf
|
||||
@@ -1 +1 @@
|
||||
-1.0.2-2 ./
|
||||
+1.0.2-3 ./
|
||||
diff --git a/rel-eng/tito.props b/rel-eng/tito.props
|
||||
index 5ddebd5..cdb345a 100644
|
||||
--- a/rel-eng/tito.props
|
||||
+++ b/rel-eng/tito.props
|
||||
@@ -1,6 +1,6 @@
|
||||
[buildconfig]
|
||||
-builder = tito.builder.Builder
|
||||
-tagger = tito.tagger.VersionTagger
|
||||
+builder = tito.distributionbuilder.DistributionBuilder
|
||||
+tagger = tito.tagger.ReleaseTagger
|
||||
changelog_do_not_remove_cherrypick = 1
|
||||
changelog_format = %s (%an)
|
||||
|
60
dnf.spec
60
dnf.spec
@ -1,4 +1,4 @@
|
||||
%global hawkey_version 0.5.9
|
||||
%global hawkey_version 0.6.0
|
||||
%global librepo_version 1.7.16
|
||||
%global libcomps_version 0.1.6
|
||||
%global rpm_version 4.12.0
|
||||
@ -10,8 +10,8 @@
|
||||
%global py3pluginpath %{python3_sitelib}/dnf-plugins
|
||||
|
||||
Name: dnf
|
||||
Version: 1.0.2
|
||||
Release: 3%{?snapshot}%{?dist}
|
||||
Version: 1.1.0
|
||||
Release: 1%{?snapshot}%{?dist}
|
||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
@ -22,9 +22,6 @@ URL: https://github.com/rpm-software-management/dnf
|
||||
# ./archive
|
||||
# tarball will be generated in $HOME/rpmbuild/sources/
|
||||
Source0: http://rpm-software-management.fedorapeople.org/dnf-%{version}.tar.gz
|
||||
Patch0: dnf-1.0.2-1-to-dnf-1.0.2-2.patch
|
||||
Patch1: dnf-1.0.2-2-to-dnf-1.0.2-3.patch
|
||||
Patch2: baseurl.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gettext
|
||||
@ -122,9 +119,6 @@ Alternative CLI to "dnf upgrade" suitable for automatic, regular execution.
|
||||
|
||||
%prep
|
||||
%setup -q -n dnf-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
rm -rf py3
|
||||
mkdir ../py3
|
||||
cp -a . ../py3/
|
||||
@ -256,13 +250,55 @@ exit 0
|
||||
%systemd_postun_with_restart dnf-automatic.timer
|
||||
|
||||
%changelog
|
||||
* Mon Aug 10 2015 Michal Luscon <mluscon@redhat.com> 1.1.0-1
|
||||
- print skipped pkg with broken deps too (Related:RhBug:1210445) (Jan Silhan)
|
||||
- history: set commands output as default (RhBug:1218401) (Michal Luscon)
|
||||
- Update es.po. save:guardar -> save:ahorrar (Máximo Castañeda)
|
||||
- cosmetic: option arg in Base.*install is replaced with strict (Jan Silhan)
|
||||
- group: don't fail on first non-existing group (Jan Silhan)
|
||||
- install: skips local pkgs of lower version when strict=0
|
||||
(Related:RhBug:1227952) (Jan Silhan)
|
||||
- install: skip broken/conflicting packages in groups when strict=0 (Jan
|
||||
Silhan)
|
||||
- install: skip broken/conflicting packages when strict=0 (Jan Silhan)
|
||||
- implemented `strict` config option working in install cmd (RhBug:1197456)
|
||||
(Jan Silhan)
|
||||
- fixed 'dnf --quiet repolist' lack of output (RhBug:1236310) (Nick Coghlan)
|
||||
- Add support for MIPS architecture (Michal Toman)
|
||||
- package: respect baseurl attribute in localPkg() (RhBug:1219638) (Michal
|
||||
Luscon)
|
||||
- Download error message is not written on the same line as progress bar
|
||||
anymore (RhBug: 1224248) (Adam Salih)
|
||||
- dnf downgrade does not try to downgrade not installed packages (RhBug:
|
||||
1243501) (max9631)
|
||||
- pkgs not installed due to rpm error are reported (RhBug:1207981) (Adam Salih)
|
||||
- dnf install checks availability of all given packages (RhBug:1208918) (Adam
|
||||
Salih)
|
||||
- implemented install_weak_deps config option (RhBug:1221635) (Jan Silhan)
|
||||
- ignore SIGPIPE (RhBug:1236306) (Michael Mraka)
|
||||
- always add LoggingTransactionDisplay to the list of transaction displays
|
||||
(RhBug:1234639) (Radek Holy)
|
||||
- Add missing FILES section (RhBug: 1225237) (Adam Salih)
|
||||
- doc: Add yum vs dnf hook information (RhBug:1244486) (Parag Nemade)
|
||||
- doc: clarify the expected type of the do_transactions's display parameter
|
||||
(Radek Holy)
|
||||
- apichange: add dnf.cli.demand.DemandSheet.transaction_display (Radek Holy)
|
||||
- apichange: add dnf.callback.TransactionProgress (Radek Holy)
|
||||
- move the error output from TransactionDisplay into a separate class (Radek
|
||||
Holy)
|
||||
- rename TransactionDisplay.errorlog to TransactionDisplay.error (Radek Holy)
|
||||
- report package verification as a regular RPM transaction event (Radek Holy)
|
||||
- rename TransactionDisplay.event to TransactionDisplay.progress (Radek Holy)
|
||||
- apichange: deprecate dnf.callback.LoggingTransactionDisplay (Radek Holy)
|
||||
- use both CliTransactionDisplay and demands.transaction_display (Radek Holy)
|
||||
- apichange: accept multiple displays in do_transaction (Radek Holy)
|
||||
- support multiple displays in RPMTransaction (Radek Holy)
|
||||
|
||||
* Fri Jul 31 2015 Michal Luscon <mluscon@redhat.com> 1.0.2-3
|
||||
- Fix regression in group list command introduced by 02c3cc3 (Adam Salih)
|
||||
- AUTHORS: updated (Jan Silhan)
|
||||
- stop saying "experimental" (Matthew Miller)
|
||||
|
||||
* Tue Jul 21 2015 Dennis Gilmore <dennis@ausil.us> 1.0.2-2.1
|
||||
- add patch to respact baseurl in metadata rhbz#1245286
|
||||
|
||||
* Tue Jul 21 2015 Jan Silhan <jsilhan@redhat.com> 1.0.2-2
|
||||
- fixed python3 syntax error from f427aa2 (Jan Silhan)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user