Update to 4.2.7
This commit is contained in:
parent
acedef08fb
commit
ff341af41b
1
.gitignore
vendored
1
.gitignore
vendored
@ -128,3 +128,4 @@
|
||||
/dnf-4.2.1.tar.gz
|
||||
/dnf-4.2.2.tar.gz
|
||||
/dnf-4.2.5.tar.gz
|
||||
/dnf-4.2.7.tar.gz
|
||||
|
37
0007-Revert-consequences-of-Fail-Safe-mechanism.patch
Normal file
37
0007-Revert-consequences-of-Fail-Safe-mechanism.patch
Normal file
@ -0,0 +1,37 @@
|
||||
From a8a3cf4247fe374855e1ee292eb2b4bda835f690 Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Mracek <jmracek@redhat.com>
|
||||
Date: Wed, 3 Jul 2019 12:37:57 +0200
|
||||
Subject: [PATCH] Revert consequences of Fail-Safe mechanism
|
||||
|
||||
---
|
||||
dnf/db/group.py | 2 +-
|
||||
doc/modularity.rst | 3 +--
|
||||
2 files changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/dnf/db/group.py b/dnf/db/group.py
|
||||
index 5082c7b..065d362 100644
|
||||
--- a/dnf/db/group.py
|
||||
+++ b/dnf/db/group.py
|
||||
@@ -331,7 +331,7 @@ class RPMTransaction(object):
|
||||
else:
|
||||
raise RuntimeError("TransactionItemAction not handled: %s" % tsi.action)
|
||||
if modular_problems:
|
||||
- raise dnf.exceptions.Error(_("No available modular metadata for modular package"))
|
||||
+ logger.critical(_("No available modular metadata for modular package"))
|
||||
|
||||
return ts
|
||||
|
||||
diff --git a/doc/modularity.rst b/doc/modularity.rst
|
||||
index 83b1227..a5d0975 100644
|
||||
--- a/doc/modularity.rst
|
||||
+++ b/doc/modularity.rst
|
||||
@@ -99,5 +99,4 @@ Orphaned modular packages
|
||||
=========================
|
||||
All packages that are built as a part of a module have ``%{modularitylabel}`` RPM header set.
|
||||
If such package becomes part of RPM transaction and cannot be associated with any available
|
||||
-modulemd, DNF prevents from getting it on the system (package is available, but cannot be
|
||||
-installed, upgraded, etc.)
|
||||
+modulemd, DNF logs the issue as critical problem.
|
||||
--
|
||||
libgit2 0.27.8
|
||||
|
38
dnf.spec
38
dnf.spec
@ -1,5 +1,5 @@
|
||||
# default dependencies
|
||||
%global hawkey_version 0.31.0
|
||||
%global hawkey_version 0.35.1
|
||||
%global libcomps_version 0.1.8
|
||||
%global libmodulemd_version 1.4.0
|
||||
%global rpm_version 4.14.0
|
||||
@ -79,8 +79,8 @@
|
||||
It supports RPMs, modules and comps groups & environments.
|
||||
|
||||
Name: dnf
|
||||
Version: 4.2.5
|
||||
Release: 2%{?dist}
|
||||
Version: 4.2.7
|
||||
Release: 1%{?dist}
|
||||
Summary: %{pkg_summary}
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
@ -92,6 +92,9 @@ Patch0003: 0003-history-Dont-store-failed-transactions-as-succeeded.patch
|
||||
Patch0004: 0004-transaction-Add-RPMCALLBACK_INST_STARTSTOP-callback-handlers.patch
|
||||
Patch0005: 0005-Change-synchronization-of-rpm-transaction-to-swdb.patch
|
||||
Patch0006: 0006-Add-detailed-debug-login-for-swdbrpm-transaction.patch
|
||||
# Temporary patch to not fail on modular RPMs without modular metadata
|
||||
# until the infrastructure is ready
|
||||
Patch0007: 0007-Revert-consequences-of-Fail-Safe-mechanism.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
@ -161,12 +164,14 @@ Common data and configuration files for DNF
|
||||
%package -n %{yum_subpackage_name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Summary: %{pkg_summary}
|
||||
%if 0%{?fedora}
|
||||
%if 0%{?fedora} >= 31
|
||||
Provides: %{name}-yum = %{version}-%{release}
|
||||
Obsoletes: %{name}-yum < %{version}-%{release}
|
||||
%else
|
||||
Conflicts: yum < 3.4.3-505
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%description -n %{yum_subpackage_name}
|
||||
%{pkg_description}
|
||||
@ -405,6 +410,7 @@ ln -sr %{buildroot}%{confdir}/vars %{buildroot}%{_sysconfdir}/yum/vars
|
||||
%endif
|
||||
%{_mandir}/man8/%{name}.8*
|
||||
%{_mandir}/man8/yum2dnf.8*
|
||||
%{_mandir}/man7/dnf.modularity.7*
|
||||
%{_unitdir}/%{name}-makecache.service
|
||||
%{_unitdir}/%{name}-makecache.timer
|
||||
%{_var}/cache/%{name}/
|
||||
@ -490,7 +496,7 @@ ln -sr %{buildroot}%{confdir}/vars %{buildroot}%{_sysconfdir}/yum/vars
|
||||
%files automatic
|
||||
%{_bindir}/%{name}-automatic
|
||||
%config(noreplace) %{confdir}/automatic.conf
|
||||
%{_mandir}/man8/%{name}.automatic.8*
|
||||
%{_mandir}/man8/%{name}-automatic.8*
|
||||
%{_unitdir}/%{name}-automatic.service
|
||||
%{_unitdir}/%{name}-automatic.timer
|
||||
%{_unitdir}/%{name}-automatic-notifyonly.service
|
||||
@ -506,6 +512,30 @@ ln -sr %{buildroot}%{confdir}/vars %{buildroot}%{_sysconfdir}/yum/vars
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jul 04 2019 Pavla Kratochvilova <pkratoch@redhat.com> - 4.2.7-1
|
||||
- Update to 4.2.7
|
||||
- librepo: Turn on debug logging only if debuglevel is greater than 2
|
||||
(RhBug:1355764,1580022)
|
||||
- Fix issues with terminal hangs when attempting bash completion
|
||||
(RhBug:1702854)
|
||||
- Rename man page from dnf.automatic to dnf-automatic to match command name
|
||||
- [provides] Enhanced detecting of file provides (RhBug:1702621)
|
||||
- [provides] Sort the output packages alphabetically
|
||||
- Set default to skip_if_unavailable=false (RhBug:1679509)
|
||||
- Fix package reinstalls during yum module remove (RhBug:1700529)
|
||||
- Fail when "-c" option is given nonexistent file (RhBug:1512457)
|
||||
- Reuse empty lock file instead of stopping dnf (RhBug:1581824)
|
||||
- Propagate comps 'default' value correctly (RhBug:1674562)
|
||||
- Better search of provides in /(s)bin/ (RhBug:1657993)
|
||||
- Add detection for armv7hcnl (RhBug:1691430)
|
||||
- Fix group install/upgrade when group is not available (RhBug:1707624)
|
||||
- Report not matching plugins when using --enableplugin/--disableplugin
|
||||
(RhBug:1673289) (RhBug:1467304)
|
||||
- Add support of modular FailSafe (RhBug:1623128) (temporarily with warnings
|
||||
instead of errors when installing modular RPMs without modular metadata)
|
||||
- Replace logrotate with build-in log rotation for dnf.log and dnf.rpm.log
|
||||
(RhBug:1702690)
|
||||
|
||||
* Thu Jun 27 2019 Pavla Kratochvilova <pkratoch@redhat.com> - 4.2.5-2
|
||||
- Backport patches to enhance synchronization of rpm transaction to swdb
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dnf-4.2.5.tar.gz) = 3366a39150111b04b3e1d792dabf21f8dae98d0ee3f5e67580510bb12846a109f45945e5655c708f3440c763b26fa1b27e9efd1347194ace2eac77a0201adf11
|
||||
SHA512 (dnf-4.2.7.tar.gz) = e586365a34ac49ba7be31fb353b96965a8452df5dd15c99040393deb6d0eb67b53b24585d701f4a46031769271eca3bfa3d9ce2058d30772c603a3206db87063
|
||||
|
Loading…
Reference in New Issue
Block a user